当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 16.04lts 升级libvlccore9出错,求教如何解决?
帖子发表于 : 2018-01-03 14:55 

注册: 2008-04-14 19:35
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
附件:
崩溃报告_999.png
崩溃报告_999.png [ 74.27 KiB | 被浏览 644 次 ]

软件更新时出现如图所示的错误,请大家赐教。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 16.04lts 升级libvlccore9出错,求教如何解决?
帖子发表于 : 2018-01-03 15:22 
头像

注册: 2011-03-20 13:12
帖子: 4552
地址: 山东省寿光县
系统: Debian
送出感谢: 106
接收感谢: 1009
您使用了第三方软件源的 vlc。该第三方软件源并没有很好地处理软件包升级过程中的替换问题,导致出现错误。您可以尝试在命令行下使用 apt-get 升级,加入参数 -o Dpkg::Options::="--force-overwrite" 令其强制替换。或停止使用第三方软件源的 vlc。


_________________
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 16.04lts 升级libvlccore9出错,求教如何解决?
帖子发表于 : 2018-01-03 16:17 
头像

注册: 2007-07-14 20:45
帖子: 1307
送出感谢: 68
接收感谢: 38
vickycq 写道:
您使用了第三方软件源的 vlc。该第三方软件源并没有很好地处理软件包升级过程中的替换问题,导致出现错误。您可以尝试在命令行下使用 apt-get 升级,加入参数 -o Dpkg::Options::="--force-overwrite" 令其强制替换。或停止使用第三方软件源的 vlc。



厉害,这是怎么看出来的?


_________________
开源、共享、自由

微信号非公众号:xfiles_sky

用手机点击这里有奇迹发生,其他无效


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 16.04lts 升级libvlccore9出错,求教如何解决?
帖子发表于 : 2018-01-04 11:48 

注册: 2009-08-04 16:33
帖子: 17898
送出感谢: 21
接收感谢: 1922
引用:
这是怎么看出来的?

1. 你是指這句話 ?
引用:
您使用了第三方软件源的 vlc

2. 如果是
2-1. 猜測
引用:
崩溃报告_999.png

裡面的軟件包 libvlccore9 版本編號含有 --git-- 字串
跟 Ubuntu 的 libvlccore9 版本編號 不一樣
2-2. https://packages.ubuntu.com/bionic/libvlccore9
套件: libvlccore9 (3.0.0~rc4-1ubuntu1)



_________________
评价: 3.7% 九天星
 
页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译