16.04lts 升级libvlccore9出错,求教如何解决?

系统安装、升级讨论
回复
bigwyvern
帖子: 23
注册时间: 2008-04-14 19:35
送出感谢: 0
接收感谢: 0

16.04lts 升级libvlccore9出错,求教如何解决?

#1

帖子 bigwyvern » 2018-01-03 14:55

崩溃报告_999.png
软件更新时出现如图所示的错误,请大家赐教。
头像
vickycq
论坛版主
帖子: 4507
注册时间: 2011-03-20 13:12
系统: Debian
来自: 山东省寿光县
送出感谢: 100 次
接收感谢: 994 次
联系:

Re: 16.04lts 升级libvlccore9出错,求教如何解决?

#2

帖子 vickycq » 2018-01-03 15:22

您使用了第三方软件源的 vlc。该第三方软件源并没有很好地处理软件包升级过程中的替换问题,导致出现错误。您可以尝试在命令行下使用 apt-get 升级,加入参数 -o Dpkg::Options::="--force-overwrite" 令其强制替换。或停止使用第三方软件源的 vlc。
Debian 中文论坛 - forums.debiancn.org
欢迎所有 Debian GNU/Linux 用户
头像
九天星
帖子: 1333
注册时间: 2007-07-14 20:45
送出感谢: 67 次
接收感谢: 38 次

Re: 16.04lts 升级libvlccore9出错,求教如何解决?

#3

帖子 九天星 » 2018-01-03 16:17

vickycq 写了:您使用了第三方软件源的 vlc。该第三方软件源并没有很好地处理软件包升级过程中的替换问题,导致出现错误。您可以尝试在命令行下使用 apt-get 升级,加入参数 -o Dpkg::Options::="--force-overwrite" 令其强制替换。或停止使用第三方软件源的 vlc。

厉害,这是怎么看出来的?
poloshiao
论坛版主
帖子: 18115
注册时间: 2009-08-04 16:33
送出感谢: 21 次
接收感谢: 1932 次

Re: 16.04lts 升级libvlccore9出错,求教如何解决?

#4

帖子 poloshiao » 2018-01-04 11:48

这是怎么看出来的?
1. 你是指這句話 ?
您使用了第三方软件源的 vlc
2. 如果是
2-1. 猜測
崩溃报告_999.png
裡面的軟件包 libvlccore9 版本編號含有 --git-- 字串
跟 Ubuntu 的 libvlccore9 版本編號 不一樣
2-2. https://packages.ubuntu.com/bionic/libvlccore9
套件: libvlccore9 (3.0.0~rc4-1ubuntu1)
这些用户感谢了作者 poloshiao 于这个帖子:
九天星 (2018-01-04 12:04)
评价: 3.7%
回复

回到 “系统安装和升级”