当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]迫切求助:fcitx无法使用
帖子发表于 : 2008-01-21 3:08 

注册: 2008-01-19 23:47
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
原来的scim在qterm等程序下不能输入中文,前几天发了帖子,把症状都贴出来了,可以没人搭理,只好又换fcitx,可是还是不行。

装上fcitx之后,输入法那里就是灰的。其他像GBK,简、繁体切换的地方,点了之后都可以变亮,就是输入法那里一直是灰的。配置了/etc/X11/xinit/xinput.d/fcitx也不行,配置~/.bashrc也不行,用im-switch -s fcitx也不行。

哪位可以帮帮忙?一直折腾输入法,好多天了,要崩溃了。:-(


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-01-21 6:51 
头像

注册: 2005-12-10 17:36
帖子: 336
地址: 北京市海淀区上地十街辉煌国际
送出感谢: 0 次
接收感谢: 0 次
最近也遇到了fcitx 的问题呢,先是 firefox突然不能输入中文了,然后就把fcitx卸载,同时把装中文支持时安装的scim 也删除。再接着就自己编译安装fcitx 3.5 还是没办法输入,卸载1之。再接着再装scim-pinyin,装好后,也没办法设置成default,每次都要右键选择下x input method。但是firefox 里还是不能输入呢。真想重装系统了呢。郁闷~~~到底出了什么问题呢


_________________
Laptop:HP Compaq Presario V3210AU
OS:Gentoo openbox+stalonetray+rox-filer+gmrun+mplayer+firefox+ibus+sonata+tilda
Phone:Orange Dopod 838+ SPV C600
OS:Windows Mobile 6.1


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-01-21 9:52 

注册: 2006-07-09 12:22
帖子: 1331
地址: 南京
送出感谢: 0 次
接收感谢: 1
FCITX需要CTYPE为zh_CN的locale支持,搜索一个论坛。wiki里也有。


最后由 aBiNg 编辑于 2008-01-21 13:38,总共编辑了 1 次

页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-01-21 12:38 
头像

注册: 2005-11-06 1:51
帖子: 1795
地址: 七彩云世界
送出感谢: 0 次
接收感谢: 0 次
我一直在用fcitx 在kde3 /和kde4中。
不知道1.2 楼的兄弟。到底有什么样的错误。不如先 pkill fcitx 。
从终端 打开 fcitx ,看看有什么样的报错消息。!


_________________
佛出寺,求索真世界 For_Truth:Free_Open_Share
OPEN GPG KEY:03D18D95


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-01-21 15:55 

注册: 2008-01-19 23:47
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
从终端打开fcitx很正常,没有任何出错信息,但是就是输入法的地方是灰的,但是仍然可以切换拼音、五笔、双拼之类的输入法,就是不能用

我的locale如下去,应该是对的把,郁闷死了~~~除了重装系统还有没有什么解决办法,只要能正常输入就行了。
LANG=zh_CN.UTF-8
LC_CTYPE="zh_CN.utf-8 "
LC_NUMERIC="zh_CN.utf-8 "
LC_TIME="zh_CN.utf-8 "
LC_COLLATE="zh_CN.utf-8 "
LC_MONETARY="zh_CN.utf-8 "
LC_MESSAGES="zh_CN.utf-8 "
LC_PAPER="zh_CN.utf-8 "
LC_NAME="zh_CN.utf-8 "
LC_ADDRESS="zh_CN.utf-8 "
LC_TELEPHONE="zh_CN.utf-8 "
LC_MEASUREMENT="zh_CN.utf-8 "
LC_IDENTIFICATION="zh_CN.utf-8 "
LC_ALL=zh_CN.utf-8


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-01-21 17:59 
头像

注册: 2006-06-01 11:01
帖子: 182
送出感谢: 0 次
接收感谢: 0 次
ctrl+space


_________________
find,sed,awk


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-01-21 18:01 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
kunkuncn 写道:
从终端打开fcitx很正常,没有任何出错信息,但是就是输入法的地方是灰的,但是仍然可以切换拼音、五笔、双拼之类的输入法,就是不能用

我的locale如下去,应该是对的把,郁闷死了~~~除了重装系统还有没有什么解决办法,只要能正常输入就行了。
LANG=zh_CN.UTF-8
LC_CTYPE="zh_CN.utf-8 "
LC_NUMERIC="zh_CN.utf-8 "
LC_TIME="zh_CN.utf-8 "
LC_COLLATE="zh_CN.utf-8 "
LC_MONETARY="zh_CN.utf-8 "
LC_MESSAGES="zh_CN.utf-8 "
LC_PAPER="zh_CN.utf-8 "
LC_NAME="zh_CN.utf-8 "
LC_ADDRESS="zh_CN.utf-8 "
LC_TELEPHONE="zh_CN.utf-8 "
LC_MEASUREMENT="zh_CN.utf-8 "
LC_IDENTIFICATION="zh_CN.utf-8 "
LC_ALL=zh_CN.utf-8


错的 , 应该是这样
代码:
LANG=zh_CN.UTF-8
LANGUAGE=zh_CN:zh:en_US:en
LC_CTYPE="zh_CN.UTF-8"
LC_NUMERIC="zh_CN.UTF-8"
LC_TIME="zh_CN.UTF-8"
LC_COLLATE="zh_CN.UTF-8"
LC_MONETARY="zh_CN.UTF-8"
LC_MESSAGES="zh_CN.UTF-8"
LC_PAPER="zh_CN.UTF-8"
LC_NAME="zh_CN.UTF-8"
LC_ADDRESS="zh_CN.UTF-8"
LC_TELEPHONE="zh_CN.UTF-8"
LC_MEASUREMENT="zh_CN.UTF-8"
LC_IDENTIFICATION="zh_CN.UTF-8"
LC_ALL=


代码:
XMODIFIERS="@im=fcitx"
XIM=fcitx
XIM_PROGRAM=/usr/bin/fcitx
XIM_ARGS=""
GTK_IM_MODULE=XIM
QT_IM_MODULE=XIM
DEPENDS="fcitx"


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-01-21 21:15 

注册: 2008-01-19 23:47
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
问题终于解决拉!

把locale中小写大utf-8改成了大写大UTF-8,然后又把/usr/lib/gtk-2.0/2.10.0/immodule-files.d中libgtk2.0-0.immodules最后一行改成
"xim" "X Input Method" "gtk20" "/usr/share/locale" "ko:ja:th:zh"
原来是
"xim" "X Input Method" "gtk20" "/usr/share/locale" "en:ko:ja:th:zh"
即可

不知道到底是locale是小写的原因,还是libgtk2.0-0.immudules的原因,总之非常感谢大家拉!!


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-01-21 21:17 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
小写的原因

代码:
$ cat /usr/lib/gtk-2.0/2.10.0/immodule-files.d/libgtk2.0-0.immodules | grep xim
"/usr/lib/gtk-2.0/2.10.0/immodules/im-xim.so"
"xim" "X Input Method" "gtk20" "/usr/share/locale" "ko:ja:th:zh"


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-01-22 19:54 

注册: 2006-06-09 9:37
帖子: 99
送出感谢: 0 次
接收感谢: 0 次
标记一下,前几天也是这个问题,不知道怎么解决,后来只有重装了系统 :cry:


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-01-22 21:25 
头像

注册: 2007-02-14 18:05
帖子: 86
地址: 上海
送出感谢: 0 次
接收感谢: 0 次
thx a lot


_________________
Keep It Simple Stupid
@ghosTM55


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-03-14 21:55 
头像

注册: 2007-04-14 11:17
帖子: 1035
送出感谢: 0 次
接收感谢: 2
帖子虽然老了点,但是看看还是很有实用价值的
我安装fcitx后也不能实用,和5楼的情况一样,最后在修改/etc/X11/Xsession.d/95xinput-fcitx为就一切OK了
export LC_ALL=zh_CN.UTF-8
export XMODIFIERS=@im=fcitx;
export GTK_IM_MODULE=fcitx;
fcitx &


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-03-15 9:27 

注册: 2006-10-24 21:26
帖子: 25
送出感谢: 0 次
接收感谢: 1
前面的招儿都不好使,只有12楼的对我有用。不过还是要谢谢前面的兄弟们,当然最感谢的是12楼的。


页首
 用户资料  
 
14 楼 
 文章标题 : Re: [问题]迫切求助:fcitx无法使用
帖子发表于 : 2010-05-04 20:00 

注册: 2009-10-28 12:49
帖子: 39
送出感谢: 0 次
接收感谢: 0 次
我都不好使 :em20


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译