当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 59 篇帖子 ]  前往页数 1, 2, 3, 4  下一页
作者 内容
1 楼 
 文章标题 : fitx 中文输入法---一种新的输入法选择(2008-05-2更新)
帖子发表于 : 2008-03-09 22:31 

注册: 2006-09-07 22:51
帖子: 849
送出感谢: 0 次
接收感谢: 0 次
一种新的基于scim-python输入法
我打了deb的包,至于rpm的包还看情况了.
关于fitx可以看
http://code.google.com/p/fitx/
下载地址:
http://www.machome.com.cn/attachments/f ... 1_i386.deb
http://www.machome.com.cn/attachments/f ... 0_i386.deb
http://ftp.ubuntu.org.cn/home/wkt/deb/(建议用这里的,因为这个最新)
下载后.
$cd downpath/
$sudo dpkg -i fitx_*
$sudo dpkg -i scim-python_*(ubuntu极有可能不用这一步)
$sudo apt-get install -f
关于打包的问题可以直接回复.
关于fitx本身请到http://code.google.com/p/fitx/issues/list发帖
因为我只打包,不是作者.
注意:
这里的scim-python禁止了起内置的输入法。
因为我打scim-python的deb包仅为fitx提供依赖。
scim-python的deb包也好像已经有人打了。
-------2008-05-2更新原因:
scim-python 0.1.11发布了,我重新打包
-------2008-03-14更新原因:
scim-python 0.1.10发布
fitx代码有改动!


_________________
blog:http://wkt55555.blog.163.com/


最后由 wkt 编辑于 2008-05-02 9:28,总共编辑了 4 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-03-10 0:06 
头像

注册: 2006-09-12 19:44
帖子: 654
地址: whu
送出感谢: 0 次
接收感谢: 0 次
fitx 为什么还要使用 scim-python

另外 发行版有要求吗 我的ubuntu 6.06 能用吗


_________________
linux 学习记录 你的 我的 大家的

http://wyg1258.cublog.cn


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-03-10 9:05 

注册: 2006-09-07 22:51
帖子: 849
送出感谢: 0 次
接收感谢: 0 次
wyg1258 写道:
fitx 为什么还要使用 scim-python

另外 发行版有要求吗 我的ubuntu 6.06 能用吗

呵呵,两边都问!!


_________________
blog:http://wkt55555.blog.163.com/


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-03-10 12:30 
头像

注册: 2007-09-26 17:23
帖子: 385
地址: 云南-香格里拉
送出感谢: 0 次
接收感谢: 1
可以指点如何打包的么?
我曾经用checkinstall准备给fitx打包。
但是失败了
源码编译安装都没问题了


_________________
自打用上ubuntu,我决定做一个不盗版的好公民


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-03-10 12:34 
头像

注册: 2007-09-26 17:23
帖子: 385
地址: 云南-香格里拉
送出感谢: 0 次
接收感谢: 1
wyg1258 写道:
fitx 为什么还要使用 scim-python

另外 发行版有要求吗 我的ubuntu 6.06 能用吗


估计对版本有要求,至少依赖要满足一定的版本。
我7.10中很多依赖版本都不满足要求
代码:
sudo dpkg -i fitx_0.0.1_i386.deb
[sudo] password for yangyu:
选中了曾被取消选择的软件包 fitx。
(正在读取数据库 ... 系统当前总共安装有 173337 个文件和目录。)
正在解压缩 fitx (从 fitx_0.0.1_i386.deb) ...
dpkg:依赖关系问题使得 fitx 的配置工作不能继续:
 fitx 依赖于 gnustep-base-runtime (>= 1.14.1);然而:
系统中 gnustep-base-runtime 的版本为 1.13.0-7。
 fitx 依赖于 libc6 (>= 2.7-1);然而:
系统中 libc6 的版本为 2.6.1-1ubuntu10。
 fitx 依赖于 libgnustep-base1.14 (>= 1.14.1);然而:
  未曾安装软件包“libgnustep-base1.14”。
 fitx 依赖于 libobjc2 (>= 4.2.1);然而:
  未曾安装软件包“libobjc2”。
 fitx 依赖于 libsqlite3-0 (>= 3.5.6);然而:
系统中 libsqlite3-0 的版本为 3.4.2-1build1。
 fitx 依赖于 libssl0.9.8 (>= 0.9.8f-5);然而:
系统中 libssl0.9.8 的版本为 0.9.8e-5ubuntu3.1。
 fitx 依赖于 scim-python;然而:
  未曾安装软件包“scim-python”。
dpkg:处理 fitx (--install)时出错:
 依赖关系问题 - 仍未被配置


_________________
自打用上ubuntu,我决定做一个不盗版的好公民


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-03-10 12:36 
头像

注册: 2006-03-25 10:36
帖子: 1233
送出感谢: 0 次
接收感谢: 0 次
打包的大侠,赞一个
作者,赞一个!


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-03-10 13:20 

注册: 2007-03-08 19:12
帖子: 161
送出感谢: 0 次
接收感谢: 0 次
我原来已经装了scim-python,再装这两个deb就装不上了。
fitx比起scim-python有什么改进?


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-03-10 14:46 
头像

注册: 2007-05-06 2:46
帖子: 15634
送出感谢: 0 次
接收感谢: 2
在 Leopard 里确实和WIN下的搜狗一样好使


:lol:


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-03-10 17:09 
头像

注册: 2007-04-23 16:41
帖子: 238
地址: 给你的爱一直很安静
送出感谢: 0 次
接收感谢: 0 次
比较讨厌scim
我现在的fcitx比较稳定
不想换来换去的


_________________
图片


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-03-10 18:12 

注册: 2006-09-07 22:51
帖子: 849
送出感谢: 0 次
接收感谢: 0 次
to 4楼
checkinstal 我记得不推荐.
打包的方法debian的手册里有啊!
看正版不要看盗版啊
再用一点歪门邪道就可以了!
to 5楼
不用管它,再安装scim-python后
就运行apt-get install -f
重启scim ,如果还不行请回复一下
多谢!
to 7楼
把错误提示 贴一下.
fitx 和scim-python的关系
我不清楚,得问作者.
当然,我也希望作者以后能远离python
因为一个输入法依赖太多不好!


_________________
blog:http://wkt55555.blog.163.com/


最后由 wkt 编辑于 2008-03-15 11:24,总共编辑了 1 次

页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-03-10 18:13 
头像

注册: 2008-02-02 23:05
帖子: 471
地址: 天津
送出感谢: 0 次
接收感谢: 0 次
fcitx4Linux就一垃圾,害死我了,还卸载不了

不过 fcitx的苹果版本还不错,不知道Linux怎么搞的。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-03-10 18:22 

注册: 2008-02-16 6:40
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
有时间的话做一个远离python的版本...呵呵。


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-03-10 18:25 
头像

注册: 2008-02-02 23:05
帖子: 471
地址: 天津
送出感谢: 0 次
接收感谢: 0 次
9494,估计就是那个什么scim-python的好事,好像我的机器所有自带的基于scim-python的输入法都有狂开进程无法退出的问题!


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2008-03-10 19:09 

注册: 2006-09-07 22:51
帖子: 849
送出感谢: 0 次
接收感谢: 0 次
wc_111191 写道:
9494,估计就是那个什么scim-python的好事,好像我的机器所有自带的基于scim-python的输入法都有狂开进程无法退出的问题!

这个我很抱歉!
我没有说明ubuntu的使用者
可能以不用那个scim-python.
我的这个被译成不内置任何输入法
可能这个原因


_________________
blog:http://wkt55555.blog.163.com/


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2008-03-10 19:28 
头像

注册: 2008-02-02 23:05
帖子: 471
地址: 天津
送出感谢: 0 次
接收感谢: 0 次
哎,都怪我的fitx是自己编译的,开头还不知道有Deb包,不过感谢楼主提供


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 59 篇帖子 ]  前往页数 1, 2, 3, 4  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译