for scim : libc6-dev: 依赖: libc6 (= 2.3.6-0ubuntu20.5) 但是 2.5

系统字体配置、中文显示和输入法问题
回复
yayu
帖子: 12
注册时间: 2006-06-30 18:04
送出感谢: 0
接收感谢: 0
联系:

for scim : libc6-dev: 依赖: libc6 (= 2.3.6-0ubuntu20.5) 但是 2.5

#1

帖子 yayu » 2008-03-22 20:20

when I configure the scim , the computer say :
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.
and then, I do this :
sudo apt-get install libc6-dev
howerver, it say :
下列的软件包有不能满足的依赖关系:
libc6-dev: 依赖: libc6 (= 2.3.6-0ubuntu20.5) 但是 2.5-0ubuntu14 正要被安装
E: 无法安装的软件包
so , I goto the http://packages.ubuntu.com/zh-cn/feisty ... 6/download
and down the libc6_2.5-0ubuntu14_i386.deb
when I install it , the computer say it exist, but I still reinstall it by xinlide( hehe pingyin )

but ,when I " sudo apt-get install libc6-dev". it still say :
下列的软件包有不能满足的依赖关系:
libc6-dev: 依赖: libc6 (= 2.3.6-0ubuntu20.5) 但是 2.5-0ubuntu14 正要被安装
E: 无法安装的软件包

and , when I configure the scim ,it still say :
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.
the tail of the `config.log' is :
#define SCIM_BINARY_VERSION "1.4.0"
#define SCIM_VERSION "1.4.7"
#define SCIM_MAJOR_VERSION 1
#define SCIM_MINOR_VERSION 4
#define SCIM_MICRO_VERSION 7
#define GETTEXT_PACKAGE "scim"
#define PACKAGE "scim"
#define VERSION "1.4.7"

configure: exit 77
Have somebody help me , thanks!
头像
foolegg
帖子: 249
注册时间: 2007-12-01 14:56
送出感谢: 0
接收感谢: 0

#2

帖子 foolegg » 2008-03-23 14:57

下列的软件包有不能满足的依赖关系:
libc6-dev: 依赖: libc6 (= 2.3.6-0ubuntu20.5) 但是 2.5-0ubuntu14 正要被安装
E: 无法安装的软件包
看你这句话,似乎是libc6正在升级列表里(我是ubuntu7.10,现在的libc6版本是2.6.1-1ubuntu10)

你是不是装了系统后没有升级过?把libc6升级一下再安装libc6-dev看看
yayu
帖子: 12
注册时间: 2006-06-30 18:04
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 yayu » 2008-03-23 19:20

开始的时候已经装上了scim,但是觉得好像没有fcitx好用,所以就卸载了。

然后就开始装fcitx,从新立得里面可以看出机子上已经装了fcitx,但是fcitx显示不出来。重启了好几次都是这样

所以当时就换回到scim,但是很遗憾是上面的结果。

无奈昨晚又折腾了一下fcitx,装了个东西,也不知道怎么弄了一下就好了。装得东西挺多的,都忘了

真无语了,呵呵
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#4

帖子 BigSnake.NET » 2008-03-23 19:22

可能你的源版本不对, 检查一下
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
yayu
帖子: 12
注册时间: 2006-06-30 18:04
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 yayu » 2008-03-23 19:24

foolegg 写了:
下列的软件包有不能满足的依赖关系:
libc6-dev: 依赖: libc6 (= 2.3.6-0ubuntu20.5) 但是 2.5-0ubuntu14 正要被安装
E: 无法安装的软件包
看你这句话,似乎是libc6正在升级列表里(我是ubuntu7.10,现在的libc6版本是2.6.1-1ubuntu10)

你是不是装了系统后没有升级过?把libc6升级一下再安装libc6-dev看看
我现在还是7.04,ubuntu7.10升级不上去,系统在自我检测的时候提示已经是最新的了

我上个星期本来已经升级到7.10了,后来想装了virtualbox玩红警

后来重启的时候,竟然提示我“cpu too old for this kernel”

真晕死
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#6

帖子 BigSnake.NET » 2008-03-23 19:26

yayu 写了:
foolegg 写了:
下列的软件包有不能满足的依赖关系:
libc6-dev: 依赖: libc6 (= 2.3.6-0ubuntu20.5) 但是 2.5-0ubuntu14 正要被安装
E: 无法安装的软件包
看你这句话,似乎是libc6正在升级列表里(我是ubuntu7.10,现在的libc6版本是2.6.1-1ubuntu10)

你是不是装了系统后没有升级过?把libc6升级一下再安装libc6-dev看看
我现在还是7.04,ubuntu7.10升级不上去,系统在自我检测的时候提示已经是最新的了

我上个星期本来已经升级到7.10了,后来想装了virtualbox玩红警

后来重启的时候,竟然提示我“cpu too old for this kernel”

真晕死
那不是 7.10 了吗, 怎么又说7.04了?
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
yayu
帖子: 12
注册时间: 2006-06-30 18:04
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 yayu » 2008-03-23 19:32

BigSnake.NET 写了:可能你的源版本不对, 检查一下
这个有上面差错么:
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper main restricted universe multiverse
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper-updates main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper-updates main restricted universe multiverse
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper-backports main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper-backports main restricted universe multiverse
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper-security main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper-security main restricted universe multiverse
deb http://ftp.sjtu.edu.cn/ubuntu-cn/ dapper main multiverse restricted universe
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#8

帖子 BigSnake.NET » 2008-03-23 19:33

yayu 写了:
BigSnake.NET 写了:可能你的源版本不对, 检查一下
这个有上面差错么:
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper main restricted universe multiverse
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper-updates main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper-updates main restricted universe multiverse
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper-backports main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper-backports main restricted universe multiverse
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper-security main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper-security main restricted universe multiverse
deb http://ftp.sjtu.edu.cn/ubuntu-cn/ dapper main multiverse restricted universe
绝对是错的..
dapper是 6.06的代号..
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
yayu
帖子: 12
注册时间: 2006-06-30 18:04
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 yayu » 2008-03-23 19:35

BigSnake.NET 写了:
yayu 写了:
foolegg 写了:
下列的软件包有不能满足的依赖关系:
libc6-dev: 依赖: libc6 (= 2.3.6-0ubuntu20.5) 但是 2.5-0ubuntu14 正要被安装
E: 无法安装的软件包
看你这句话,似乎是libc6正在升级列表里(我是ubuntu7.10,现在的libc6版本是2.6.1-1ubuntu10)

你是不是装了系统后没有升级过?把libc6升级一下再安装libc6-dev看看
我现在还是7.04,ubuntu7.10升级不上去,系统在自我检测的时候提示已经是最新的了

我上个星期本来已经升级到7.10了,后来想装了virtualbox玩红警

后来重启的时候,竟然提示我“cpu too old for this kernel”

真晕死
那不是 7.10 了吗, 怎么又说7.04了?
7.10时,想装了virtualbox玩红警,后来重启的时候,竟然提示我“cpu too old for this kernel”

所以昨天重装了系统。是7.04的系统盘

想升级,提示我说已经是最新版本了,所以没升级到7.01
yayu
帖子: 12
注册时间: 2006-06-30 18:04
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 yayu » 2008-03-23 19:44

BigSnake.NET 写了:
yayu 写了:
BigSnake.NET 写了:可能你的源版本不对, 检查一下
这个有上面差错么:
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper main restricted universe multiverse
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper-updates main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper-updates main restricted universe multiverse
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper-backports main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper-backports main restricted universe multiverse
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper-security main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ dapper-security main restricted universe multiverse
deb http://ftp.sjtu.edu.cn/ubuntu-cn/ dapper main multiverse restricted universe
绝对是错的..
dapper是 6.06的代号..
!!!!!!!!!!!!!!!!!!!!!!!!!!

我从wiki上复制的

能告诉我正确的么?谢谢了!
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#11

帖子 BigSnake.NET » 2008-03-23 19:45

http://wiki.ubuntu.org.cn/index.php?tit ... iant=zh-cn

要看清楚.. 不要只管复制..
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
yayu
帖子: 12
注册时间: 2006-06-30 18:04
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 yayu » 2008-03-24 10:11

BigSnake.NET 写了:http://wiki.ubuntu.org.cn/index.php?tit ... iant=zh-cn

要看清楚.. 不要只管复制..
你是说这个么:http://wiki.ubuntu.org.cn/index.php?tit ... d.29ubuntu

我是北京网通,看上去得设置这个:

代码: 全选

deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ feisty main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ feisty main restricted universe multiverse
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ feisty-updates main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ feisty-updates main restricted universe multiverse
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ feisty-backports main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ feisty-backports main restricted universe multiverse
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ feisty-security main restricted universe multiverse
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ feisty-security main restricted universe multiverse
deb http://ubuntu.csie.ntu.edu.tw/ubuntu/ feisty-proposed main multiverse restricted universe
deb-src http://ubuntu.csie.ntu.edu.tw/ubuntu/ feisty-proposed main restricted universe multiverse
回复

回到 “字体美化和中文支持”