当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [已解决]ubuntu 英文环境下某些地方中文乱码~帮帮我吧...
帖子发表于 : 2008-05-07 10:51 
头像

注册: 2007-09-05 15:29
帖子: 90
地址: 湘B粤H
送出感谢: 0 次
接收感谢: 0 次
ubuntu8.04从中文环境转到 英文环境后 (想用英文环境)
win分区中txt文件中文内容是乱码 但中文文件名正常
之前没什么问题
怎么解决这个问题?
fstab 跟locale 信息如下
引用:
# /dev/hda1
UUID=4672-CA2B /media/WINXP vfat utf8,umask=007,gid=46 0 0
# /dev/hda5
UUID=28E0-B991 /media/SOFTWARE vfat utf8,umask=007,gid=46 0 0
# /dev/hda6
UUID=20EB-20B6 /media/AMUSEMENT vfat utf8,umask=007,gid=46 0 0
# /dev/hda7
UUID=BA50ED7450ED3831 /media/STUDY ntfs utf8,umask=007,gid=46 0 1
# /dev/hda8
UUID=9638BD4938BD28DF /media/OTHERS ntfs utf8,umask=007,gid=46 0 1


引用:
os@auto:~$ locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=


最后由 木精 编辑于 2008-05-07 11:10,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-05-07 10:56 
头像

注册: 2006-11-11 10:23
帖子: 1226
地址: Mars
送出感谢: 0 次
接收感谢: 0 次
英文locale 设置中文输入法

编辑 /etc/gtk-2.0/gtk.immodules(如果存在的话) 或者 /usr/lib/gtk-2.0/2.10.0/immodule-files.d/libgtk2.0-0.immodules 文件,在xim 的 local 增加 en 也就是说:

"xim" "X Input Method" "gtk20" "/usr/share/locale" "ko:ja:th:zh"

改成

"xim" "X Input Method" "gtk20" "/usr/share/locale" "en:ko:ja:th:zh"


接着将环境变量 LC_CTYPE 设置为 zh_CN.UTF-8

$ echo 'LC_CTYPE=zh_CN.UTF-8' | sudo tee - -a /etc/environment





英文locale gedit 显示 GBK 中文文本
gconf-editor->apps->gedit-2->encodings->auto_detected中将加入一项GBK,并放以ISO-8859-15之前


_________________
抬头望星空一片晴,我独行,夜已渐寒……


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-05-07 11:09 
头像

注册: 2007-09-05 15:29
帖子: 90
地址: 湘B粤H
送出感谢: 0 次
接收感谢: 0 次
谢谢...
用这个解决了...
引用:
gconf-editor->apps->gedit-2->encodings->auto_detected中将加入一项GBK,并放以ISO-8859-15之前


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-05-08 22:47 

注册: 2008-04-25 21:53
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
lz
gconf-editor->apps->gedit-2->encodings->auto_detected中将加入一项GBK,并放以ISO-8859-15之前

这句话什么意思?


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-05-09 12:29 

注册: 2006-10-24 21:26
帖子: 25
送出感谢: 0 次
接收感谢: 1
引用:
ubuntu8.04从中文环境转到 英文环境后

想请教一下,怎么从中文环境转到英文环境啊?
我在语言支持里面选择了两种语言支持:中文和英文,默认语言设置为英文。可是现在菜单和窗口界面仍旧是中文的。[/quote]


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-05-09 18:36 

注册: 2008-04-25 21:53
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
楼主,什么时候回来解释下啊?
你所引用的那句话是什么意思啊?实在gedit窗口打开后进行的设置吗?还是在什么地方设置的?
你后来是没打开个win下的txt文档都可以正常显示,还是每次都要设置下。。。
着急中,楼主什么时候回来,再解释下哈!
谢谢了


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2008-05-09 18:43 
头像

注册: 2007-04-25 13:12
帖子: 2838
送出感谢: 0 次
接收感谢: 0 次
运行gconf-editor你就知道了


_________________
♜♞♝♛♚♝♞♜
♟♟♟♟♟♟♟♟
♙♙♙♙♙♙♙♙
♖♘♗♕♔♗♘♖

☠☯⚔⚓☣☦☃☕
☹☻☪☭☬⚖⚛⚜
ℜℳℬ™ ℋℯℓ℘ ℳℭ
sƂɐʍ рǀɹoʍ əɥʇ oS


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-05-10 10:08 

注册: 2008-04-25 21:53
帖子: 28
送出感谢: 0 次
接收感谢: 0 次
谢谢楼上的!
开始觉得命令不会加“-”吧,就没尝试!
现在好了,谢谢!


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2008-05-10 16:17 

注册: 2008-05-04 18:14
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
我的是
gconf-editor->apps->gedit-2->preferences->encodings->auto_detected


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-05-23 23:06 
头像

注册: 2007-09-05 15:29
帖子: 90
地址: 湘B粤H
送出感谢: 0 次
接收感谢: 0 次
不好意思..都忘记自己发的帖子了..
gconf-editor 有点像win下面的注册表


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Yahoo [Bot] 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译