而谁出现过这样的字体问题?

系统字体配置、中文显示和输入法问题
回复
bmlinkai
帖子: 8
注册时间: 2006-08-28 20:48
来自: SCUT
送出感谢: 0
接收感谢: 0
联系:

而谁出现过这样的字体问题?

#1

帖子 bmlinkai » 2008-05-25 19:33

打开Baidu搜索结果后,页面的字体是这个样子的. 显示结果列表正常,但“设置百度为首页”等字变得很大。

Google的搜索页这里的“下一页”几个字,也变得特别大。

怀疑是不是黑体字设置的有问题?有人帮帮我吗?给我看看字体和配置文件怎么设置?

还不会贴图,不知道有没有贴错。
附件
Screenshot1.png
百度
Screenshot2.png
Google
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

#2

帖子 leeaman » 2008-05-25 19:40

刷新一下看看
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
头像
adagio
论坛版主
帖子: 22120
注册时间: 2008-02-17 23:47
来自: 美丽富饶的那啥星球
送出感谢: 7 次
接收感谢: 74 次

#3

帖子 adagio » 2008-05-25 19:49

:lol: 这个才叫一砣屎啊
明天就换大三八!
——8核CPU、8G内存、8T硬盘……
8卡交火,80寸大屏放8个……
IPv8的光纤要8条……

---------------------------------------------------------------------------------
[图片版]新手当自强(续)FAQ
[新手进阶]挂载、fstab、调整linux分区
[图片版]E17桌面环境配置手把手
头像
solcomo
帖子: 2838
注册时间: 2007-04-25 13:12
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 solcomo » 2008-05-25 19:53

你是按照什么方法配置字体的 ?
♜♞♝♛♚♝♞♜
♟♟♟♟♟♟♟♟
♙♙♙♙♙♙♙♙
♖♘♗♕♔♗♘♖

☠☯⚔⚓☣☦☃☕
☹☻☪☭☬⚖⚛⚜
ℜℳℬ™ ℋℯℓ℘ ℳℭ
sƂɐʍ рǀɹoʍ əɥʇ oS
bmlinkai
帖子: 8
注册时间: 2006-08-28 20:48
来自: SCUT
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 bmlinkai » 2008-05-25 19:58

solcomo 写了:你是按照什么方法配置字体的 ?


我一开始装的Alternative版本的Ubuntu8.04,然后自己装了Ubuntu-Desktop,此外没有做任何字体相关的东西。
一开始就发现百度和Google显示不正常。其他网页基本还好,但碰到一些网页有类似黑体的字,也会变得很大。

之后我试了很多字体美化方案都没有解决问题

唯一的一个发现是,如果Firefox的字体设为文泉驿点阵的话就不会有这么大的字体出现,不过文泉驿点阵看起来字体笔划实在太小,不想用。
头像
relaxssl
帖子: 1448
注册时间: 2007-01-30 7:13
送出感谢: 4 次
接收感谢: 0

#6

帖子 relaxssl » 2008-05-25 20:00

很恶心的字体
头像
solcomo
帖子: 2838
注册时间: 2007-04-25 13:12
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 solcomo » 2008-05-25 20:05

你先做备份,然后试试把/etc/fonts/conf.avail/90-synthetic.conf 的最后一段改成这样

代码: 全选

<!--
 Synthetic emboldening for fonts that do not have bold face available
 -->

   <match target="font">
      <!-- check to see if the font is just regular -->
      <test name="weight" compare="less_eq">
         <const>medium</const>
      </test>
      <!-- check to see if the pattern requests bold -->
      <test target="pattern" name="weight" compare="more">
         <const>medium</const>
      </test>
      <!--
        set the embolden flag
        needed for applications using cairo, e.g. gucharmap, gedit, ...
      -->
      <edit name="embolden" mode="assign">
         <bool>true</bool>
      </edit>
      <!--
       set weight to bold
       needed for applications using Xft directly, e.g. Firefox, ...
      -->
      <edit name="weight" mode="assign">
         <const>medium</const>
      </edit>
   </match>
♜♞♝♛♚♝♞♜
♟♟♟♟♟♟♟♟
♙♙♙♙♙♙♙♙
♖♘♗♕♔♗♘♖

☠☯⚔⚓☣☦☃☕
☹☻☪☭☬⚖⚛⚜
ℜℳℬ™ ℋℯℓ℘ ℳℭ
sƂɐʍ рǀɹoʍ əɥʇ oS
bmlinkai
帖子: 8
注册时间: 2006-08-28 20:48
来自: SCUT
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 bmlinkai » 2008-05-25 20:31

solcomo 写了:你先做备份,然后试试把/etc/fonts/conf.avail/90-synthetic.conf 的最后一段改成这样

代码: 全选

<!--
 Synthetic emboldening for fonts that do not have bold face available
 -->

   <match target="font">
      <!-- check to see if the font is just regular -->
      <test name="weight" compare="less_eq">
         <const>medium</const>
      </test>
      <!-- check to see if the pattern requests bold -->
      <test target="pattern" name="weight" compare="more">
         <const>medium</const>
      </test>
      <!--
        set the embolden flag
        needed for applications using cairo, e.g. gucharmap, gedit, ...
      -->
      <edit name="embolden" mode="assign">
         <bool>true</bool>
      </edit>
      <!--
       set weight to bold
       needed for applications using Xft directly, e.g. Firefox, ...
      -->
      <edit name="weight" mode="assign">
         <const>medium</const>
      </edit>
   </match>



好象没有什么用,还是要在安装了Xfonts-wqy后,选中Firefox的字体为WenQuanYi Bitmap Song,还要在高级那里把“允许页面选择显示字体而不使用上面的配置”这个勾去掉 。
回复

回到 “字体美化和中文支持”