当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]请问各位,ubuntu5.1䒈访问windows XP系统时,中文为什么都显示"??"?
帖子发表于 : 2006-04-23 14:19 

注册: 2006-02-19 10:24
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
请问这么配置,thanks :wink:


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-04-23 17:09 

注册: 2006-04-08 14:27
帖子: 9
送出感谢: 0 次
接收感谢: 0 次
如果是访问分区的话,挂载的时候加字符选项,mount -o iocharset=utf8,否则中文显示不正常.


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-04-23 17:17 

注册: 2006-02-19 10:24
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
谢班友:yfzero, good luck~! :P


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-04-25 23:24 

注册: 2006-04-25 23:15
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
我在使用u盘的时候都没问题,以中文命名的文件夹和文件都能正确显示,但是系统自动加载的硬盘就无法正确显示中文命名的文件夹和文件。看了你的帖子我尝试修改了 /etc/mtab
在盘符后面 适当位置加上iocharset=utf8 eg:
/dev/hda6 /media/hda6 vfat rw,iocharset=utf8 0 0
但 重起后系统又把文件的内容改回去了
我该怎么办阿??


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-04-26 19:58 

注册: 2006-02-19 10:24
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
请楼上的朋友修改/etc/fstab文件试试,此文件是系统自动加载䒈分区的文件。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-04-26 20:00 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
xjtugong 写道:
我在使用u盘的时候都没问题,以中文命名的文件夹和文件都能正确显示,但是系统自动加载的硬盘就无法正确显示中文命名的文件夹和文件。看了你的帖子我尝试修改了 /etc/mtab
在盘符后面 适当位置加上iocharset=utf8 eg:
/dev/hda6 /media/hda6 vfat rw,iocharset=utf8 0 0
但 重起后系统又把文件的内容改回去了
我该怎么办阿??
mtab只是个让你看看的磁盘挂载的列表哦。fstab才是配置。


_________________
● 鸣学


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-04-26 23:23 

注册: 2006-04-25 23:15
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
终于成功了
饮水思源
谢谢大家对我的帮助!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译