[已解决]这些乱码怎么解决?

系统字体配置、中文显示和输入法问题
uTomBox
帖子: 80
注册时间: 2006-04-30 23:41
送出感谢: 0
接收感谢: 0

[已解决]这些乱码怎么解决?

#1

帖子 uTomBox » 2006-05-01 11:58

这些乱码怎么解决?

代码: 全选

sudo gedit /etc/fstab

代码: 全选

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda7       /               ext3    defaults,errors=remount-ro 0       1
/dev/hda8       /home           ext3    defaults        0       2
/dev/hda1       /media/hda1     vfat    utf8,umask=0222        0        0
/dev/hda5       /media/hda5     vfat    utf8,umask=0222        0        0
/dev/hda6       /media/hda6     vfat    utf8,umask=0222        0        0
/dev/hda9       /media/hda9     vfat    utf8,umask=0222        0        0
/dev/hdd        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0

代码: 全选

sudo mount -a
附件
Screenshot-1.png
Screenshot.png
上次由 uTomBox 在 2006-05-01 18:15,总共编辑 1 次。
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 karron » 2006-05-01 12:09

请搜索论坛。
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
uTomBox
帖子: 80
注册时间: 2006-04-30 23:41
送出感谢: 0
接收感谢: 0

#3

帖子 uTomBox » 2006-05-01 12:10

搜索了~```麻烦把地址贴一下~- -
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 karron » 2006-05-01 12:16

你这个是有修改过windows分区磁盘挂载吗?没有的话,那么看看新手指南里面的修改方法,论坛里面也有很多。如果修改过,那么把你的/etc/fstab文件贴出来看看。
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
uTomBox
帖子: 80
注册时间: 2006-04-30 23:41
送出感谢: 0
接收感谢: 0

#5

帖子 uTomBox » 2006-05-01 13:32

karron 写了:你这个是有修改过windows分区磁盘挂载吗?没有的话,那么看看新手指南里面的修改方法,论坛里面也有很多。如果修改过,那么把你的/etc/fstab文件贴出来看看。
http://old.ubuntu.org.cn/search?Searcha ... 2%E8%BD%BD

帮我看看会不会对windows分区造成什么危害?如数据丢失之类~``

挂载了看到的字就不是乱码吗?

如果回到windows会不会有影响。
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 karron » 2006-05-01 14:05

不会,这里基本上有windows分区的人都会挂载windows分区,ubuntu5.10默认的挂载没有加上utf8的参数,导致中文文件乱码,所以要修改,建议你搜索论坛,查找方法,直接修改/etc/fstab文件,然后
sudo umount -a
sudo mount -a
就行了

最新的ubuntu6.06已经能够正确挂载了,不用再手工修改。

安装ubuntu之后,请首先,安装新手指南上面的设置指南进行设置,出现问题请搜索论坛和主页。多多利用新手指南和搜索功能,会大大降低使用ubuntu的难度。
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
uTomBox
帖子: 80
注册时间: 2006-04-30 23:41
送出感谢: 0
接收感谢: 0

#7

帖子 uTomBox » 2006-05-01 14:17

好像我的还是5.10- -
怎样才可以安装6.06
uTomBox
帖子: 80
注册时间: 2006-04-30 23:41
送出感谢: 0
接收感谢: 0

#8

帖子 uTomBox » 2006-05-01 16:57

代码: 全选

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda7       /               ext3    defaults,errors=remount-ro 0       1
/dev/hda8       /home           ext3    defaults        0       2
/dev/hda1       /media/hda1     vfat    defaults        0       0
/dev/hda5       /media/hda5     vfat    defaults        0       0
/dev/hda6       /media/hda6     vfat    defaults        0       0
/dev/hda9       /media/hda9     vfat    defaults        0       0
/dev/hdd        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
修改:

代码: 全选

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda7       /               ext3    defaults,errors=remount-ro 0       1
/dev/hda8       /home           ext3    defaults        0       2
/dev/hda1       /media/hda1     vfat    nls=utf8,umask=0222        0        0 
/dev/hda5       /media/hda5     vfat    nls=utf8,umask=0222        0        0 
/dev/hda6       /media/hda6     vfat    nls=utf8,umask=0222        0        0 
/dev/hda9       /media/hda9     vfat    nls=utf8,umask=0222        0        0 
/dev/hdd        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
All right????
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 karron » 2006-05-01 17:20

代码: 全选

/dev/hda5       /media/hda5     vfat    defaults,utf8,umask=007,gid=46 0       1
/dev/hda6       /media/hda6     ntfs    defaults,nls=utf8,umask=007,gid=46 0       1
上面是我的6.06自动生成的代码。注意NTFS和vfat是不一样的,vfat是不需要nls=的。
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
uTomBox
帖子: 80
注册时间: 2006-04-30 23:41
送出感谢: 0
接收感谢: 0

#10

帖子 uTomBox » 2006-05-01 17:31

代码: 全选

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda7       /               ext3    defaults,errors=remount-ro 0       1
/dev/hda8       /home           ext3    defaults        0       2
/dev/hda1       /media/hda1     vfat    utf8,umask=0222        0        0
/dev/hda5       /media/hda5     vfat    utf8,umask=0222        0        0
/dev/hda6       /media/hda6     vfat    utf8,umask=0222        0        0
/dev/hda9       /media/hda9     vfat    utf8,umask=0222        0        0
/dev/hdd        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0 
All right?

代码: 全选

umask=0222
这个又是什么意思?

修改好了是不是要重新启动?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#11

帖子 eexpress » 2006-05-01 17:45

sudo mount -a
umask是权限掩码。
weblog_entry.php?e=83
● 鸣学
uTomBox
帖子: 80
注册时间: 2006-04-30 23:41
送出感谢: 0
接收感谢: 0

#12

帖子 uTomBox » 2006-05-01 17:49

eexpress 写了:sudo mount -a
umask是权限掩码。
weblog_entry.php?e=83
我就是看你的~``- -~`但是改了,还是“?????”这个,要重启吗?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#13

帖子 eexpress » 2006-05-01 17:57

不要重启啊。只是要重新挂载。sudo mount -a就是重新挂载fstab里面的所有带了user参数的分区。要卸载,也可以在nautilus里面右键选“卸载文件卷”的。都可以多试试。反正不影响主系统的挂载。乱试也可熟悉的,以后多看man。man fstab和man mount这样的。

代码: 全选

/dev/hda1       /media/win-c     vfat    user,utf8,umask=0      0       0
/dev/hda5       /media/win-d     vfat    user,utf8,umask=0      0       0
● 鸣学
uTomBox
帖子: 80
注册时间: 2006-04-30 23:41
送出感谢: 0
接收感谢: 0

#14

帖子 uTomBox » 2006-05-01 18:06

eexpress 写了:不要重启啊。只是要重新挂载。sudo mount -a就是重新挂载fstab里面的所有带了user参数的分区。要卸载,也可以在nautilus里面右键选“卸载文件卷”的。都可以多试试。反正不影响主系统的挂载。乱试也可熟悉的,以后多看man。man fstab和man mount这样的。

代码: 全选

/dev/hda1       /media/win-c     vfat    user,utf8,umask=0      0       0
/dev/hda5       /media/win-d     vfat    user,utf8,umask=0      0       0
谢谢问题解决~``umask的权限问题我还是不懂~``
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#15

帖子 eexpress » 2006-05-01 18:10

umask [-p] [-S] [mode]
用户创建文件的掩码被设置为 mode. 如果 mode 以数字开始,它被解释
为一个八进制数;否则被解释为类似于 chmod(1) 接受的符号形式的模式
掩码。如果忽略了 mode,将打印当前掩码值。选项 -S 使得掩码以符 号
形 式 打 印 ;默认输出是八进制数。如果给出了 -p 选项,并且忽略了
mode,输出将是一种可以重用为输入的形式。返回值是 0,如果成功改变
了模式,或者没有给出 mode。其他情况返回假。

自己man umask就会出来的。如果要安装中文的man手册,在论坛搜索。man里面用/搜索字符串就是了。
● 鸣学
回复

回到 “字体美化和中文支持”