设置自动挂载分区后,分区下的中文文件名和目录名都变成乱马了

系统字体配置、中文显示和输入法问题
回复
czg0002
帖子: 26
注册时间: 2006-08-02 9:47
送出感谢: 0
接收感谢: 0

设置自动挂载分区后,分区下的中文文件名和目录名都变成乱马了

#1

帖子 czg0002 » 2008-09-27 11:35

各位大虾,我在ubuntu8.04下设置了自动挂载windows下的d、e分区,结果重启后发现e分区下的中文文件名和目录名都变成乱码了,但是d分区下的中文文件名都能正常显示。在e分区下新建中文目录,目录明也能正常显示。
这是怎么回事?该怎么处理呢?
头像
Nile
帖子: 990
注册时间: 2006-07-15 11:20
来自: 枫叶刀市
送出感谢: 2 次
接收感谢: 0

Re: 设置自动挂载分区后,分区下的中文文件名和目录名都变成乱马了

#2

帖子 Nile » 2008-09-27 11:39

列一下fstab
Thinkpad T400
czg0002
帖子: 26
注册时间: 2006-08-02 9:47
送出感谢: 0
接收感谢: 0

Re: 设置自动挂载分区后,分区下的中文文件名和目录名都变成乱马了

#3

帖子 czg0002 » 2008-09-27 13:58

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda7
UUID=1e05ad52-a811-4923-9124-e66199ea7df4 / ext3 relatime,errors=remount-ro 0 1
# /dev/sda6
UUID=5ba3470c-8665-4bf0-8925-f963cfce62fa none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/sda5 /media/disk auto defaults 0 0
/dev/sda8 /media/disk-1 auto defaults 0 0

最后两行是自己加上的,有什么问题么?
头像
leeaman
帖子: 30702
注册时间: 2007-02-02 18:14
系统: debian sid
送出感谢: 1 次
接收感谢: 23 次

Re: 设置自动挂载分区后,分区下的中文文件名和目录名都变成乱马了

#4

帖子 leeaman » 2008-09-27 14:01

最后两行参数不对,具体自己Google
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)
czg0002
帖子: 26
注册时间: 2006-08-02 9:47
送出感谢: 0
接收感谢: 0

Re: 设置自动挂载分区后,分区下的中文文件名和目录名都变成乱马了

#5

帖子 czg0002 » 2008-09-27 21:53

谢谢楼上。google了一下,把最后两行换成下面的:
/dev/sda5 /media/disk ntfs defaults,codepage=936,iocharset=cp936 0 0
/dev/sda8 /media/disk-1 vfat defaults,codepage=936,iocharset=utf8 0 0
中文显示是正常了,可是发现不能对disk-1进行读写,是这个defaults默认设置的问题么?
要把他改成可读写的是什么参数呢?
回复

回到 “字体美化和中文支持”