打好deb包的fcitx-3.5-080918输入法,有兴趣的兄弟一起分享

系统字体配置、中文显示和输入法问题
acaimin
帖子: 27
注册时间: 2008-06-30 19:09
送出感谢: 0
接收感谢: 0

打好deb包的fcitx-3.5-080918输入法,有兴趣的兄弟一起分享

#1

帖子 acaimin » 2008-10-16 7:03

来论坛这么久,都在索取全无付出,今天开始要改变一下

对新手来说,在U下编译程序可能属于比较难受的事,我正是其中之一

从源安装的是3.4版,这个版本是作者在宣布停止开发后自己 用的。

折腾半天终于打包好这个版本的输入法,X86平台。

安装了之后,需要手动设置一下:


1:在etc/X11/Xsession.d/目录下,
新建文件,名为 95fcitx_start
内容输入:
export LC_CTYPE=zh_CN.UTF-8
export XMODIFIERS=@im=fcitx
export XIM=fcitx
export XIM_PROGRAM=fcitx
fcitx

2:保存退出,给该文件添加可执行权限,
sudo chmod +x /etc/X11/Xsession.d/95fcitx.install

包太大,超出限制大小,上传到纳米盘。

http://www.namipan.com/downfile/fcitx_3 ... 5c42dc6000
头像
daf3707
论坛版主
帖子: 12673
注册时间: 2007-06-13 15:57
来自: 在他乡
送出感谢: 49 次
接收感谢: 85 次

Re: 打好deb包的fcitx-3.5-080918输入法,有兴趣的兄弟一起分享

#2

帖子 daf3707 » 2008-10-16 8:42

有啥更新或者特点也不说?没人捧场啊
头像
adagio
论坛版主
帖子: 22120
注册时间: 2008-02-17 23:47
来自: 美丽富饶的那啥星球
送出感谢: 7 次
接收感谢: 74 次

Re: 打好deb包的fcitx-3.5-080918输入法,有兴趣的兄弟一起分享

#3

帖子 adagio » 2008-10-16 9:32

就是,给个理由先
明天就换大三八!
——8核CPU、8G内存、8T硬盘……
8卡交火,80寸大屏放8个……
IPv8的光纤要8条……

---------------------------------------------------------------------------------
[图片版]新手当自强(续)FAQ
[新手进阶]挂载、fstab、调整linux分区
[图片版]E17桌面环境配置手把手
acaimin
帖子: 27
注册时间: 2008-06-30 19:09
送出感谢: 0
接收感谢: 0

Re: 打好deb包的fcitx-3.5-080918输入法,有兴趣的兄弟一起分享

#4

帖子 acaimin » 2008-10-16 17:04

我也不是特别清楚,这个版本是作者的朋友经其同意放出来的

fcitx输入停止开发的时候版本号为070703,即07年7月3号的版本
这个是09年纪念918的版本

这个版本至少以可五笔拼音同时输入,不必切换
头像
arvan
帖子: 190
注册时间: 2005-08-02 18:04
来自: Lanzhou
送出感谢: 0
接收感谢: 0
联系:

Re: 打好deb包的fcitx-3.5-080918输入法,有兴趣的兄弟一起分享

#5

帖子 arvan » 2008-10-16 17:14

很感谢分享啊。呵呵。 :em01
Jonathan Swift - "May you live every day of your life."
头像
coffer
帖子: 673
注册时间: 2006-12-22 21:05
来自: 上海
送出感谢: 0
接收感谢: 0
联系:

Re: 打好deb包的fcitx-3.5-080918输入法,有兴趣的兄弟一起分享

#6

帖子 coffer » 2008-10-16 22:37

fcitx 918纪念版的改进:最主要的就是在 firefox 下输入的时候,不会选不上第二个候选词了。另外的改善还有输入大写字母,会自动转为英文模式,双击 ctrl 可以切换回来等等。同时,config 文件的格式也有点变化了,最好备份原来的 config 并删除以后,让程序自动生成一个默认 config,再进行修改。
xx168happy
帖子: 2
注册时间: 2008-10-17 0:37
送出感谢: 0
接收感谢: 0

Re: 打好deb包的fcitx-3.5-080918输入法,有兴趣的兄弟一起分享

#7

帖子 xx168happy » 2008-10-17 0:40

acaimin 写了:来论坛这么久,都在索取全无付出,今天开始要改变一下

对新手来说,在U下编译程序可能属于比较难受的事,我正是其中之一

从源安装的是3.4版,这个版本是作者在宣布停止开发后自己 用的。

折腾半天终于打包好这个版本的输入法,X86平台。

安装了之后,需要手动设置一下:


1:在etc/X11/Xsession.d/目录下,
新建文件,名为 95fcitx_start
内容输入:
export LC_CTYPE=zh_CN.UTF-8
export XMODIFIERS=@im=fcitx
export XIM=fcitx
export XIM_PROGRAM=fcitx
fcitx

2:保存退出,给该文件添加可执行权限,
sudo chmod +x /etc/X11/Xsession.d/95fcitx.install

包太大,超出限制大小,上传到纳米盘。

http://www.namipan.com/downfile/fcitx_3 ... 5c42dc6000
95fcitx_start 里要多加一行,要不OPERA里用不了

export LC_CTYPE=zh_CN.UTF-8
export XMODIFIERS=@im=fcitx
export XIM=fcitx
export XIM_PROGRAM=fcitx
export QT_IM_MODULE=XIM
fcitx
kingpin
帖子: 263
注册时间: 2007-11-03 16:37
送出感谢: 0
接收感谢: 0

Re: 打好deb包的fcitx-3.5-080918输入法,有兴趣的兄弟一起分享

#8

帖子 kingpin » 2008-10-17 13:25

一址用fcitx,感觉已经很稳定了,不知道这个版本增加了什么?

:em09
greatguo
帖子: 24
注册时间: 2008-09-23 8:17
送出感谢: 0
接收感谢: 0

Re: 打好deb包的fcitx-3.5-080918输入法,有兴趣的兄弟一起分享

#9

帖子 greatguo » 2008-10-17 14:56

用上了,非常感谢分享
greatguo
帖子: 24
注册时间: 2008-09-23 8:17
送出感谢: 0
接收感谢: 0

Re: 打好deb包的fcitx-3.5-080918输入法,有兴趣的兄弟一起分享

#10

帖子 greatguo » 2008-10-17 15:53

我这里总是提示更新,结果更新完又成为3.4版本了,怎么回事?
:em20
头像
逍遥昱昕
帖子: 103
注册时间: 2007-01-12 21:33
送出感谢: 0
接收感谢: 0
联系:

Re: 打好deb包的fcitx-3.5-080918输入法,有兴趣的兄弟一起分享

#11

帖子 逍遥昱昕 » 2008-10-17 19:15

很喜欢这个东西……可是我这里不能用,显示error……
头像
daf3707
论坛版主
帖子: 12673
注册时间: 2007-06-13 15:57
来自: 在他乡
送出感谢: 49 次
接收感谢: 85 次

Re: 打好deb包的fcitx-3.5-080918输入法,有兴趣的兄弟一起分享

#12

帖子 daf3707 » 2008-10-17 19:28

greatguo 写了:我这里总是提示更新,结果更新完又成为3.4版本了,怎么回事?
:em20
把源里的卸载,再把这个安装好之后,在新立得里将fcitx锁定版本就OK了
头像
逍遥昱昕
帖子: 103
注册时间: 2007-01-12 21:33
送出感谢: 0
接收感谢: 0
联系:

Re: 打好deb包的fcitx-3.5-080918输入法,有兴趣的兄弟一起分享

#13

帖子 逍遥昱昕 » 2008-10-17 20:24

多谢楼主,已经成功更新了。

不过貌似光标跟随的问题仍然没有解决……唉……
setter
帖子: 236
注册时间: 2008-05-10 15:34
送出感谢: 0
接收感谢: 0

Re: 打好deb包的fcitx-3.5-080918输入法,有兴趣的兄弟一起分享

#14

帖子 setter » 2008-10-17 20:36

光标跟随和软件有关
这个版本不能用左右shift键选词,比较郁闷...
setter
帖子: 236
注册时间: 2008-05-10 15:34
送出感谢: 0
接收感谢: 0

Re: 打好deb包的fcitx-3.5-080918输入法,有兴趣的兄弟一起分享

#15

帖子 setter » 2008-10-17 20:57

greatguo 写了:我这里总是提示更新,结果更新完又成为3.4版本了,怎么回事?
:em20
我自己编译的64bit版,一开始也是这样,估计楼主在checkinstall的时候没有填版本,后来我按照源里面版本的格式自己更改了deb的版本,就不再提示了
回复

回到 “字体美化和中文支持”