新手求助,不能完全显示中文,

系统字体配置、中文显示和输入法问题
回复
sky66110
帖子: 2
注册时间: 2008-11-17 16:17
送出感谢: 0
接收感谢: 0

新手求助,不能完全显示中文,

#1

帖子 sky66110 » 2008-11-20 5:52

安装系统后更新了语言包,系统都变成中文了,
但是后来装的软件都不完全是中文的,很多软件是英文
比如smplayer,3D桌面的软件,都是英文
用起来很不方便
不知道有什么办法可以解决?
sky66110
帖子: 2
注册时间: 2008-11-17 16:17
送出感谢: 0
接收感谢: 0

Re: 新手求助,不能完全显示中文,

#2

帖子 sky66110 » 2008-11-20 12:16

有没有人可以帮我,谢谢~~~~~~~~~~
lwjcxy
帖子: 408
注册时间: 2008-08-26 2:08
送出感谢: 0
接收感谢: 0

Re: 新手求助,不能完全显示中文,

#3

帖子 lwjcxy » 2008-11-20 15:12

我也是有一点英文。就是smplayer这个单词,不能中文//////////////


有一点英文有什么关系。。。不就是那几个键吗?用多几次就熟了。
附件
Screenshot.png
Screenshot-5.png
头像
netphi
帖子: 1051
注册时间: 2008-08-29 21:31
送出感谢: 0
接收感谢: 2 次

Re: 新手求助,不能完全显示中文,

#4

帖子 netphi » 2008-11-20 15:22

:em20 :em20 并非所有软件都有中文包的,只能说中国人参与开源软件比较少。
我的系统全部是英文界面,也不觉得有什么不方便,习惯就好 :em04
oldghost
帖子: 17
注册时间: 2006-12-14 20:51
送出感谢: 0
接收感谢: 0

Re: 新手求助,不能完全显示中文,

#5

帖子 oldghost » 2008-11-24 22:56

netphi 写了::em20 :em20 并非所有软件都有中文包的,只能说中国人参与开源软件比较少。
我的系统全部是英文界面,也不觉得有什么不方便,习惯就好 :em04

请问系统是英文界面怎样才能支持中文阿?
我本来想用英文界面的可是打开中文TXT文件都是乱码,不知道要怎么解决?
头像
netphi
帖子: 1051
注册时间: 2008-08-29 21:31
送出感谢: 0
接收感谢: 2 次

Re: 新手求助,不能完全显示中文,

#6

帖子 netphi » 2008-11-24 23:37

oldghost 写了:
netphi 写了::em20 :em20 并非所有软件都有中文包的,只能说中国人参与开源软件比较少。
我的系统全部是英文界面,也不觉得有什么不方便,习惯就好 :em04

请问系统是英文界面怎样才能支持中文阿?
我本来想用英文界面的可是打开中文TXT文件都是乱码,不知道要怎么解决?


这个问题涉及的东西比较多。
一般来说,默认locale要选en_US.utf8,支持的locale要选上中文的,包括zh_CN.utf、zh_CN.gbk、zh_CN.gb2302等等。这个可以通过sudo dpkg-reconfigure locales命令来设定。
英文的locale默认不会启动中文的输入法,这个你得自己设置,还需要设置gtk和qt程序的输入法,比较繁琐,你google一下吧。
至于打开TXT文件的乱码问题,这个得看你是用什么来打开了,可能你的TXT文件是gbk编码,有些编辑器默认不会自动识别编码,需要自己设置一下。
此外,你还需要修改/etc/fonts/local.conf 和 ~/.fonts.conf文件,指定中英文的显示字体和优先级,否则字体的显示会比较难看。
还有一些细节的问题就不说了,是不是比较繁琐? :em04
oldghost
帖子: 17
注册时间: 2006-12-14 20:51
送出感谢: 0
接收感谢: 0

Re: 新手求助,不能完全显示中文,

#7

帖子 oldghost » 2008-11-26 20:36

我找不到/etc/fonts/local.conf 这个文件啊,另外我执行完sudo kpkg-reconfigure locales好像还是乱码呢?
我的是Ubuntu 8.04版,我挂载原来Windows分区用的命令是"/dev/sda5 /media/WORK vfat atuo,user,utf8,umask=0 0 0".
头像
netphi
帖子: 1051
注册时间: 2008-08-29 21:31
送出感谢: 0
接收感谢: 2 次

Re: 新手求助,不能完全显示中文,

#8

帖子 netphi » 2008-11-26 20:41

oldghost 写了:我找不到/etc/fonts/local.conf 这个文件啊,另外我执行完sudo kpkg-reconfigure locales好像还是乱码呢?
我的是Ubuntu 8.04版,我挂载原来Windows分区用的命令是"/dev/sda5 /media/WORK vfat atuo,user,utf8,umask=0 0 0".


找不到就新建一个。
执行完命令麻烦重登录一下。
还有,你到底什么地方乱码?乱码的原因很多,说清楚一点。
oldghost
帖子: 17
注册时间: 2006-12-14 20:51
送出感谢: 0
接收感谢: 0

Re: 新手求助,不能完全显示中文,

#9

帖子 oldghost » 2008-11-27 21:41

netphi 写了:
oldghost 写了:我找不到/etc/fonts/local.conf 这个文件啊,另外我执行完sudo kpkg-reconfigure locales好像还是乱码呢?
我的是Ubuntu 8.04版,我挂载原来Windows分区用的命令是"/dev/sda5 /media/WORK vfat atuo,user,utf8,umask=0 0 0".


找不到就新建一个。
执行完命令麻烦重登录一下。
还有,你到底什么地方乱码?乱码的原因很多,说清楚一点。

我重启过系统还是不行,我原来Windows D和E盘mount后打开里面的txt文件,中文都显示乱码。
头像
netphi
帖子: 1051
注册时间: 2008-08-29 21:31
送出感谢: 0
接收感谢: 2 次

Re: 新手求助,不能完全显示中文,

#10

帖子 netphi » 2008-11-27 21:55

oldghost 写了:
netphi 写了:
oldghost 写了:我找不到/etc/fonts/local.conf 这个文件啊,另外我执行完sudo kpkg-reconfigure locales好像还是乱码呢?
我的是Ubuntu 8.04版,我挂载原来Windows分区用的命令是"/dev/sda5 /media/WORK vfat atuo,user,utf8,umask=0 0 0".


找不到就新建一个。
执行完命令麻烦重登录一下。
还有,你到底什么地方乱码?乱码的原因很多,说清楚一点。

我重启过系统还是不行,我原来Windows D和E盘mount后打开里面的txt文件,中文都显示乱码。


:em20 :em20
大哥,反复跟你说过多次了,先告诉我你是用什么编辑器来打开txt文件的,OK?
我估计你用的是gedit,那么:
按alt+F2,在弹出来的窗口中输入:gconf-editor
依次打开:apps-->gedit-2-->preferences-->encodings,双击右边的“auto_detected"-->"add"-->输入:gb18030-->OK-->点UP把它移动到最上边-->OK. 要是gb18030还不行你就再加上gbk!

你说的乱码完全是由于使用的编辑器没有自动包含你的txt文件的编码造成的!
oldghost
帖子: 17
注册时间: 2006-12-14 20:51
送出感谢: 0
接收感谢: 0

Re: 新手求助,不能完全显示中文,

#11

帖子 oldghost » 2008-11-28 11:44

非常感谢netphi的帮助,终于可以正常显示了,不好意思我提问没有把问题描述的很清楚。
回复

回到 “字体美化和中文支持”