使用 gnome-terminal和putty连接IBM服务器,中文乱码,求助!

系统字体配置、中文显示和输入法问题
回复
头像
arvan
帖子: 190
注册时间: 2005-08-02 18:04
来自: Lanzhou
送出感谢: 0
接收感谢: 0
联系:

使用 gnome-terminal和putty连接IBM服务器,中文乱码,求助!

#1

帖子 arvan » 2008-12-11 16:58

用gnome-terminal链接IBM小机,执行一个脚本,出现乱码如下图
terminal.png
之后又使用了putty连接IBM小机,执行一个脚本,出现乱码如下图:
putty.png
putty.png (8.3 KiB) 查看 664 次
如何能让putty或者gnome-terminal显示中文?小机OS是AIX,没有权限进行修改。

我从同事的windows机器用SecureCRT进入主机,执行脚本,能显示中文。所以我想问题还是在我这边,高人帮一下。

最近一直是用Ubuntu办公的。
Jonathan Swift - "May you live every day of your life."
头像
cnkilior
论坛版主
帖子: 4979
注册时间: 2007-08-05 17:40
送出感谢: 0
接收感谢: 5 次

Re: 使用 gnome-terminal和putty连接IBM服务器,中文乱码,求助!

#2

帖子 cnkilior » 2008-12-11 17:09

gnome-terminal----选择一种合适的字符编码。在菜单里面找找!。。。。。。。。
xeoc
帖子: 1994
注册时间: 2007-05-06 10:12
送出感谢: 0
接收感谢: 0

Re: 使用 gnome-terminal和putty连接IBM服务器,中文乱码,求助!

#3

帖子 xeoc » 2008-12-11 17:33

用screen啊,单开可选编码
头像
宇宙卡门
帖子: 70
注册时间: 2009-12-13 21:11
来自: 湖南湘潭
送出感谢: 0
接收感谢: 1 次

Re: 使用 gnome-terminal和putty连接IBM服务器,中文乱码,求助!

#4

帖子 宇宙卡门 » 2010-05-07 12:16

我的系统是ubuntu 10.04的,也遇到过这种情况,用xp下的putty连接的时候就出现了乱码,主要是汉字 的乱码,这个不是系统的问题,而是你的putty 的编码没有设置好,在putty 的change settings 里面把translation的received data assumed ... set 为UTF-8就ok了. :em01
我喜欢你,很久了。等你,也很久了。现在,我要离开,比很久很久还要久
我问,怎样才能让一个人知道你在想他?
你说,心里不停地默念他的名字,他就能感受到。
可我一直在心底重复着你的名字,你却一直没有音信。
我问,当你在等一个人的短信时,你是会调成静音模式还是户外模式?
你说,静音。这样,发现短信来到的时候就会充满惊喜。
于是我调了静音,于是我马上就后悔。
我一直在看手机,每一次屏幕亮起的瞬间,我的一颗心就也跟着亮了起来,这感觉,那样美好,那样心碎。
也许,你并不知道我在等你。
头像
arvan
帖子: 190
注册时间: 2005-08-02 18:04
来自: Lanzhou
送出感谢: 0
接收感谢: 0
联系:

Re: 使用 gnome-terminal和putty连接IBM服务器,中文乱码,求助!

#5

帖子 arvan » 2010-05-09 14:07

thanks. :em01
Jonathan Swift - "May you live every day of your life."
回复

回到 “字体美化和中文支持”