当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : opera 9.6 字体设置
帖子发表于 : 2008-12-14 7:40 
头像

注册: 2008-12-07 19:43
帖子: 317
地址: 江苏盐城亭湖区
系统: ubuntu14.10
送出感谢: 0 次
接收感谢: 0 次
因为OPERA对QQ空间的支持比FF稍好一点,所以就装了个。但是那个字体难看得一塌糊涂。在“首选项”设置是不行,网上有很多说法都不行。经过不间断的GOOGLE,终于解决了。
呵呵,按照作者的说法,OPERA开发者太不把我中华天朝帝国放在眼里了。
在/usr/share/opera/ini/下有个font.ini文件,修改它是要有管理员权限的。方法:sudo gnome-open /usr/share/opera/ini
打开font.ini,找到下面一段(我的已经改过了,这是我印象中的):
; Known fonts that solves specific problems
family:mincho|gothic=japanese good try-first
family:song|song ti|fangsong*=chinese-s try-first
family:kochi*=japanese good try-first
family:baekmuk*=korean good try-first
NND,我中华帝国的文字优先级低于日语,不可饶恕。杀之而后快!
改成(就是把chinese-s那一行放上面):
; Known fonts that solves specific problems
family:song|song ti|fangsong*=chinese-s try-first
family:mincho|gothic=japanese good try-first
family:kochi*=japanese good try-first
family:baekmuk*=korean good try-first
重启OPERA,成功,感觉好多了,其余的在OPERA的“首选项”中设置,呵呵。
但在我的机子上,网页刚出来时字挺清爽的,一动就又有许多字糊掉了,继续GG。


_________________
Ubuntu14.10 + Firefox + Gimp


页首
 用户资料  
 
2 楼 
 文章标题 : Re: opera 9.6 字体设置
帖子发表于 : 2008-12-14 11:50 
头像

注册: 2008-12-07 19:43
帖子: 317
地址: 江苏盐城亭湖区
系统: ubuntu14.10
送出感谢: 0 次
接收感谢: 0 次
估计是OPERA和系统配合不默契吧?
我把上面代码中日本鬼子和韩国棒子的三行删了。
一个网页刚出来是清楚的,上下一动,模糊了。
模糊的主要是小号的字。 比如这个帖子,一楼是糊的,二楼是清楚的。
但在FF中,一楼同样十分清晰


_________________
Ubuntu14.10 + Firefox + Gimp


页首
 用户资料  
 
3 楼 
 文章标题 : i测试页
帖子发表于 : 2008-12-21 12:51 
头像

注册: 2008-12-07 19:43
帖子: 317
地址: 江苏盐城亭湖区
系统: ubuntu14.10
送出感谢: 0 次
接收感谢: 0 次
http://www.89wx.com/Book/ShowBookList.aspx
这个页面,用Opera9.63 访问,刚刷出来时字体是清楚的,但用鼠标一走,所到之处一片模糊。


_________________
Ubuntu14.10 + Firefox + Gimp


页首
 用户资料  
 
4 楼 
 文章标题 : Re: opera 9.6 字体设置
帖子发表于 : 2008-12-21 13:13 
头像

注册: 2008-08-29 21:31
帖子: 1051
送出感谢: 0 次
接收感谢: 2
恩,默认字体是难看得要命,必须更改font.ini,以后情况可能会好一点,opera正在开发中国专用版,叫朱雀 :em05

而且楼主,我打开你上面的那个网址完全没问题,字体显示得很好,我建议你使用论坛上提供的font.ini,见:
http://forum.ubuntu.org.cn/viewtopic.php?f=8&t=70843


_________________
。。。。。。。。。。。。。


页首
 用户资料  
 
5 楼 
 文章标题 : Ubuntu8.10 + Opera9.63 在fonts中,我删除了日文和韩方的代码。 可能是系统自带的X11的那什么
帖子发表于 : 2008-12-21 13:39 
头像

注册: 2008-12-07 19:43
帖子: 317
地址: 江苏盐城亭湖区
系统: ubuntu14.10
送出感谢: 0 次
接收感谢: 0 次
Ubuntu8.10 + Opera9.63
在fonts中,我删除了日文和韩方的代码。
可能是系统自带的X11的那什么太旧了造成的。
在opera:config中禁用了X11后(Enable Core X Fonts 的鉤去发),本论坛首页的很多文字由宋体变成楷体了。
刚刚说的那个测试页,刚刷出来是是宋体,鼠标滑过的地方也变成楷体了,而且字体很小。
另外,这个帖子的前两楼原来是宋体的,现在楷体了。


_________________
Ubuntu14.10 + Firefox + Gimp


最后由 卞锦生 编辑于 2008-12-21 13:46,总共编辑了 1 次

页首
 用户资料  
 
6 楼 
 文章标题 : Re: opera 9.6 字体设置
帖子发表于 : 2008-12-21 13:43 
头像

注册: 2008-08-29 21:31
帖子: 1051
送出感谢: 0 次
接收感谢: 2
我用的也是9.63,打开你上面那个网页,字体是完全没问题的。


附件:
opera 2.png
opera 2.png [ 210.92 KiB | 被浏览 1777 次 ]



_________________
。。。。。。。。。。。。。
页首
 用户资料  
 
7 楼 
 文章标题 : Re: opera 9.6 字体设置
帖子发表于 : 2008-12-21 14:04 
头像

注册: 2008-12-07 19:43
帖子: 317
地址: 江苏盐城亭湖区
系统: ubuntu14.10
送出感谢: 0 次
接收感谢: 0 次
图中小楷部分是鼠标经过的,没动的是宋体。
网页制作者,当然希望浏览器显示作者设置的字体。浏览器当然要忠实地表现设计者的原意,但我们两个人的Opera都没有做到。我的想法,这和Opera没太大关系,应该是Ubuntu的问题。听说X11中的东西很久都没更新了,这个我不太懂。
奇怪的是左边的“龙战”“莲花宝鉴”和右边的“连载”没有变。


附件:
Screenshot-1.png
Screenshot-1.png [ 300.63 KiB | 被浏览 1730 次 ]



_________________
Ubuntu14.10 + Firefox + Gimp


页首
 用户资料  
 
8 楼 
 文章标题 : FF中的这页
帖子发表于 : 2008-12-21 14:22 
头像

注册: 2008-12-07 19:43
帖子: 317
地址: 江苏盐城亭湖区
系统: ubuntu14.10
送出感谢: 0 次
接收感谢: 0 次
在FF中显示正常,不知道怎么回事,可惜顶部显示错位。
但Opera是一定要装的,因为对动网的论坛支持比FF好。


附件:
Screenshot-2.png
Screenshot-2.png [ 235.96 KiB | 被浏览 1656 次 ]



_________________
Ubuntu14.10 + Firefox + Gimp


页首
 用户资料  
 
9 楼 
 文章标题 : 就是这样
帖子发表于 : 2008-12-28 18:25 
头像

注册: 2008-12-07 19:43
帖子: 317
地址: 江苏盐城亭湖区
系统: ubuntu14.10
送出感谢: 0 次
接收感谢: 0 次
; Known fonts that solves specific problems
family:song|song ti|Simsun|WenQuanYi Bitmap Song|fangsong*=chinese-s try-first
代码改成这个,就是添加宋体(Simsun)和文泉驿点阵宋体(WenQuanYi Bitmap Song),前者要从Windows中“弄“过来。


_________________
Ubuntu14.10 + Firefox + Gimp


页首
 用户资料  
 
10 楼 
 文章标题 : QQ空间导航栏及视频站部分文字乱码的解决
帖子发表于 : 2009-01-16 16:31 
头像

注册: 2008-12-07 19:43
帖子: 317
地址: 江苏盐城亭湖区
系统: ubuntu14.10
送出感谢: 0 次
接收感谢: 0 次
终端:sudo gedit /etc/fonts/conf.d/49-sansserif.conf
找到: <edit name="family" mode="append_last">
<string>sans-serif</string>
</edit>
把 sans-serif 改成中文字体,比如Simsun等等 。


_________________
Ubuntu14.10 + Firefox + Gimp


页首
 用户资料  
 
11 楼 
 文章标题 : 给Ubuntu8安装windows字体的方法
帖子发表于 : 2009-01-16 20:36 
头像

注册: 2008-12-07 19:43
帖子: 317
地址: 江苏盐城亭湖区
系统: ubuntu14.10
送出感谢: 0 次
接收感谢: 0 次
 1、 如果你拥有某份Vista或xp 副本的所有权或使用权(咱得讲理,对不对?呵呵。),在字体文件夹(C:\Windows\Fonts)中寻找自己喜欢的中文字体:

  雅黑:msyh、黑体:SimHei、宋体:SimSun、华文细黑:STXihei、华文楷体:STKaiti、华文宋体:STSong、华文仿宋:STFangsong、华文彩云:STCaiyun、华文琥珀:STHupo、华文隶书:STLiti、华文行楷:STXingkai、华文新魏:STXinwei……很多

  2、创建一个文件夹,命名为:winfonts( 这个文件夹的名字自定义),将自己喜欢的字体文件全部装入该文件夹内;

  3、将字体文件夹拷贝在/usr/share/fonts/下

  需要说明的是:Ubuntu8.04并不像Windows可以对任何文件(文件夹)进行读、写、创建、拷贝和删除。字体文件夹的创建也是必须拥有系统管理权限。用下面的命令打开fonts:

  sudo gnome-open /usr/share/fonts/TrueType/

  然后拷贝刚才创建的vista字体文件夹到TrueType下(通常是复制到上一级的fonts下,但为了让永中Office也能用上这些字体,就要放在TrueType里面了);

  4、修改字体权限,使root以外的用户可以使用这些字体。如果不熟悉命令的话,可以直接点击字体文件——属性——权限,进行修改;

  5、建立字体缓存,命令:

  cd /usr/share/fonts/TrueType/winfonts/

  sudo mkfontscale

  sudo mkfontdir

  sudo fc-cache -fv

  6、重启电脑。


_________________
Ubuntu14.10 + Firefox + Gimp


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译