当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : win编辑的文本文件用gedit打开,中文全部变成乱码
帖子发表于 : 2009-01-14 21:30 
头像

注册: 2008-12-21 15:27
帖子: 5349
地址: TARDIS
送出感谢: 1
接收感谢: 10
本来默认语言我是用的中文(安装了中文语言包),一切正常。
后来在“语言支持”里面把“默认语言”该成了英文,下面的输入方法里面的勾也勾上了,后来浏览有中文的东西经常有乱码,怎么解决(前提是不把默认语言改回中文)


_________________


页首
 用户资料  
 
2 楼 
 文章标题 : Re: win编辑的文本文件用gedit打开,中文全部变成乱码
帖子发表于 : 2009-01-14 21:50 
头像

注册: 2008-08-29 21:31
帖子: 1051
送出感谢: 0 次
接收感谢: 2
如果是系统乱码,在终端下运行sudo dpkg-reconfigure locales,把zh_CN.utf8、zh_CN.gbk、zh_CN.18030等等全部选上,默认编码则选择en_US.utf8。
如果仅仅是gedit查看中文乱码,那么,打开gconf-editor,找到app->gedit-2->preferences->encoding中的auto_detected, 添加GB18030,并把GB18030移到在所有编码的最前面即可


_________________
。。。。。。。。。。。。。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: win编辑的文本文件用gedit打开,中文全部变成乱码
帖子发表于 : 2009-01-21 12:18 
头像

注册: 2008-12-21 15:27
帖子: 5349
地址: TARDIS
送出感谢: 1
接收感谢: 10
奇怪,没有问我什么问题,而且也没有gbk之类的。。。

Generating locales...
en_AU.UTF-8... up-to-date
en_BW.UTF-8... up-to-date
en_CA.UTF-8... up-to-date
en_DK.UTF-8... up-to-date
en_GB.UTF-8... up-to-date
en_HK.UTF-8... up-to-date
en_IE.UTF-8... up-to-date
en_IN.UTF-8... up-to-date
en_NZ.UTF-8... up-to-date
en_PH.UTF-8... up-to-date
en_SG.UTF-8... up-to-date
en_US.UTF-8... up-to-date
en_ZA.UTF-8... up-to-date
en_ZW.UTF-8... up-to-date
ja_JP.UTF-8... up-to-date
zh_CN.UTF-8... up-to-date
zh_HK.UTF-8... up-to-date
zh_SG.UTF-8... up-to-date
zh_TW.UTF-8... up-to-date
Generation complete.


_________________


页首
 用户资料  
 
4 楼 
 文章标题 : Re: win编辑的文本文件用gedit打开,中文全部变成乱码
帖子发表于 : 2009-01-21 12:37 
头像

注册: 2008-12-21 15:27
帖子: 5349
地址: TARDIS
送出感谢: 1
接收感谢: 10
奇怪,没有问我什么问题,而且也没有gbk之类的。。。

Generating locales...
en_AU.UTF-8... up-to-date
en_BW.UTF-8... up-to-date
en_CA.UTF-8... up-to-date
en_DK.UTF-8... up-to-date
en_GB.UTF-8... up-to-date
en_HK.UTF-8... up-to-date
en_IE.UTF-8... up-to-date
en_IN.UTF-8... up-to-date
en_NZ.UTF-8... up-to-date
en_PH.UTF-8... up-to-date
en_SG.UTF-8... up-to-date
en_US.UTF-8... up-to-date
en_ZA.UTF-8... up-to-date
en_ZW.UTF-8... up-to-date
ja_JP.UTF-8... up-to-date
zh_CN.UTF-8... up-to-date
zh_HK.UTF-8... up-to-date
zh_SG.UTF-8... up-to-date
zh_TW.UTF-8... up-to-date
Generation complete.

是不是我的语言包要重装?


_________________


页首
 用户资料  
 
5 楼 
 文章标题 : Re: win编辑的文本文件用gedit打开,中文全部变成乱码
帖子发表于 : 2009-01-21 12:52 
头像

注册: 2007-11-29 9:41
帖子: 8455
送出感谢: 0 次
接收感谢: 0 次
转码再开
代码:
iconv -f cp936 -t utf-8


页首
 用户资料  
 
6 楼 
 文章标题 : Re: win编辑的文本文件用gedit打开,中文全部变成乱码
帖子发表于 : 2009-01-21 13:21 

注册: 2006-02-27 10:32
帖子: 267
送出感谢: 0 次
接收感谢: 0 次
你可以让gedit自动检测编码格式的.。

打开gconf-editor,找到 /apps/gedit-2/preferences/encodings

在自动检测(auto_detected)中加入gb18030

如果你希望打开的时候可以选择,则在 shown_in_menu 中加入 GB18030


页首
 用户资料  
 
7 楼 
 文章标题 : Re: win编辑的文本文件用gedit打开,中文全部变成乱码
帖子发表于 : 2009-02-02 19:04 
头像

注册: 2008-12-21 15:27
帖子: 5349
地址: TARDIS
送出感谢: 1
接收感谢: 10
搞定了,谢谢!


_________________


页首
 用户资料  
 
8 楼 
 文章标题 : Re: win编辑的文本文件用gedit打开,中文全部变成乱码
帖子发表于 : 2009-04-28 20:53 
头像

注册: 2008-09-29 15:31
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
zigzed 写道:
你可以让gedit自动检测编码格式的.。

打开gconf-editor,找到 /apps/gedit-2/preferences/encodings

在自动检测(auto_detected)中加入gb18030

如果你希望打开的时候可以选择,则在 shown_in_menu 中加入 GB18030


我的设置了还是不行,依然是乱码 :em20 :em20
不过找到了一个比较次的办法,就是用gedit的“打开”,然后选择GB18030,就不是乱码了,哈哈。汗一个 :em06


_________________
三思方举步,百折不回头!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译