英文环境下fcitx输入法的问题

系统字体配置、中文显示和输入法问题
回复
holly2k
帖子: 86
注册时间: 2008-08-13 20:11
送出感谢: 0
接收感谢: 0

英文环境下fcitx输入法的问题

#1

帖子 holly2k » 2009-02-15 0:14

Sorry,because i could type any chinese character right now,so i have to ask this question by Egs,
this is the first time i use ubuntu,i use fedora 10 for a while several months ago,at that time, I install fcitx 2,but i work very well, after i restart the system, the toolbar appear and i can activate it by press the key ctrl+space,
but now i want to try the ubuntu,i download this version of fcitx
fcitx-3.4.2-bin.tar.bz2 2006-12-01 稳定版(预编译包IA32)
tar it and run the command :./fcitx.install, it look like nothing happen, and i coundn't use the chinese input method, i found something about it, it look like i have 2 upgrade my sources.list,so i upgrade it,and then there is someone said that i have to confugurate the fcitx before using it, so i add the content into the file:
/etc/X11/Xsession.d/95xinput
Content:
export LC_CTYPE=zh_CN.UTF-8
export XMODIFIERS=@im=fcitx
export XIM=fcitx
export XIM_PROGRAM=fcitx
export Language="EN_cn:EN_us:EN_GB:en"
fcitx

reboot in the terminal
now i can see the toolbar, but it appear just before the desktop show up,and then disappear, when i try to type fcitx in the terminal window, i tell me there is another instance running,but the toobar isn't there
i change the configuration, remove the fcitx in the last line,so it doesn't start when the system start, after i got into the system,i run fcitx in the terminal window, this time, the toobar stay in the desktop, but now i press the ctrl+space key ,i doesn't work at all, i am using the English version Ubuntu,and i found someone have a idea below,i try it already and i doesn't work 2, so this time i don't know what to do now, i can only came here asking for help,help,help,help!!!!!
第三,英文环境下fcitx输入法的问题。
代码:
sudo vim /usr/lib/gtk-2.0/2.10.0/immodule-files.d/libgtk2.0-0.immodules

修改最后一行,使其成为这个样子:
代码:
"xim" "X Input Method" "gtk20" "/usr/share/locale" "en:ko:ja:th:zh"
头像
Ur@nus
帖子: 622
注册时间: 2006-12-01 23:02
送出感谢: 0
接收感谢: 0

Re: 英文环境下fcitx输入法的问题

#2

帖子 Ur@nus » 2009-02-15 12:06

头像
mymathersname
帖子: 2870
注册时间: 2008-09-18 23:40
系统: Ubuntu 15.04 x64
来自: Mars
送出感谢: 1 次
接收感谢: 1 次

Re: 英文环境下fcitx输入法的问题

#3

帖子 mymathersname » 2009-02-15 13:33

从源安装多好,非要编译…… :em20
转移各位校内,百毒朋友,把目标转向twitter和facebook,别总看局域网的内容
其实从那么多的ubuntu发行版和fedora的各个发行版中,我们不难看出,linux的进步是惊人的,从长久的发展规律和更加深远的意义来看,linux桌面版与微软的距离在缩小,这是值得庆幸的……
ubuntu是半年还去偷情一次的初恋。fedora是一生挚爱的正室。debian是和正室同等地位的妾侍。rh/cent是用来偷窥的正室大姐姐。suse是一夜夫妻百二蚊。gentoo是有内涵的才女。arch是久闻其名不敢接触的怪叔叔。其余发行版,我是帝皇它们是屁民,无福宠幸。
头像
rodren
帖子: 100
注册时间: 2007-11-23 12:54
送出感谢: 0
接收感谢: 0
联系:

Re: 英文环境下fcitx输入法的问题

#4

帖子 rodren » 2009-02-15 15:33

我上次也和LZ 的差不多
不过现在好了 哈 照着WIKI 上的说明 虽然上面有些命令用不了 不过还好现在可以打字了! :em04
holly2k
帖子: 86
注册时间: 2008-08-13 20:11
送出感谢: 0
接收感谢: 0

Re: 英文环境下fcitx输入法的问题

#5

帖子 holly2k » 2009-02-15 22:47



when i run the first command in the terminal:sudo aptitude install im-switch
it came out the following information
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 84 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Writing extended state information... Done
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = "zh_CN.UTF-8",
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done

is there some problem?
头像
Ur@nus
帖子: 622
注册时间: 2006-12-01 23:02
送出感谢: 0
接收感谢: 0

Re: 英文环境下fcitx输入法的问题

#6

帖子 Ur@nus » 2009-02-16 1:51

你已经装了im-switch。关键是要用 im-switch命令换一下默认输入法,给你的链接里面有,试试看
如果你是英文环境你就把LANGUAGE等变量都设成en_US.UTF-8好了。
uranus@uranus:~$ locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
如果还不行,我就把我的终极方法告诉你 :em06
holly2k
帖子: 86
注册时间: 2008-08-13 20:11
送出感谢: 0
接收感谢: 0

Re: 英文环境下fcitx输入法的问题

#7

帖子 holly2k » 2009-02-16 20:47

vincent@vincent-ubuntu:~$ sudo im-switch -s fcitx -z all_ALL
[sudo] password for vincent:
No system wide default defined just for locale zh_CN .
Use "all_ALL" quasi-locale and set IM.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = "zh_CN.UTF-8",
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = "zh_CN.UTF-8",
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
Using '/etc/X11/xinit/xinput.d/fcitx' to provide 'xinput-all_ALL'.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = "zh_CN.UTF-8",
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

vincent@vincent-ubuntu:~$ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US.UTF-8
LC_CTYPE=zh_CN.UTF-8
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
vincent@vincent-ubuntu:~$

vincent@vincent-ubuntu:/usr/lib/gtk-2.0/2.10.0/immodule-files.d$ vi libgtk2.0-0.immodules
"/usr/lib/gtk-2.0/2.10.0/immodules/im-xim.so"
"xim" "X Input Method" "gtk20" "/usr/share/locale" "en:ko:ja:th:zh"
头像
roxette
帖子: 25
注册时间: 2006-08-06 22:01
送出感谢: 0
接收感谢: 0

Re: 英文环境下fcitx输入法的问题

#8

帖子 roxette » 2009-02-16 22:19

要装个中文输入法,随便啥不限制成拼音,否则会出现错误的

sudo aptitude install im-switch
sudo apt-get install scim-pinyin
sudo im-switch -s scim -z all_ALL
im-switch -s scim -z all_ALL
教者,上所施,下所效。
头像
mymathersname
帖子: 2870
注册时间: 2008-09-18 23:40
系统: Ubuntu 15.04 x64
来自: Mars
送出感谢: 1 次
接收感谢: 1 次

Re: 英文环境下fcitx输入法的问题

#9

帖子 mymathersname » 2009-02-16 22:59

怎么把简单的事搞的那么麻烦呢,我装fcitx,前后不要2分钟……
转移各位校内,百毒朋友,把目标转向twitter和facebook,别总看局域网的内容
其实从那么多的ubuntu发行版和fedora的各个发行版中,我们不难看出,linux的进步是惊人的,从长久的发展规律和更加深远的意义来看,linux桌面版与微软的距离在缩小,这是值得庆幸的……
ubuntu是半年还去偷情一次的初恋。fedora是一生挚爱的正室。debian是和正室同等地位的妾侍。rh/cent是用来偷窥的正室大姐姐。suse是一夜夫妻百二蚊。gentoo是有内涵的才女。arch是久闻其名不敢接触的怪叔叔。其余发行版,我是帝皇它们是屁民,无福宠幸。
头像
Ur@nus
帖子: 622
注册时间: 2006-12-01 23:02
送出感谢: 0
接收感谢: 0

Re: 英文环境下fcitx输入法的问题

#10

帖子 Ur@nus » 2009-02-17 23:18

楼主,问题解决了么?
holly2k
帖子: 86
注册时间: 2008-08-13 20:11
送出感谢: 0
接收感谢: 0

Re: 英文环境下fcitx输入法的问题

#11

帖子 holly2k » 2009-02-21 1:23

Ur@nus 写了:楼主,问题解决了么?
问题终于解决啦,这也没办法的事啊,每个人的机器装出来问题都不一样,只希望我们能够解决问题后能给以后使用的人一点提示
头像
yilan198711
帖子: 1628
注册时间: 2008-06-22 13:38
来自: 武汉
送出感谢: 0
接收感谢: 0

Re: 英文环境下fcitx输入法的问题

#12

帖子 yilan198711 » 2009-02-22 14:14

how can u do it ?!
mint+gnome
dwyane.xia
帖子: 3
注册时间: 2009-01-18 0:34
送出感谢: 0
接收感谢: 0

Re: 英文环境下fcitx输入法的问题

#13

帖子 dwyane.xia » 2009-04-17 17:21

I had the same problem ,how did you solve it at last?
dwyane.xia
帖子: 3
注册时间: 2009-01-18 0:34
送出感谢: 0
接收感谢: 0

Re: 英文环境下fcitx输入法的问题

#14

帖子 dwyane.xia » 2009-04-17 17:24

by the way ,I can see the toolbar when I am logging out and logging in ,but I can use them anyway.
回复

回到 “字体美化和中文支持”