当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu8.10 64位 编译安装ibus完整过程
帖子发表于 : 2009-03-04 17:42 

注册: 2009-01-14 21:53
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
参考及感谢:
viewtopic.php?f=8&t=167881
viewtopic.php?f=8&t=147333&st=0&sk=t&sd=a
viewtopic.php?f=8&t=183341

安装步骤记录:
sudo apt-get install python-enchant
sudo apt-get install python-gtk2-dev
sudo apt-get install libgtk2.0-dev
sudo apt-get install libdbus-1-dev libdbus-glib-1-dev
sudo apt-get install automake
sudo apt-get install libtool
sudo apt-get install libgconf2-dev
sudo apt-get install git
sudo apt-get install git-core
sudo apt-get install gtk-doc-tools
对比参考文档 sudo apt-get install python-dbus 不要执行 原因见后

安装ibus
$ git clone git://github.com/phuang/ibus.git ibus
$ cd ibus
$ ./autogen.sh --prefix=/usr --with-gtk-im-module-dir=/usr/lib/gtk-2.0/2.10.0/immodules/ --enable-pygconf


##############错误的分割线##################
按照参考文档执行到这步出现错误如下:
can not find dbus-python >= 0.83.0

分析原因:版本不对(废话)
解决办法:我的源用的是成都科技大学的,其他源我不知道,反正我更新不了0.83.0,只能下载自己编译安装
下载地址:http://packages.ubuntu.com/zh-cn/source/jaunty/dbus-python
解压后执行:
./configure
make
make install

再执行./autogen.sh --prefix=/usr --with-gtk-im-module-dir=/usr/lib/gtk-2.0/2.10.0/immodules/ --enable-pygconf 通过
###############错误解决的分割线#################


$ make
$ sudo make install
$ update-gtk-immodules `uname -i`

安装拼音:
$ git clone git://github.com/phuang/ibus-pinyin.git ibus-pinyin
$ cd ibus-pinyin
$ ./autogen.sh --prefix=/usr
$ make
$ sudo make install


运行ibus
applications - accessories - ibus (程序 - 附件 - iBus)就可以运行拉。

测试:
GTK_IM_MODULE=ibus gedit

配置:
编辑/usr/lib/gtk-2.0/2.10.0/immodule-files.d/libgtk2.0-0.immodules
sudo vi /usr/lib/gtk-2.0/2.10.0/immodule-files.d/libgtk2.0-0.immodules
在文件到最后添加两行:
"/usr/lib/gtk-2.0/2.10.0/immodules/im-ibus.so"
"ibus" "X Input Method" "gtk20" "/usr/share/locale" "zh"

在~/.profile尾部,填写:
export XMODIFIERS=@im=ibus
export GTK_IM_MODULE=ibus
export QT_IM_MODULE=ibus

在~/.bashrc尾部,填写:
export XMODIFIERS=@im=ibus
export GTK_IM_MODULE=ibus
export QT_IM_MODULE=ibus

结论 这个输入法确实好用,但是这个安装的过程也太```
如果不是64位貌似应该有deb可以直接安装
记得论坛上某位仁兄说过“ 64位 你们慢慢玩吧 ”


页首
 用户资料  
 
2 楼 
 文章标题 : Re: ubuntu8.10 64位 编译安装ibus完整过程
帖子发表于 : 2009-03-04 23:17 

注册: 2008-11-03 15:31
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
:em11 很详细啊,辛苦了。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ubuntu8.10 64位 编译安装ibus完整过程
帖子发表于 : 2009-03-05 18:00 

注册: 2009-01-14 21:53
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
学习的过程 给大家共享一下 看了别人写的东西才学到的


页首
 用户资料  
 
4 楼 
 文章标题 : Re: ubuntu8.10 64位 编译安装ibus完整过程
帖子发表于 : 2009-03-05 19:15 
头像

注册: 2007-11-29 9:41
帖子: 8455
送出感谢: 0 次
接收感谢: 0 次
mark一下,听说比较慢?


页首
 用户资料  
 
5 楼 
 文章标题 : Re: ubuntu8.10 64位 编译安装ibus完整过程
帖子发表于 : 2009-03-06 8:21 

注册: 2009-01-14 21:53
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
64位的电脑CPU主频都不会太低吧,不过内存确实要大一些,我的是4G内存没有感觉慢太多


页首
 用户资料  
 
6 楼 
 文章标题 : Re: ubuntu8.10 64位 编译安装ibus完整过程
帖子发表于 : 2009-03-22 21:24 

注册: 2008-06-17 11:40
帖子: 127
送出感谢: 0 次
接收感谢: 0 次
代码:
jimogsh@jimogsh-desktop:~$ git clone git://github.com/phuang/ibus.git ibus
fatal: destination directory 'ibus' already exists.
jimogsh@jimogsh-desktop:~$ cd ibus
jimogsh@jimogsh-desktop:~/ibus$ ./autogen.sh --prefix=/usr --with-gtk-im-module-dir=/usr/lib/gtk-2.0/2.10.0/immodules/ --enable-pygconf
bash: ./autogen.sh: 没有该文件或目录

执行到这里出现了问题,请楼主帮忙解决


页首
 用户资料  
 
7 楼 
 文章标题 : Re: ubuntu8.10 64位 编译安装ibus完整过程
帖子发表于 : 2009-03-22 21:43 

注册: 2008-06-17 11:40
帖子: 127
送出感谢: 0 次
接收感谢: 0 次
解决了,是没有仔细看下面的分隔线里的内容,重新弄了一遍好了,可惜慢的不行……


页首
 用户资料  
 
8 楼 
 文章标题 : Re: ubuntu8.10 64位 编译安装ibus完整过程
帖子发表于 : 2009-03-22 21:59 
头像

注册: 2007-10-23 12:54
帖子: 1689
送出感谢: 0 次
接收感谢: 13
最后一句甚好。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译