当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求助:fcitx通过svn编译安装,但系统更新时被覆盖?[附svn编译安装]
帖子发表于 : 2009-04-06 1:07 

注册: 2008-08-02 13:01
帖子: 122
送出感谢: 0 次
接收感谢: 0 次
我前天通过svn编译安装了fcitx,svn版本203,成功后,fcitx显示3.6.0- 090326,昨晚更新系统内核至2.6.28.11-40(从38升级到40),后台自动下载并安装的,没注意fcitx是否在里面,就直接更新了,今天打字的时候发现fcitx的版本又变成那个3.6.0-RC类似的了。

我的疑问:哪里出错了?如何避免?


请老鸟忽略以下
:em09
附fctix的svn编译安装,很简单的啊,一步一步来,我也是新手的:)

1
先安装svn
引用:
sudo apt-get install subversion

我的安装没有依赖要弄,如果有的话,搜索解决。。。或者看wiki中的介绍http://wiki.ubuntu.org.cn/SubVersion
:em06
2
svn源码
引用:


3
编译安装
执行步骤2后在当前目录下生成一个trunk文件夹,开个终端,CD到trunk文件夹。
依次执行以下命令,不到三分钟就可以搞定。
引用:
./autogen.sh
./configure
make
sudo make install (要sudo,否则会报错)


4 使用
开个终端,或者alt +F2,输入fcitx,用ctrl+space调出fcitx,再ctrl+5刷新配置一下。
我的情况是table.conf没有放在~/.fcitx内,所以多余的码表又出现了,cp一个到~/.fcitx目录下再刷新一下就完美使用了。
5 感受
svn编译的fcitx,速度明显加快,用源里面的话,调出fcitx打第一个字或者词组时反应有点慢,现在几乎感觉不到滞后。
引用:
/svn/trunk$ svn update
At revision 211.


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 求助:fcitx通过svn编译安装,但系统更新时被覆盖?[附svn编译安装]
帖子发表于 : 2009-04-06 14:43 
头像

注册: 2006-09-10 16:06
帖子: 1456
送出感谢: 0 次
接收感谢: 0 次
步骤好像没有什么错的,我也这样弄,但是,我不make install,而是把它打包成deb包,既然用基于Debian的系统,就用deb包吧,哪天我要是会弄LFS了,我就用make install的方式:)

就算更新之后被还原,也不可能还原到3.6.0-RC,因为源里的fcitx还是3.4的吧,几百年没有更新了。

是不是你make install的时候的问题,有没有把该替换的程序替换掉呢?反正我用deb包来装的话,没有遇到过这样的问题。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 求助:fcitx通过svn编译安装,但系统更新时被覆盖?[附svn编译安装]
帖子发表于 : 2009-04-06 18:10 

注册: 2008-08-02 13:01
帖子: 122
送出感谢: 0 次
接收感谢: 0 次
fcitx girldog 3.6.0-RC 是我以前自己下载源码手动编译的,弄的时候还不会用svn 。。。
alpha.gu 写道:
步骤好像没有什么错的,我也这样弄,但是,我不make install,而是把它打包成deb包,既然用基于Debian的系统,就用deb包吧,哪天我要是会弄LFS了,我就用make install的方式:)

就算更新之后被还原,也不可能还原到3.6.0-RC,因为源里的fcitx还是3.4的吧,几百年没有更新了。

是不是你make install的时候的问题,有没有把该替换的程序替换掉呢?反正我用deb包来装的话,没有遇到过这样的问题。

谢谢你的建议。现在的情况又复杂了 :em20
1
即使没有更新,重启后,fcitx的图标也变成了fcitx girldog 3.6.0-RC ,
2
正常开机后,通过systerm monitor 干掉fcitx,然后alt+F2,打开fcitx时,则显示fcitx 3.6.0-20090326
用fcitx -v 命令查看 信息如下:
引用:
fcitx -v
fcitx version: 3.6.0-090326-xft


3
在使用上和重启前并未发现大的差别,完全不影响使用,但总觉得有一些问题存在, :em06

继续求助。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 求助:fcitx通过svn编译安装,但系统更新时被覆盖?[附svn编译安装]
帖子发表于 : 2009-04-07 9:47 
头像

注册: 2008-12-25 23:33
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
非常烦!!我又换回Sicm了 :em20


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 求助:fcitx通过svn编译安装,但系统更新时被覆盖?[附svn编译安装]
帖子发表于 : 2009-07-25 15:49 
头像

注册: 2007-05-08 16:26
帖子: 2058
地址: 火星内核某分子内某原子核内
系统: arch
送出感谢: 20
接收感谢: 6
fcitx(小企鹅)3.6.0编译安装 viewtopic.php?f=95&t=180518


_________________
笔记本 :
F208S : gentoo
A460P i3G D6 : UBUNTU + WIN7
UN43D1 : UBUNTU + WIN7
1000人超级QQ群 LINUX + WIN : 31465544 或 18210387


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 求助:fcitx通过svn编译安装,但系统更新时被覆盖?[附svn编译安装]
帖子发表于 : 2009-07-25 16:07 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
要用新版本,最好把老版本都卸掉,肯定万无一失,不过余懒人,用的是Alpha.pu打的deb包。 :em05
./configure --prefix=/usr


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Bing [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译