创建 nightly build 文泉驿 deb 包 (shell script)

系统字体配置、中文显示和输入法问题
回复
carlosliu
帖子: 2
注册时间: 2006-07-12 21:33
送出感谢: 0
接收感谢: 0

创建 nightly build 文泉驿 deb 包 (shell script)

#1

帖子 carlosliu » 2006-07-12 22:18

For Ubuntu dapper and edgy:

代码: 全选

wget http://chinese.alioth.debian.org/xfonts-wqy/build_wqy_for_ubuntu.sh
chmod +x build_wqy_for_ubuntu.sh
./build_wqy_for_ubuntu.sh
DONE.

For Debian etch and sid:

代码: 全选

wget http://chinese.alioth.debian.org/xfonts-wqy/build_wqy_for_debian.sh
chmod +x build_wqy_for_debian.sh
./build_wqy_for_debian.sh
头像
islet8
帖子: 76
注册时间: 2006-04-09 15:21
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 islet8 » 2006-07-13 15:31

这个脚本太棒了!
头像
arbor
帖子: 312
注册时间: 2006-04-18 20:49
来自: 苏州
送出感谢: 1 次
接收感谢: 1 次
联系:

#3

帖子 arbor » 2006-07-13 15:49

这需要系统再安装很多东西,这些东西以后还有用吗?能否在安装完成后删除?如何删除?
自行车运动摄影、足球摄影照片分享
qiaomu.org
头像
arbor
帖子: 312
注册时间: 2006-04-18 20:49
来自: 苏州
送出感谢: 1 次
接收感谢: 1 次
联系:

#4

帖子 arbor » 2006-07-13 15:52

如果已经通过源安装了0.6的可以直接用这个升级吗?
自行车运动摄影、足球摄影照片分享
qiaomu.org
carlosliu
帖子: 2
注册时间: 2006-07-12 21:33
送出感谢: 0
接收感谢: 0

#5

帖子 carlosliu » 2006-07-15 11:11

这需要系统再安装很多东西,这些东西以后还有用吗?能否在安装完成后删除?如何删除?
这个脚本似乎不需要安装很多东西吧,只是几个小工具而已。

arbor 写了:如果已经通过源安装了0.6的可以直接用这个升级吗?
这里只提供了编译脚本,一般情况下建议您直接安装 edgy 中的 xfonts-wqy。
头像
islet8
帖子: 76
注册时间: 2006-04-09 15:21
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 islet8 » 2006-07-15 15:15

运行这个脚本后按照它的提示,先sudo apt dep** xfonts-wqy(具体我忘了,现在不在linux下,脚本提示很详细的)
然后再回来输入y后开始下载wqy包,之后它会产生一个deb,但似乎每次都不是它提示中的那个文件名,所以自己打一下命令吧:sudo dpkg -i ****.deb(忘了是不是这样的@@,看提示里的格式即可)
然后sudo gedit /etc/fonts/language-selector.conf把所有文泉驿提到那个系统默认宋体(uming)的前面,再稍微配置下,具体看
viewtopic.php?t=18638&highlight=
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

#7

帖子 dogfox » 2006-11-07 23:42

是tar文档啊?
不是有deb的吗?
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员
wooin
帖子: 37
注册时间: 2006-11-15 11:50
送出感谢: 0
接收感谢: 0

#8

帖子 wooin » 2006-12-03 19:46

wooin@FOX:~$ ./build_wqy_for_ubuntu.sh
//////////////////////////////////////////////////////////////
// Please run apt-get build-dep xfonts-wqy to get
// build-depend packages. You also need dpkg-dev and
// fakeroot.
Do you have them? (y/n)
y
Continue...
//////////////////////////////////////////////////////////////
// Cleaning last build...
// Getting info from ubuntu.com ...
// Found error



请教高人。。。这是怎么回事阿。。。。
头像
hanscowboy
帖子: 135
注册时间: 2006-12-05 14:42
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 hanscowboy » 2006-12-09 20:22

6.10 ubuntu 可以使用吗?
star_s
帖子: 24
注册时间: 2006-10-11 19:09
送出感谢: 0
接收感谢: 0

#10

帖子 star_s » 2007-01-25 15:39

试试 :P
热爱开源……
头像
Element
论坛版主
帖子: 3537
注册时间: 2005-09-10 16:04
来自: DG-GD-China
送出感谢: 0
接收感谢: 0

#11

帖子 Element » 2007-02-21 1:28

WQY先在有deb的包下载了哦
http://element.blog.ubuntu.org.cn/
Ubuntu Jaunty Jackalope...
AMD Barton 2600+
MSI K7N2 Delta-L
Kingston DDR400 512M*2+256M*1
nVidia FX5200
Seagate 80G(Jaunty Jackalope)
Seagate 160G(XXxxXX)
SyncMaster 732N
回复

回到 “字体美化和中文支持”