当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 23 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : gedit不能显示GB2312文件
帖子发表于 : 2006-08-12 2:34 

注册: 2006-08-12 2:15
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
您们好!我是在在 en_US.UTF-8 locale 下执行。
yccheok@yccheok-desktop:~/Desktop$ locale | grep LANG=

我相信我以安装了GB2312 locale

yccheok@yccheok-desktop:~/Desktop$ sudo dpkg-reconfigure locales
Generating locales...
en_AU.UTF-8... up-to-date
en_BW.UTF-8... up-to-date
en_CA.UTF-8... up-to-date
en_DK.UTF-8... up-to-date
en_GB.UTF-8... up-to-date
en_HK.UTF-8... up-to-date
en_IE.UTF-8... up-to-date
en_IN.UTF-8... up-to-date
en_NZ.UTF-8... up-to-date
en_PH.UTF-8... up-to-date
en_SG.UTF-8... up-to-date
en_US.UTF-8... up-to-date
en_ZA.UTF-8... up-to-date
en_ZW.UTF-8... up-to-date
zh_CN.GB2312... up-to-date
zh_CN.UTF-8... up-to-date
zh_HK.UTF-8... up-to-date
zh_SG.UTF-8... up-to-date
zh_TW.UTF-8... up-to-date
Generation complete.

我有些文件,在firefox下的GB2312 encoding,能显示出来。可当我用gedit 或是vi, 就是乱码。 :(

请问各位有什么建议吗?我需要在en_US.UTF-8环境下执行,可又能编辑GB2312文件。。。

谢谢


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-08-12 7:13 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
gedit在打开文件的时候有编码选择,你选择正确的编码好了。

至于vim就更方便了,在你的.vimrc中加上下面的代码,以后就会自动检测编码了。

代码:
let &termencoding=&encoding
set fileencodings=utf-8,gbk,ucs-bom,cp936


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-08-13 16:29 

注册: 2006-08-12 2:15
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
可否告诉我要如何在gedit编码选择?谢谢


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-08-14 8:43 

注册: 2006-04-13 13:53
帖子: 305
送出感谢: 0 次
接收感谢: 1
在哪里进行编码选择?我也想知道。

karron 写道:
gedit在打开文件的时候有编码选择,你选择正确的编码好了。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-08-14 9:19 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
gedit的打开文件的对话框,就那么几个控件在上面,好好找找。好像是左下角有个编码选择。


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
6 楼 
 文章标题 : Re: gedit不能显示GB2312文件
帖子发表于 : 2009-08-18 23:46 

注册: 2009-08-14 22:14
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
ubuntu默认的打开.txt文件用的是gedit,可gedit默认编码是UTF8,打开windows下编辑的gb2312的文档都是乱码。解决方法之一就是把gedit的编码改为GB2312,方法如下:

  在“应用程序”菜单上点右键,选择“编辑菜单”.在主菜单的对话框中勾选系统工具-配置编辑器,并从应用程序菜单中开启。

  依次开启 /apps/gedit-2/preferences/encodings/双击右侧auto_detected,在弹出对话框中点选Add,添加Values值为GB2312,确定后选中,点选Up按钮将其移至第一位。

  同样方法,对show_in_menu进行设置,并将GB2312置于首位。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: gedit不能显示GB2312文件
帖子发表于 : 2009-09-08 12:46 

注册: 2009-06-19 1:45
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
myzod 写道:
ubuntu默认的打开.txt文件用的是gedit,可gedit默认编码是UTF8,打开windows下编辑的gb2312的文档都是乱码。解决方法之一就是把gedit的编码改为GB2312,方法如下:

  在“应用程序”菜单上点右键,选择“编辑菜单”.在主菜单的对话框中勾选系统工具-配置编辑器,并从应用程序菜单中开启。

  依次开启 /apps/gedit-2/preferences/encodings/双击右侧auto_detected,在弹出对话框中点选Add,添加Values值为GB2312,确定后选中,点选Up按钮将其移至第一位。

  同样方法,对show_in_menu进行设置,并将GB2312置于首位。


这个方法不错,非常感谢:)


页首
 用户资料  
 
8 楼 
 文章标题 : Re: gedit不能显示GB2312文件
帖子发表于 : 2009-09-08 21:17 
头像

注册: 2007-05-23 20:38
帖子: 309
地址: 鍟.
送出感谢: 0 次
接收感谢: 0 次
换装leafpad


页首
 用户资料  
 
9 楼 
 文章标题 : Re: gedit不能显示GB2312文件
帖子发表于 : 2009-09-08 21:19 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
ancintosh 写道:
换装leafpad

leafpad同荐,X下修改配置文件必备。


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
10 楼 
 文章标题 : Re: gedit不能显示GB2312文件
帖子发表于 : 2009-09-16 22:32 

注册: 2006-10-18 15:48
帖子: 700
送出感谢: 0 次
接收感谢: 0 次
gedit默认只能UTF-8编码的文件,通过gconf可以设置其编码检测的编码列表,以达到自动识别编码的效果。

gconftool-2 --set --type=list --list-type=string /apps/gedit-2/preferences/encodings/auto_detected "[UTF-8,CURRENT,GBK,BIG5-HKSCS,UTF-16]"


一条命令搞定


页首
 用户资料  
 
11 楼 
 文章标题 : Re: gedit不能显示GB2312文件
帖子发表于 : 2009-09-16 22:36 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
sunzhaoyu2000 写道:
gedit默认只能UTF-8编码的文件,通过gconf可以设置其编码检测的编码列表,以达到自动识别编码的效果。

gconftool-2 --set --type=list --list-type=string /apps/gedit-2/preferences/encodings/auto_detected "[UTF-8,CURRENT,GBK,BIG5-HKSCS,UTF-16]"


一条命令搞定

楼上这招一键搞定gedit编码的方法不错。复制之。 :em11


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
12 楼 
 文章标题 : Re: gedit不能显示GB2312文件
帖子发表于 : 2009-09-18 2:14 
头像

注册: 2009-03-22 22:29
帖子: 34
送出感谢: 1
接收感谢: 0 次
sunzhaoyu2000 写道:
gedit默认只能UTF-8编码的文件,通过gconf可以设置其编码检测的编码列表,以达到自动识别编码的效果。

gconftool-2 --set --type=list --list-type=string /apps/gedit-2/preferences/encodings/auto_detected "[UTF-8,CURRENT,GBK,BIG5-HKSCS,UTF-16]"


一条命令搞定


:em11 太感谢了 :em11


_________________
你们啊图样图森破啊
通过这里注册DropBox不仅不会怀孕,而且还会比别人多0.5G!
点这里传送去我的BLOG

    2009年DIY的台式机
  • AMD Athlon 5200+
  • Kingston DDRII 800 2G
  • Sapphire HD4650


页首
 用户资料  
 
13 楼 
 文章标题 : Re: gedit不能显示GB2312文件
帖子发表于 : 2009-09-18 9:03 
头像

注册: 2008-11-21 20:26
帖子: 36913
送出感谢: 1
接收感谢: 36
我只会第一种方法改gedit编码识别
另外,改系统设置我只会用nano。。。


_________________
讨厌我的人可以试着点一下
浏览全部ubuntu技巧


页首
 用户资料  
 
14 楼 
 文章标题 : Re: gedit不能显示GB2312文件
帖子发表于 : 2009-09-18 9:29 
头像

注册: 2007-05-08 16:26
帖子: 2058
地址: 火星内核某分子内某原子核内
系统: arch
送出感谢: 20
接收感谢: 6
gedit乱码: 打开终端:gconftool-2 --set --type=list --list-type=string /apps/gedit-2/preferences/encodings/auto_detected "[UTF-8,CURRENT,GBK,BIG5-HKSCS,UTF-16]" 通过gconf设置

或用vim,比gedit专业多了。
vim的配置文件里写:
set fileencodings=ucs-bom,utf-8,cp936,gb18030,iso-8859-1
set encoding=utf-8


_________________
笔记本 :
F208S : gentoo
A460P i3G D6 : UBUNTU + WIN7
UN43D1 : UBUNTU + WIN7
1000人超级QQ群 LINUX + WIN : 31465544 或 18210387


页首
 用户资料  
 
15 楼 
 文章标题 : Re: gedit不能显示GB2312文件
帖子发表于 : 2009-09-28 14:39 
头像

注册: 2009-04-09 15:06
帖子: 673
送出感谢: 0 次
接收感谢: 13
sunzhaoyu2000 写道:
gedit默认只能UTF-8编码的文件,通过gconf可以设置其编码检测的编码列表,以达到自动识别编码的效果。

gconftool-2 --set --type=list --list-type=string /apps/gedit-2/preferences/encodings/auto_detected "[UTF-8,CURRENT,GBK,BIG5-HKSCS,UTF-16]"


一条命令搞定

3Q :em11


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 23 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译