当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [求助]中文 locale 菜单不显示中文,怎么办?
帖子发表于 : 2009-09-30 13:45 
头像

注册: 2009-04-11 23:46
帖子: 4030
系统: Arch Linux
送出感谢: 11
接收感谢: 110
本人一同学在本人的教唆下装了U,起初一切良好,可据说在换源升级之后就无法显示中文了(源已经换回来了)。具体症状如下:

$LANG=zh_CN.UTF-8
登录界面为英文,无论选择什么语言
Gnome主菜单、nautilus 为英文
大部分程序,如火狐、Opera、GVIM、一些命令行程序的输出为正常的中文
KDE为中文

重装过中文语言包,包括在新立得里把所有带zh的包(特定软件的除外)重装过,无效。

谁能告诉我怎么办?


_________________
我的博客 http://blog.lilydjwg.me/
Dropbox,你值得拥有。
提问的智慧
Arch Linux 中文论坛

我的vimrc: http://git.io/vimrc


页首
 用户资料  
 
2 楼 
 文章标题 : Re: [求助]中文 locale 菜单不显示中文,怎么办?
帖子发表于 : 2009-09-30 13:57 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
骂你同学 :em06 ,那个版本 什么装的


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
3 楼 
 文章标题 : Re: [求助]中文 locale 菜单不显示中文,怎么办?
帖子发表于 : 2009-09-30 14:05 
头像

注册: 2008-11-21 20:26
帖子: 36913
送出感谢: 1
接收感谢: 36
LZ同学罪大恶极啊


_________________
讨厌我的人可以试着点一下
浏览全部ubuntu技巧


页首
 用户资料  
 
4 楼 
 文章标题 : Re: [求助]中文 locale 菜单不显示中文,怎么办?
帖子发表于 : 2009-09-30 14:09 
头像

注册: 2008-02-17 23:47
帖子: 22109
地址: 美丽富饶的那啥星球
送出感谢: 11
接收感谢: 82
代码:
locale=zh_CN.UTF-8


_________________
明天就换大三八!
——8核CPU、8G内存、8T硬盘……
8卡交火,80寸大屏放8个……
IPv8的光纤要8条……

---------------------------------------------------------------------------------
[图片版]新手当自强(续)FAQ
[新手进阶]挂载、fstab、调整linux分区
[图片版]E17桌面环境配置手把手


页首
 用户资料  
 
5 楼 
 文章标题 : Re: [求助]中文 locale 菜单不显示中文,怎么办?
帖子发表于 : 2009-09-30 17:07 
头像

注册: 2009-04-11 23:46
帖子: 4030
系统: Arch Linux
送出感谢: 11
接收感谢: 110
leeaman 写道:
骂你同学 :em06 ,那个版本 什么装的

9.04呗,安装好久了,因为那些e文而被闲置好一段时间了


_________________
我的博客 http://blog.lilydjwg.me/
Dropbox,你值得拥有。
提问的智慧
Arch Linux 中文论坛

我的vimrc: http://git.io/vimrc


页首
 用户资料  
 
6 楼 
 文章标题 : Re: [求助]中文 locale 菜单不显示中文,怎么办?
帖子发表于 : 2009-09-30 17:09 
头像

注册: 2009-04-11 23:46
帖子: 4030
系统: Arch Linux
送出感谢: 11
接收感谢: 110
adagio 写道:
代码:
locale=zh_CN.UTF-8

这个会有用吗?看起来他的locale是zh_CN.UTF-8啊,有部分软件正常的。而且,我的也没有这个变量只有LANG也没出问题呀。
怀疑是不是Gnome的某个配置文件出问题了?


_________________
我的博客 http://blog.lilydjwg.me/
Dropbox,你值得拥有。
提问的智慧
Arch Linux 中文论坛

我的vimrc: http://git.io/vimrc


页首
 用户资料  
 
7 楼 
 文章标题 : Re: [求助]中文 locale 菜单不显示中文,怎么办?
帖子发表于 : 2009-10-01 19:40 
头像

注册: 2009-04-11 23:46
帖子: 4030
系统: Arch Linux
送出感谢: 11
接收感谢: 110
终于解决了,是某些.mo文件的问题,从另外的一个目录ln -s一下就好了。


_________________
我的博客 http://blog.lilydjwg.me/
Dropbox,你值得拥有。
提问的智慧
Arch Linux 中文论坛

我的vimrc: http://git.io/vimrc


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译