[问题]使用fcitx输入法没有双拼

系统字体配置、中文显示和输入法问题
回复
zhrb
帖子: 53
注册时间: 2005-09-05 17:04
送出感谢: 0
接收感谢: 0

[问题]使用fcitx输入法没有双拼

#1

帖子 zhrb » 2006-09-12 2:44

使用apt-get install fcitx安装的输入法为什么没有双拼呢?
我在RedHat底下装的都有.
头像
ulixer
帖子: 231
注册时间: 2006-03-02 23:51
送出感谢: 0
接收感谢: 1 次

#2

帖子 ulixer » 2006-09-12 16:40

可能要修改~/.fcitx/config文件,这个文件是中文gb2312编码的
具体可以到/usr/share/doc/fcitx/下看那个压缩的pdf文档
zhrb
帖子: 53
注册时间: 2005-09-05 17:04
送出感谢: 0
接收感谢: 0

#3

帖子 zhrb » 2006-09-12 18:54

奇怪我用vim怎么显示的是乱吗?
用GEDIT可以打开
ulixer 写了:可能要修改~/.fcitx/config文件,这个文件是中文gb2312编码的
具体可以到/usr/share/doc/fcitx/下看那个压缩的pdf文档
头像
ulixer
帖子: 231
注册时间: 2006-03-02 23:51
送出感谢: 0
接收感谢: 1 次

#4

帖子 ulixer » 2006-09-12 19:43

把这一行加入.vimrc中去,以后打开gb编码的文件就不会乱码
set fileencodings=ucs-bom,utf-8,chinese,latin1
zhrb
帖子: 53
注册时间: 2005-09-05 17:04
送出感谢: 0
接收感谢: 0

#5

帖子 zhrb » 2006-09-12 21:23

果然可以了,高手啊
不过还有一个问题
vimtutor启动以后为什么显示的中文还是乱码?
ulixer 写了:把这一行加入.vimrc中去,以后打开gb编码的文件就不会乱码
set fileencodings=ucs-bom,utf-8,chinese,latin1
头像
ulixer
帖子: 231
注册时间: 2006-03-02 23:51
送出感谢: 0
接收感谢: 1 次

#6

帖子 ulixer » 2006-09-13 14:20

打开vimtutor后试试
:set encoding=utf-8 或 :set encoding=gb2312试试

vimtutor看一遍就差不多了,应该没什么影响
zhrb
帖子: 53
注册时间: 2005-09-05 17:04
送出感谢: 0
接收感谢: 0

#7

帖子 zhrb » 2006-09-17 21:12

设置了一下,好象这两个都没什么作用.
不知道到底是怎么回事
我的locale如下:
LANG=zh_CN.UTF-8
LANGUAGE=zh_CN:zh:en_US:en
LC_CTYPE=zh_CN.UTF-8
LC_NUMERIC="zh_CN.UTF-8"
LC_TIME="zh_CN.UTF-8"
LC_COLLATE="zh_CN.UTF-8"
LC_MONETARY="zh_CN.UTF-8"
LC_MESSAGES="zh_CN.UTF-8"
LC_PAPER="zh_CN.UTF-8"
LC_NAME="zh_CN.UTF-8"
LC_ADDRESS="zh_CN.UTF-8"
LC_TELEPHONE="zh_CN.UTF-8"
LC_MEASUREMENT="zh_CN.UTF-8"
LC_IDENTIFICATION="zh_CN.UTF-8"
LC_ALL=

ulixer 写了:打开vimtutor后试试
:set encoding=utf-8 或 :set encoding=gb2312试试

vimtutor看一遍就差不多了,应该没什么影响
头像
ulixer
帖子: 231
注册时间: 2006-03-02 23:51
送出感谢: 0
接收感谢: 1 次

#8

帖子 ulixer » 2006-09-17 21:47

今天上网好像看到过这个问题,应该是vimtutor的问题,改一下vimtutor就行了
lz去搜一下吧

另外LC没有必要设那么多,默认用的是lang或LC_ALL的值
只有你要单独设某个的时候才用

具体可以看unicode-howto
zhrb
帖子: 53
注册时间: 2005-09-05 17:04
送出感谢: 0
接收感谢: 0

#9

帖子 zhrb » 2006-09-17 23:42

的确是vimtutor的问题
vimtutor不知道根据什么条件,自动调用了一个不知道什么编码的tutor,而不会调用vim.tutor.euc
ulixer 写了:今天上网好像看到过这个问题,应该是vimtutor的问题,改一下vimtutor就行了
lz去搜一下吧

另外LC没有必要设那么多,默认用的是lang或LC_ALL的值
只有你要单独设某个的时候才用

具体可以看unicode-howto
zhrb
帖子: 53
注册时间: 2005-09-05 17:04
送出感谢: 0
接收感谢: 0

#10

帖子 zhrb » 2006-09-18 19:44

换了一种方法,也算是曲线救国吧:

在 ~ 下编辑一个文件:
vitutor
内容如下:
rm -f ~/.tutor.zh.euc.swp
rm -f ~/tutor.zh.euc
cp -f /usr/share/vim/vimcurrent/tutor/tutor.zh.euc ~
cd ~
vim tutor.zh.euc

然后,chmod 777 vitutor

这样子以后执行vitutor,就自动打开一个新的tutor了
ulixer 写了:今天上网好像看到过这个问题,应该是vimtutor的问题,改一下vimtutor就行了
lz去搜一下吧

另外LC没有必要设那么多,默认用的是lang或LC_ALL的值
只有你要单独设某个的时候才用

具体可以看unicode-howto
回复

回到 “字体美化和中文支持”