当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu文本模式下中文显示乱码,该怎样解决?
帖子发表于 : 2010-01-10 15:37 

注册: 2009-10-24 9:35
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
RT。。。ubuntu文本模式下中文显示乱码,该怎样解决?谢谢!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: ubuntu文本模式下中文显示乱码,该怎样解决?
帖子发表于 : 2010-01-10 15:38 
头像

注册: 2008-11-21 20:26
帖子: 36913
送出感谢: 1
接收感谢: 36
啥叫文本模式?tty?terminal?还是gedit里面?


_________________
讨厌我的人可以试着点一下
浏览全部ubuntu技巧


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ubuntu文本模式下中文显示乱码,该怎样解决?
帖子发表于 : 2010-01-10 16:30 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
cli啊,开framebuffre,装zhcon或者别的可以显示中文的终端


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
4 楼 
 文章标题 : Re: ubuntu文本模式下中文显示乱码,该怎样解决?
帖子发表于 : 2010-06-20 18:27 

注册: 2010-05-16 13:35
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
例如按 Ctrl+Alt+F1登录进去就是文本模式了,我也在苦恼中文显示的问题


页首
 用户资料  
 
5 楼 
 文章标题 : Re: ubuntu文本模式下中文显示乱码,该怎样解决?
帖子发表于 : 2010-06-20 18:34 

注册: 2010-02-07 0:44
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
init 3 的?


页首
 用户资料  
 
6 楼 
 文章标题 : Re: ubuntu文本模式下中文显示乱码,该怎样解决?
帖子发表于 : 2010-06-23 22:17 

注册: 2009-04-29 13:45
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
我搜到了答案:在這里。在终端输入下文中的命令后,重新打开文件,会会到一个无法正确打开的提示。在所给出的左侧下拉框中选择gb180即可支持简体;big5可支持繁体。
原文地址:http://wiki.ubuntu.org.cn/Gedit中文乱码
原文:
Gedit中文乱码
缺省配置下,用 Ubuntu 的文本编辑器(gedit)打开 GB18030/GBK/GB2312 等类型的中文编码文本文件时,将会出现乱码。

出现这种情况的原因是,gedit 使用一个编码匹配列表,只有在这个列表中的编码才会进行匹配,不在这个列表中的编码将显示为乱码。您要做的就是将 GB18030 加入这个匹配列表。

命令行方式,适用于所有 Ubuntu 用户。
复制以下命令到终端中,然后回车即可:

gconftool-2 --set --type=list --list-type=string /apps/gedit-2/preferences/encodings/auto_detected "[UTF-8,CURRENT,GB18030,BIG5-HKSCS,UTF-16]"

图形化方式,适用于 Ubuntu 用户,而不适用于 KUbuntu/XUbuntu 用户。
您可以遵循以下步骤,使您的 gedit 正确显示中文编码文件。

按下 Alt-F2,打开“运行应用程序”对话框。
在文本框中键入“gconf-editor”,并按下回车键,打开“配置编辑器”。
展开左边的树节点,找到 /apps/gedit-2/preferences/encodings 节点并单击它。
双击右边的 auto_detected 键,打开“编辑键”对话框。
单击列表右边的“添加”按钮,输入“GB18030”,单击确定按钮。
列表的最底部新增加了一个“GB18030”。单击选中它,并单击右边的 “向上” 按钮直到 “GB18030” 位于列表的顶部为止。
单击确定按钮,关闭配置编辑器。
现在,您的 gedit 应该能够顺利打开 GB18030 编码的文本文件了。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: ubuntu文本模式下中文显示乱码,该怎样解决?
帖子发表于 : 2010-06-24 11:05 

注册: 2010-06-24 10:55
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
:em11 :em05 :em05


页首
 用户资料  
 
8 楼 
 文章标题 : Re: ubuntu文本模式下中文显示乱码,该怎样解决?
帖子发表于 : 2010-06-24 13:53 

注册: 2006-05-29 14:09
帖子: 120
送出感谢: 0 次
接收感谢: 0 次
:em48 每次看见2楼头像 我都后悔 点进那个帖子


页首
 用户资料  
 
9 楼 
 文章标题 : Re: ubuntu文本模式下中文显示乱码,该怎样解决?
帖子发表于 : 2010-10-26 4:18 
头像

注册: 2010-08-02 3:03
帖子: 68
送出感谢: 0 次
接收感谢: 0 次
MARK 学习了!


_________________
独醒者http://www.tosolos.com


页首
 用户资料  
 
10 楼 
 文章标题 : Re: ubuntu文本模式下中文显示乱码,该怎样解决?
帖子发表于 : 2011-12-19 9:09 
头像

注册: 2010-05-14 19:36
帖子: 76
送出感谢: 5
接收感谢: 0 次
以后统一下以后只要是文字模式就是TTY了

安装fbterm
代码:
sudo apt-get install fbterm

运行fbterm
代码:
sudo fbterm


看是不是中文了?


页首
 用户资料  
 
11 楼 
 文章标题 : Re: ubuntu文本模式下中文显示乱码,该怎样解决?
帖子发表于 : 2011-12-19 22:20 
头像

注册: 2009-02-23 14:37
帖子: 278
地址: 北京
送出感谢: 0 次
接收感谢: 0 次
如果非得进去cli,又不想有乱码,还能忍受英文的话,可以更改/etc/rc.conf中的LOCALE改为"en_US.UTF-8"

好像这个也会影响其他的一些东西,反正用完再改回来zh_CN.UTF-8就好了 :em05


_________________
ThinkPad X220i
i7-2620M CPU
8G DDR3 1333 RAM
INTEL SSDMCEAC180E3 - openSUSE 12.3 / Windows 7 Ultimate
HGST HTS725050A7E630 - main storage
咳咳。。。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译