[问题]为何安装jre-1_5_0_06-linux-i586.bin后firefox检测不到等?

系统字体配置、中文显示和输入法问题
回复
David.chen.0755
帖子: 13
注册时间: 2006-05-25 11:50
送出感谢: 0
接收感谢: 0

[问题]为何安装jre-1_5_0_06-linux-i586.bin后firefox检测不到等?

#1

帖子 David.chen.0755 » 2006-10-24 14:28

1。我安装的是Kubuntu 6.06,我在sun公司网站上下载了最新的jre-1_5_0_06-linux-i586.bin或jre-1_5_0_07-linux-i586.bin并安装(sudo /usr/jre-1_5_0_06-linux-i586.bin运行安装)后,LumaQQ能跑起来。但用FireFox打开网站http://www.668map.com/szmap时,总是说java插件没安装,不知何故?各位有安装了jre1.5.06或1.5.07的吗,请试着打开http://www.668map.com/szmap看,java虚拟机正常运行了么?

2。如果我用sudo apt-get install j2re1.4_1.4.2.02-1ubuntu3_i386.deb后,打开上述网站倒是java能运行了,但依据看到的一些文章却怎么也没能显示出汉字来,唉,都看过N篇文章了,也试过N次了。

BTW,我在虚拟机安装MagicLinux 2.0下,打开上述网站则一起正常(java及其中文),安装的好像是1.5.05的版本,不过MagicLinux好像是基于RedHat的linux版本,不知怎么配置的?

有自己成功安装jre-1_5_0_06-linux-i586.bin及其中文的网友能说说您的“一步一步的安装和配置”经验么?
gmlbh
帖子: 406
注册时间: 2006-03-21 10:47
送出感谢: 0
接收感谢: 0

#2

帖子 gmlbh » 2006-10-25 20:02

edgy的源里面的是jre-1_5_0_08了,我用起来好像没问题,好像也不用修改字体就能正确显示中文了。
David.chen.0755
帖子: 13
注册时间: 2006-05-25 11:50
送出感谢: 0
接收感谢: 0

#3

帖子 David.chen.0755 » 2006-10-27 9:22

楼上的:请问你的locale怎么设置的,我喜欢设置成en_US.UTF8,你是不是设成cn_ZH.xxx ?
CCIE15766
帖子: 21
注册时间: 2006-10-29 12:26
送出感谢: 0
接收感谢: 0

#4

帖子 CCIE15766 » 2006-10-29 15:13

SUN的网站上有安装说明,上边有怎样注册plugin for mozilla,你按照那个做一边就行了。

主要就是在firefox的plugin目录下建立一个链接到jre目录下几层子目录中的一个.so文件。


在UNIX世界要改掉你在windows上养成的那种从不看README和install instructions的毛病。
oldbeggar
帖子: 102
注册时间: 2006-01-19 13:14
送出感谢: 0
接收感谢: 0

#5

帖子 oldbeggar » 2006-11-01 10:54

我自己从sun网站上down的JDK,挺好用的啊~~~~
中文显示就是要改一下JRE获取字体的地方~
David.chen.0755
帖子: 13
注册时间: 2006-05-25 11:50
送出感谢: 0
接收感谢: 0

#6

帖子 David.chen.0755 » 2006-11-09 11:19

已解决,谢谢各位的意见!
wxhui163
帖子: 4
注册时间: 2006-11-09 4:30
送出感谢: 0
接收感谢: 0

#7

帖子 wxhui163 » 2006-12-04 18:26

:cry:
我也用你的这方法。下载jre。但是用不了QQ
能不能写下你的详细步骤啊。
安装JRE和LumaQQ的。我不喜欢从源上安装。
可能是还不知道上面说的那几个源到底怎么改吧
回复

回到 “字体美化和中文支持”