当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 一直困扰我的ibus在gnome的问题
帖子发表于 : 2010-08-22 16:25 
头像

注册: 2007-03-24 23:45
帖子: 2357
送出感谢: 0 次
接收感谢: 9
ubuntu 10.04,gnome
每次启动系统后,ibus都无法显示输入条,我要把ibus重启一遍才能显示输入条

而且,通知区域会强制显示ibus图标。
我到ibus的主页报告过bug,说是加载ibus太慢还是太快来的,把配置给忽略了,但是没说解决方法。

请问有解决方法吗?这个问题真的很郁闷!每次登录有都要重启ibus,烦死了!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 一直困扰我的ibus在gnome的问题
帖子发表于 : 2010-08-22 17:14 
头像

注册: 2010-06-04 1:06
帖子: 1791
送出感谢: 3
接收感谢: 5
要不,换fcitx吧 :em04


_________________
1. GIMP入门教程(1~7)——比Photoshop更棒的图像处理软件!
2. Ubuntu桌面培训——初级,新手入门必看


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 一直困扰我的ibus在gnome的问题
帖子发表于 : 2010-08-22 17:28 
头像

注册: 2007-03-24 23:45
帖子: 2357
送出感谢: 0 次
接收感谢: 9
fcitx 词库不行


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 一直困扰我的ibus在gnome的问题
帖子发表于 : 2010-08-22 19:01 
头像

注册: 2007-11-25 13:29
帖子: 7237
地址: 新疆博乐
系统: 14.04/16.04/Fedroa22
送出感谢: 37
接收感谢: 101
ibus 试过拼音没发现什么,平时基本用fcitx的五笔拼音


_________________
===新手请看===
Ubuntu 安装 | Ubuntu12.04/14.04/16.04 桌面操作指南
··Ubuntu16.04 安装图文教程(超简单)
····有时间就静下心来——折腾:)


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 一直困扰我的ibus在gnome的问题
帖子发表于 : 2010-08-23 2:33 

注册: 2009-01-08 21:44
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
用IBUS经常打不出字,经常要重启IBUS才行,郁闷啊!!!!


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 一直困扰我的ibus在gnome的问题
帖子发表于 : 2010-08-23 3:31 
头像

注册: 2010-05-27 1:50
帖子: 80
送出感谢: 0 次
接收感谢: 0 次
fanhe 写道:
ubuntu 10.04,gnome
每次启动系统后,ibus都无法显示输入条,我要把ibus重启一遍才能显示输入条

而且,通知区域会强制显示ibus图标。
我到ibus的主页报告过bug,说是加载ibus太慢还是太快来的,把配置给忽略了,但是没说解决方法。

请问有解决方法吗?这个问题真的很郁闷!每次登录有都要重启ibus,烦死了!



这个超级好解决。。。
新建一个sh写入下面内容
#!/bin/bash
ibus-daemon -rxd
保存为ibus restart.sh
在开机启动中添加此项,你开机就不会不加载你的配置了。。

关于使用中无法输入了 可以在 键盘快捷键里 新增一个 值为ibus-daemon -rxd 自己设一个快捷键如super+i ,出问题了 直接 按就好了 。。


_________________
DoubleX


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 一直困扰我的ibus在gnome的问题
帖子发表于 : 2010-08-24 15:27 

注册: 2010-07-23 13:11
帖子: 10
送出感谢: 0 次
接收感谢: 0 次
楼上的方法 不错,,

起码不用死等了,,,

:em04


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 一直困扰我的ibus在gnome的问题
帖子发表于 : 2010-08-24 15:29 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 274
当然是太慢。有些软件,启动后,没发现输入法。

继续scim


_________________
● 鸣学


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 一直困扰我的ibus在gnome的问题
帖子发表于 : 2010-08-28 15:28 
头像

注册: 2007-03-24 23:45
帖子: 2357
送出感谢: 0 次
接收感谢: 9
用了6楼的方法,登录后,sleep 15秒后自动重启一次
这问题真是蛋疼


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 一直困扰我的ibus在gnome的问题
帖子发表于 : 2010-08-28 16:31 
头像

注册: 2009-10-15 19:32
帖子: 394
送出感谢: 0 次
接收感谢: 1
opensuse的ibus没这个问题阿。。我用的kde


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 一直困扰我的ibus在gnome的问题
帖子发表于 : 2010-08-28 22:27 
头像

注册: 2010-05-27 1:50
帖子: 80
送出感谢: 0 次
接收感谢: 0 次
fanhe 写道:
用了6楼的方法,登录后,sleep 15秒后自动重启一次
这问题真是蛋疼

会么?你有在里边加数字么?


_________________
DoubleX


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 一直困扰我的ibus在gnome的问题
帖子发表于 : 2010-08-29 1:34 
头像

注册: 2007-03-24 23:45
帖子: 2357
送出感谢: 0 次
接收感谢: 9
mrx8836350 写道:
fanhe 写道:
用了6楼的方法,登录后,sleep 15秒后自动重启一次
这问题真是蛋疼

会么?你有在里边加数字么?

可能我表达有误了,反正算是解决了

原因是ibus启动太快了,gconf还没启动,ibus就启动了,所以没有读到配置
ibus有选项能等所有进程启动完在启动吗


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 一直困扰我的ibus在gnome的问题
帖子发表于 : 2010-09-01 23:25 
头像

注册: 2010-07-17 0:00
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
呵呵,这问题也困扰我好久了。终于找到了答案。 :em04
小声问一下,#!/bin/bash是什么意思?


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 一直困扰我的ibus在gnome的问题
帖子发表于 : 2010-09-02 12:53 
头像

注册: 2007-01-10 11:42
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
:em04


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译