当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 39 篇帖子 ]  前往页数 1, 2, 3  下一页
作者 内容
1 楼 
 文章标题 : Ubuntu10.04使用Chrome,输入法问题
帖子发表于 : 2010-10-05 6:36 

注册: 2008-08-20 7:36
帖子: 298
送出感谢: 0 次
接收感谢: 0 次
只要删除后,就必须切换输入法才能输入字,否则打不了字。
请教有没有解决的办法。
非常感谢~


_________________
Thinkpad SL410k
Ubuntu 10.04 LTS
远离那害人的Windows!!!


页首
 用户资料  
 
2 楼 
 文章标题 : Re: Ubuntu10.04使用Chrome,输入法问题
帖子发表于 : 2010-10-05 7:25 

注册: 2009-04-01 0:04
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
sudo apt-get update;
sudo apt-get dist-upgrade
即可


页首
 用户资料  
 
3 楼 
 文章标题 : Re: Ubuntu10.04使用Chrome,输入法问题
帖子发表于 : 2010-10-06 19:04 

注册: 2006-09-25 15:08
帖子: 169
送出感谢: 0 次
接收感谢: 0 次
碰到和楼主一样的问题,若是打错字,删除之,输入法就不响应了。

按照2楼指引,未成功。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: Ubuntu10.04使用Chrome,输入法问题
帖子发表于 : 2010-10-06 22:50 
头像

注册: 2010-06-09 19:57
帖子: 1211
送出感谢: 2
接收感谢: 9
有方法说升级ibus,你们可以找ppa的源先试试


_________________
听歌


页首
 用户资料  
 
5 楼 
 文章标题 : Re: Ubuntu10.04使用Chrome,输入法问题
帖子发表于 : 2010-10-07 5:35 
头像

注册: 2010-08-27 15:53
帖子: 803
送出感谢: 0 次
接收感谢: 1
过来证实 chromium确实有此问题, 10.04上的


_________________
基础问题,请看入门手册http://people.ubuntu.com/~happyaron/udc-cn/lucid-html/

Acer aspire 4736G / Ubuntu 10.04LTS
Asus eeepc900 / Xandros
Nokia N900 / Maemo 1.2.12


页首
 用户资料  
 
6 楼 
 文章标题 : Re: Ubuntu10.04使用Chrome,输入法问题
帖子发表于 : 2010-10-07 9:56 

注册: 2006-09-25 15:08
帖子: 169
送出感谢: 0 次
接收感谢: 0 次
我的ibus已经好用了,可能是参照下述方法的作用:

ppa安裝方法:
代码:
sudo add-apt-repository ppa:shawn-p-huang/ppa
sudo apt-get update
sudo apt-get install ibus-gtk ibus-qt ibus-pinyin ibus-pinyin-db-open-phrase

上述代码,前两行我完全依照,第三行我昨天只是“sudo apt-get install ibus-pinyin”。当时未见效。
今晨,更新管理器启动,发现新增了“ppa”内容,其中有两项关于ibus的更新。安装之,输入法完全好使了。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: Ubuntu10.04使用Chrome,输入法问题
帖子发表于 : 2010-10-07 9:59 

注册: 2009-06-07 15:58
帖子: 101
送出感谢: 0 次
接收感谢: 0 次
9.10下面也是这个问题。

楼上的回复再次证明了这个论坛的价值。

不过,直接用楼上的命令行不能即时增加源和软件包列表。估计重新启动以后是可以,但是做个修改就要重启动机器的是windows,不是Linux。

于是,Google: ibus 1.3 ppa 得到如下的地址:

https://launchpad.net/~shawn-p-huang/+archive/ppa

就是ibus的软件包PPA列表。

打开页面选择你自己的Ubuntu版本,得到了源地址。
附件:
文件注释: ibus-ppa
Screenshot-ibus-ppa.png
Screenshot-ibus-ppa.png [ 41.72 KiB | 被浏览 3258 次 ]


源地址:
附件:
文件注释: ibus ppa address
Screenshot-ibus-ppa-address.png
Screenshot-ibus-ppa-address.png [ 5.19 KiB | 被浏览 3258 次 ]


然后打开系统的源地址管理器(System --> Administration --> Software Sourses)把页面上的地址加到地址列表里面。
附件:
文件注释: add address
Screenshot-ibus-ppa-add-sourse.png
Screenshot-ibus-ppa-add-sourse.png [ 87.19 KiB | 被浏览 3258 次 ]


就是其中PPA开头的那两个。

加完了,系统会提示更新,让它自己更新。

更新完毕后,打开系统的升级管理器(System --> Administration --> Update Manager),我的可以看到了:
附件:
文件注释: update manager
Screenshot-ibus-update-manager.png
Screenshot-ibus-update-manager.png [ 77.58 KiB | 被浏览 3258 次 ]



后面的事情,你懂的。 :em01


页首
 用户资料  
 
8 楼 
 文章标题 : Re: Ubuntu10.04使用Chrome,输入法问题
帖子发表于 : 2010-10-09 10:29 
头像

注册: 2009-02-02 17:41
帖子: 277
送出感谢: 7
接收感谢: 0 次
mark之,困扰死我了,希望ls的方法好用,其实还有类似的一个帖子反映了这个问题,可惜解决办法俱是无效。而且本人较菜,不能举一反三,只好继续求索。


反馈,依然失败,没有任何更新出现。ibus的所有我都装了,源也都加了,什么都做了,依然无效,难道要编译最新版ibus?


经过再次实验,发现虽然我通过源只能更新到1.3.3,但是火狐当中不会出现问题,这个问题只在chromium中出现。应该是属于ibus和chromium不兼容的现象。希望用chrome和ibus的人进来说话。解决办法我寻找了一上午,毫无进展。当然,有些人说要更新到1.3.7及以上版本,我通过源是做不到的。不知道通过源代码编译的人是不是真的能解决ibus与chromium的冲突问题。


我直接生气了,这都什么跟什么呀?我都快受不了了,当初用fcitx,在OOo里表现象垃圾,后来换到ibus,我擦来,跟chromium又过不去了。在linux下,不折腾是别想好好用,现在换了小小输入法,也不知道会出什么问题,先这么着吧,不搞了。总之最好的解决办法就是卸载ibus。希望小小输入法品质卓越,让我省心,反正目前ibus那套乱七八糟的东西不见了。


_________________
莫谈国事
ubuntu!


页首
 用户资料  
 
9 楼 
 文章标题 : Re: Ubuntu10.04使用Chrome,输入法问题
帖子发表于 : 2010-10-09 18:42 

注册: 2009-06-07 15:58
帖子: 101
送出感谢: 0 次
接收感谢: 0 次
一时热血,写了上面到东西,也升级了ibus。

痛苦地发现,我的9.10问题依旧,而且原本好用的ibus-sunpinyin跟着没了。

在Chrome里再次出现删除已经输入的文字,然后再输入时就不能输入的问题。

只能2次Ctrl+Space来解决。

现在用ibus自带的拼音输入,虽然速度不错,不过备选字只有5个,也不知道怎么改。新下载的sunpinyin需要自己编译,还没对应版本deb包。按照sunpinyin的wiki说明编译,大概是我的scons版本低,又无法编译源代码。

累,我不折腾了,就着现在的先用着,能忍就忍。实在不行了再说。


页首
 用户资料  
 
10 楼 
 文章标题 : Re: Ubuntu10.04使用Chrome,输入法问题
帖子发表于 : 2010-10-09 20:19 

注册: 2010-09-12 19:46
帖子: 197
送出感谢: 0 次
接收感谢: 0 次
surran 写道:
一时热血,写了上面到东西,也升级了ibus。

痛苦地发现,我的9.10问题依旧,而且原本好用的ibus-sunpinyin跟着没了。

在Chrome里再次出现删除已经输入的文字,然后再输入时就不能输入的问题。

只能2次Ctrl+Space来解决。

现在用ibus自带的拼音输入,虽然速度不错,不过备选字只有5个,也不知道怎么改。新下载的sunpinyin需要自己编译,还没对应版本deb包。按照sunpinyin的wiki说明编译,大概是我的scons版本低,又无法编译源代码。

累,我不折腾了,就着现在的先用着,能忍就忍。实在不行了再说。


sunpinyin好像新立得里面有。不用下载安装包啊。


页首
 用户资料  
 
11 楼 
 文章标题 : Re: Ubuntu10.04使用Chrome,输入法问题
帖子发表于 : 2010-10-11 11:08 
头像

注册: 2009-11-29 20:56
帖子: 34
送出感谢: 0 次
接收感谢: 0 次
我也标记一下,看看能否解决这个问题。


页首
 用户资料  
 
12 楼 
 文章标题 : Re: Ubuntu10.04使用Chrome,输入法问题
帖子发表于 : 2010-10-11 12:08 

注册: 2010-07-21 21:50
帖子: 12
送出感谢: 0 次
接收感谢: 0 次
我好像一样哦,弄的很是烦


页首
 用户资料  
 
13 楼 
 文章标题 : Re: Ubuntu10.04使用Chrome,输入法问题
帖子发表于 : 2010-10-12 9:38 

注册: 2010-10-03 14:31
帖子: 27
送出感谢: 0 次
接收感谢: 0 次
1.2.x 版本的 ibus 确实有问题,更新到 1.3.x 问题解决。


页首
 用户资料  
 
14 楼 
 文章标题 : Re: Ubuntu10.04使用Chrome,输入法问题
帖子发表于 : 2010-10-30 12:31 
头像

注册: 2010-01-03 19:58
帖子: 631
地址: 杭州
系统: OS X, Ubuntu(server)
送出感谢: 4
接收感谢: 0 次
楼主现在怎么样的,我今天ppa的ibus升级,也是同一个源,结果有个libpinyin无法正常安装,结果我把ibus删掉以为重装就没有问题了,现在都只能用云输入法,真没办法了


页首
 用户资料  
 
15 楼 
 文章标题 : Re: Ubuntu10.04使用Chrome,输入法问题
帖子发表于 : 2010-10-30 12:39 
头像

注册: 2008-06-23 15:19
帖子: 3048
地址: 北欧某国
系统: ���������
送出感谢: 21
接收感谢: 6
我用的是1.3.1,问题依旧。


_________________
http://noie.name 网站改版中。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 39 篇帖子 ]  前往页数 1, 2, 3  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译