当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : (主要已解决)怎么把XIM变成默认,10.10
帖子发表于 : 2010-11-07 17:19 

注册: 2010-02-23 13:44
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
locale:en_US-utf8,fcitx在10.04能正常使用,一升级到10.10就用不了,搞到现在,发现是默认不是XIM的问题.文本输入的时候默认不是XIM,必须右键input Methods把system改成X Input Method,但是Firefox就不行了,因为右键菜单没有选择IM的选项。

另外,用im-switch能将fcitx设成默认,但是用指令sudo im-switch -s fcitx -z default就不行
代码:
sudo im-switch -s fcitx -z default
No system wide default defined just for locale en_US .
Use "all_ALL" quasi-locale and set IM.
update-alternatives: error: alternative /etc/X11/xinit/xinput.d/fcitx for xinput-all_ALL not registered, not setting.


搞了一个下午搞到头都晕了,才想起问题都这么明显了还不去google。

现在就剩下
代码:
sudo im-switch -s fcitx -z default
No system wide default defined just for locale en_US .
Use "all_ALL" quasi-locale and set IM.
update-alternatives: error: alternative /etc/X11/xinit/xinput.d/fcitx for xinput-all_ALL not registered, not setting.

这个问题

和10.04的时候开机会弹出的fcitx的设置hint,
export XMODIFIERS="@im=fcitx"
export QT_IM_MODULE=xim
export GTK_IM_MODULE=xim

设置了之后每次开机还是会弹出的,any idea?是因为它不会自动侦测?还是?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译