为什么我有些txt打开之后是乱码?

系统字体配置、中文显示和输入法问题
回复
wangwwzj
帖子: 34
注册时间: 2010-11-16 1:41
送出感谢: 0
接收感谢: 0

为什么我有些txt打开之后是乱码?

#1

帖子 wangwwzj » 2010-11-28 15:46

比如附件这个文档,我在win的系统下都是可以看的。在ubuntu中全是黑色的东西。
管理咨询名词.txt
(5.16 KiB) 下载 11 次
头像
wowoto
帖子: 3049
注册时间: 2009-04-11 12:17
送出感谢: 0
接收感谢: 0

Re: 为什么我有些txt打开之后是乱码?

#2

帖子 wowoto » 2010-11-28 15:57

wowoto>ubuntu8.04>ubuntu9.04>Archlinux>FreeBSD8.0>Archlinux & end here.
wangwwzj
帖子: 34
注册时间: 2010-11-16 1:41
送出感谢: 0
接收感谢: 0

Re: 为什么我有些txt打开之后是乱码?

#3

帖子 wangwwzj » 2010-11-28 16:59

已解决,用openoffice打开的时候把字体调成chinese simplified(apple macintosh)就可以了。
levee
帖子: 3030
注册时间: 2009-10-03 23:31
送出感谢: 0
接收感谢: 13 次

Re: 为什么我有些txt打开之后是乱码?

#4

帖子 levee » 2010-11-29 2:28

用leafpad打开。
头像
tenzu
论坛版主
帖子: 36913
注册时间: 2008-11-21 20:26
送出感谢: 0
接收感谢: 21 次

Re: 为什么我有些txt打开之后是乱码?

#5

帖子 tenzu » 2010-11-29 9:04

gedit也可以改编码
头像
shadowmoon23
帖子: 287
注册时间: 2008-11-06 11:52
来自: 长沙
送出感谢: 0
接收感谢: 1 次
联系:

Re: 为什么我有些txt打开之后是乱码?

#6

帖子 shadowmoon23 » 2010-11-29 14:30

tenzu 写了:gedit也可以改编码
大大只丢下一句话就跑啦,我来完善一下吧:
我搜索了一下,方法是这样,在终端下输入

代码: 全选

gconf-editor
如果提示没安装则先:

代码: 全选

sudo apt-get install gconf-editor
然后依次找到app-->gedit2-->preferences-->encodings
右侧auto-detected默认的编码,将GB2312放在第一位(没有的话自己敲)。即可。
头像
自由建客
论坛版主
帖子: 13443
注册时间: 2008-07-30 23:21
系统: Debian stable AMD64
来自: freebuilder@yeah.net
送出感谢: 12 次
接收感谢: 112 次
联系:

Re: 为什么我有些txt打开之后是乱码?

#7

帖子 自由建客 » 2010-11-29 19:57

gbk还好,要是碰到 UNICODE 就瞪着看吧
回复

回到 “字体美化和中文支持”