当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 25 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 关于Gedit无法自动识别编码
帖子发表于 : 2010-12-25 8:07 
头像

注册: 2010-10-16 10:03
帖子: 149
送出感谢: 0 次
接收感谢: 0 次
近两天gedit发飙,居然不给我识别GB18030了。 :em20
我已经在gconf-editor里增加过这个GB编码了,之前都是好好的(正常识别),突然间就不行了。
而且我又重新locale-gen一下,已经有GB的locale了。
现在如果在gconf-editor删除那个ISO-8859-15,打开GB18030的文件就提示说无法auto encoding,要我自己选个编码,我就得选个GB18030,然后gedit才可以正常打开这个文件。
但是如果这个ISO-8859-15存在的话,读GB18030的文件就是乱码,除非手动选择编码。
求解求解~~~
请知道怎么解决的朋友分享一下你的心得~~~ :em11


_________________
Ubuntu11.04 64bit + Gnome 3 完美
Windows7 64 Ultimate


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 关于Gedit无法自动识别编码
帖子发表于 : 2010-12-25 9:27 
头像

注册: 2007-06-13 15:57
帖子: 12648
地址: 在他乡
送出感谢: 54
接收感谢: 90
代码:
   gconftool-2 –set /apps/gedit-2/preferences/encodings/auto_detected [UTF-8,CURRENT,GB18030,BIG5,ISO-8859-15,UTF-16] –type list –l-type string


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 关于Gedit无法自动识别编码
帖子发表于 : 2010-12-25 11:39 
头像

注册: 2010-10-16 10:03
帖子: 149
送出感谢: 0 次
接收感谢: 0 次
daf3707 写道:
代码:
   gconftool-2 –set /apps/gedit-2/preferences/encodings/auto_detected [UTF-8,CURRENT,GB18030,BIG5,ISO-8859-15,UTF-16] –type list –l-type string

谢谢你的回答,但结果还是乱码~~
gconf的修改对我目前的状况没有改变,唉
继续去求解


_________________
Ubuntu11.04 64bit + Gnome 3 完美
Windows7 64 Ultimate


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 关于Gedit无法自动识别编码
帖子发表于 : 2010-12-25 22:23 
头像

注册: 2010-10-16 10:03
帖子: 149
送出感谢: 0 次
接收感谢: 0 次
自己顶贴。。。
求高手~~
:em20


_________________
Ubuntu11.04 64bit + Gnome 3 完美
Windows7 64 Ultimate


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 关于Gedit无法自动识别编码
帖子发表于 : 2010-12-25 22:42 
头像

注册: 2010-10-16 10:03
帖子: 149
送出感谢: 0 次
接收感谢: 0 次
发现只有是GB编码并且line ending是windows的,gedit打开都是乱码。
把它另存为GB而且UNIX line ending的话一切就正常了。
无语中。。。 :em20


_________________
Ubuntu11.04 64bit + Gnome 3 完美
Windows7 64 Ultimate


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 关于Gedit无法自动识别编码
帖子发表于 : 2010-12-26 8:52 
头像

注册: 2010-10-16 10:03
帖子: 149
送出感谢: 0 次
接收感谢: 0 次
附件是两个几乎一样的文件,一个是unix line ending 一个是windows line ending。
请有兴趣的同学帮忙测试一下,是否是unix的打开不乱码,而windows的是乱码除非手工选择用GB18030编码。
以上实验是在已经把GB18030添加到auto_detect的基础上。
谢谢各位~~~ :em02


附件:
文件注释: Line ending is windows&&GB18030
道德经(原文).txt [14.07 KiB]
被下载 58 次
文件注释: Line ending is unix&&GB18030
道德经(原文).txt [13.99 KiB]
被下载 46 次


_________________
Ubuntu11.04 64bit + Gnome 3 完美
Windows7 64 Ultimate
页首
 用户资料  
 
7 楼 
 文章标题 : Re: 关于Gedit无法自动识别编码
帖子发表于 : 2010-12-26 9:34 
头像

注册: 2009-07-31 18:56
帖子: 1670
地址: 广东阳江
系统: windows、ubuntu
送出感谢: 7
接收感谢: 20
帮你消灭0下载,测试完了,与你的结论一致,unix的打开不乱码,windows的是乱码
随便问一下怎么我的Gedit没有“手工选择编码”这个选项呢?


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 关于Gedit无法自动识别编码
帖子发表于 : 2010-12-26 10:17 
头像

注册: 2010-10-16 10:03
帖子: 149
送出感谢: 0 次
接收感谢: 0 次
qq420100523 写道:
帮你消灭0下载,测试完了,与你的结论一致,unix的打开不乱码,windows的是乱码
随便问一下怎么我的Gedit没有“手工选择编码”这个选项呢?

谢谢!在gedit里边按open,下边有个character encoding,下拉就可以选了


_________________
Ubuntu11.04 64bit + Gnome 3 完美
Windows7 64 Ultimate


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 关于Gedit无法自动识别编码
帖子发表于 : 2010-12-26 10:25 
头像

注册: 2009-07-31 18:56
帖子: 1670
地址: 广东阳江
系统: windows、ubuntu
送出感谢: 7
接收感谢: 20
xiahongze 写道:
qq420100523 写道:
帮你消灭0下载,测试完了,与你的结论一致,unix的打开不乱码,windows的是乱码
随便问一下怎么我的Gedit没有“手工选择编码”这个选项呢?

谢谢!在gedit里边按open,下边有个character encoding,下拉就可以选了

可是我没看到呀 :em20
附件:
Screenshot-道德经(原文).txt (~-下载) - gedit.png
Screenshot-道德经(原文).txt (~-下载) - gedit.png [ 150.1 KiB | 被浏览 1922 次 ]


哦,我明白了,是在打开后,选文件时选编码的。。我还以为是在gedit打开后再选呢。。。 :em04


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 关于Gedit无法自动识别编码
帖子发表于 : 2010-12-26 17:02 
头像

注册: 2007-11-25 13:29
帖子: 7256
地址: 新疆博乐
系统: 14.04/16.04/Fedroa22
送出感谢: 38
接收感谢: 101
参考: viewtopic.php?f=122&t=227562&start=0
或者在论坛右上角搜索 “gedit 乱码”


_________________
===新手请看===
Ubuntu 安装 | Ubuntu12.04/14.04/16.04 桌面操作指南
··Ubuntu16.04 安装图文教程(超简单)
····有时间就静下心来——折腾:)


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 关于Gedit无法自动识别编码
帖子发表于 : 2010-12-26 19:17 
头像

注册: 2010-10-16 10:03
帖子: 149
送出感谢: 0 次
接收感谢: 0 次
TeliuTe 写道:
参考: viewtopic.php?f=122&t=227562&start=0
或者在论坛右上角搜索 “gedit 乱码”

你好~我认为我在这个贴子里是讨论Gedit因为line ending的改变而乱码,目前为止我在google和本论坛没有找到相关的资料。
对于去修改gconf-editor的事情我知道很久了,跟这个没有关系。
简单的说就是gedit的auto-detect功能因为line ending而失效。
谢谢关注~


_________________
Ubuntu11.04 64bit + Gnome 3 完美
Windows7 64 Ultimate


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 关于Gedit无法自动识别编码
帖子发表于 : 2010-12-26 19:44 
头像

注册: 2009-10-08 11:15
帖子: 8428
地址: 大城市铁岭
送出感谢: 0 次
接收感谢: 9
两个一样

ANSI
附件:
无标题.jpg
无标题.jpg [ 225.5 KiB | 被浏览 1892 次 ]



_________________
我们是命运的妓女,它把我们都嫖了

N卡驱动:http://www.nvidia.cn/Download/index.aspx?lang=cn
极品飞车:http://www.geforce.cn/optimize/optimal-game-settings/need-for-speed-shift-geforce-gts-450-ops
孤岛危机优化设置:http://www.geforce.cn/optimize/optimal-game-settings/crysis-geforce-gtx-450-ops
:cp /etc/skel/.bashrc ~/
PS1="\[\e]2;\u@\H \w\a\e[32;1m\]\T$\[\e[0m\] "
http://cdimage.ubuntu.com/
http://releases.ubuntu.com/


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 关于Gedit无法自动识别编码
帖子发表于 : 2010-12-26 21:13 
头像

注册: 2010-10-16 10:03
帖子: 149
送出感谢: 0 次
接收感谢: 0 次
黄美姬 写道:
两个一样

ANSI
附件:
无标题.jpg

我的意思是用gedit去打开,您好像用的是EmEditor? :em06
这两个文件是一样的啊,就是line ending不一样而已。


_________________
Ubuntu11.04 64bit + Gnome 3 完美
Windows7 64 Ultimate


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 关于Gedit无法自动识别编码
帖子发表于 : 2010-12-27 15:54 
头像

注册: 2008-07-27 8:51
帖子: 717
地址: 广西玉林|广东深圳
系统: Ubuntu/Windows
送出感谢: 1
接收感谢: 3
楼主说得对,确实有这个问题,确认


_________________
走过去了也便有了路
http://www.ptpt52.com/


页首
 用户资料  
 
15 楼 
 文章标题 : Re: 关于Gedit无法自动识别编码
帖子发表于 : 2010-12-30 19:52 

注册: 2008-05-25 9:48
帖子: 38
送出感谢: 0 次
接收感谢: 0 次
还是没解决自动编码,每次都得手动选择~烦!!!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 25 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Bing [Bot], Google Feedfetcher 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译