引自wiki:Gedit中文乱码的解决方法

系统字体配置、中文显示和输入法问题
回复
ivylw
帖子: 97
注册时间: 2006-10-15 14:20
送出感谢: 0
接收感谢: 0

引自wiki:Gedit中文乱码的解决方法

#1

帖子 ivylw » 2011-01-05 15:35

Gedit中文乱码
出自Ubuntu中文

缺省配置下,用 Ubuntu 的文本编辑器(gedit)打开 GB18030/GBK/GB2312 等类型的中文编码文本文件时,将会出现乱码。

出现这种情况的原因是,gedit 使用一个编码匹配列表,只有在这个列表中的编码才会进行匹配,不在这个列表中的编码将显示为乱码。您要做的就是将 GB18030 加入这个匹配列表。

* 命令行方式,适用于所有 Ubuntu 用户。
复制以下命令到终端中,然后回车即可:

代码: 全选

gconftool-2 --set --type=list --list-type=string /apps/gedit-2/preferences/encodings/auto_detected "[UTF-8,CURRENT,GB18030,BIG5-HKSCS,UTF-16]" 
联想 启天M245E
Celeron D 335
768M DDR
40G
Linux mint8
头像
cameron
帖子: 358
注册时间: 2007-08-10 15:06
送出感谢: 0
接收感谢: 1 次

Re: 引自wiki:Gedit中文乱码的解决方法

#2

帖子 cameron » 2011-01-05 16:26

很有用! :em11
回复

回到 “字体美化和中文支持”