设置了系统语言为英语后,中文输入法怎么打开呢?

系统字体配置、中文显示和输入法问题
回复
头像
Kimurate
帖子: 24
注册时间: 2011-05-05 16:55
送出感谢: 0
接收感谢: 0

设置了系统语言为英语后,中文输入法怎么打开呢?

#1

帖子 Kimurate » 2011-05-10 19:43

如题~ :em06
jtshs256
论坛版主
帖子: 22322
注册时间: 2010-07-19 21:41
系统: OS X
送出感谢: 2 次
接收感谢: 27 次

Re: 设置了系统语言为英语后,中文输入法怎么打开呢?

#2

帖子 jtshs256 » 2011-05-10 19:54

设LC_TYPE为中文的…
NO DO NO DIE
http://a/%%30%30
头像
Kimurate
帖子: 24
注册时间: 2011-05-05 16:55
送出感谢: 0
接收感谢: 0

Re: 设置了系统语言为英语后,中文输入法怎么打开呢?

#3

帖子 Kimurate » 2011-05-10 19:58

jtshs256 写了:设LC_TYPE为中文的…
LC_TYPE。。。是神马?
头像
清风明月
帖子: 843
注册时间: 2011-05-01 19:29
送出感谢: 0
接收感谢: 1 次

Re: 设置了系统语言为英语后,中文输入法怎么打开呢?

#4

帖子 清风明月 » 2011-05-10 20:04

Running IBus

If IBus doesn't automatically startup at login then you need to add it to startup applications list.

Open System > Preferences > Startup Applications
Click on the "Add" button
Write command as: "ibus-daemon"
Click on the "Add" button

Setting up your Language

Go to System->Preferences->Ibus Preferences.
Go to 'Input Method' tab
Select your language from the drop down menu and click 'Add button'
Move it up to the top so that whenever you run ibus you will be directly able to type in your language.
Close
以上摘自wiki,Google一下就知道了。选输入法时把你想用的输入法放在第一位,Ibus自带的Chinese-PinYin就很好
头像
Kimurate
帖子: 24
注册时间: 2011-05-05 16:55
送出感谢: 0
接收感谢: 0

Re: 设置了系统语言为英语后,中文输入法怎么打开呢?

#5

帖子 Kimurate » 2011-05-11 0:05

清风明月 写了:Running IBus

If IBus doesn't automatically startup at login then you need to add it to startup applications list.

Open System > Preferences > Startup Applications
Click on the "Add" button
Write command as: "ibus-daemon"
Click on the "Add" button

Setting up your Language

Go to System->Preferences->Ibus Preferences.
Go to 'Input Method' tab
Select your language from the drop down menu and click 'Add button'
Move it up to the top so that whenever you run ibus you will be directly able to type in your language.
Close
以上摘自wiki,Google一下就知道了。选输入法时把你想用的输入法放在第一位,Ibus自带的Chinese-PinYin就很好
嗯,我照着这个方法做了,有效果:) 多谢这位大哥啦!
但是设置完之后,系统的中文变得很难看。。。原本是很好看的,我没有调整过字体,为什么会有这种情况呢?
头像
清风明月
帖子: 843
注册时间: 2011-05-01 19:29
送出感谢: 0
接收感谢: 1 次

Re: 设置了系统语言为英语后,中文输入法怎么打开呢?

#6

帖子 清风明月 » 2011-05-11 11:31

你说的原本字体好看是在系统中文界面下吧?改了英文界面得重新设定字体,桌面点右键选change desktop background然后在Fonts选项里改就行了
levee
帖子: 3030
注册时间: 2009-10-03 23:31
送出感谢: 0
接收感谢: 13 次

Re: 设置了系统语言为英语后,中文输入法怎么打开呢?

#7

帖子 levee » 2011-05-12 0:41

fcitx,scim都不用改LC_TYPE,在en_US.UTF-8的locale下可正常输入,ibus不清楚。
头像
Kimurate
帖子: 24
注册时间: 2011-05-05 16:55
送出感谢: 0
接收感谢: 0

Re: 设置了系统语言为英语后,中文输入法怎么打开呢?

#8

帖子 Kimurate » 2011-05-12 13:23

清风明月 写了:你说的原本字体好看是在系统中文界面下吧?改了英文界面得重新设定字体,桌面点右键选change desktop background然后在Fonts选项里改就行了
我看了字体的名字,没有变,还是原来的那个字体。
头像
清风明月
帖子: 843
注册时间: 2011-05-01 19:29
送出感谢: 0
接收感谢: 1 次

Re: 设置了系统语言为英语后,中文输入法怎么打开呢?

#9

帖子 清风明月 » 2011-05-12 14:02

系统显示到sans serif什么的不是真正的字体,在不同语言界面下对应不同的字体。你把那些都改成wenquanyi micro hei系列的试试
附件
Screenshot.png
头像
Kimurate
帖子: 24
注册时间: 2011-05-05 16:55
送出感谢: 0
接收感谢: 0

Re: 设置了系统语言为英语后,中文输入法怎么打开呢?

#10

帖子 Kimurate » 2011-05-12 20:46

清风明月 写了:系统显示到sans serif什么的不是真正的字体,在不同语言界面下对应不同的字体。你把那些都改成wenquanyi micro hei系列的试试
:em06 真不巧,我改的就是这个字体,好吧,也许是我看不习惯吧。。
回复

回到 “字体美化和中文支持”