[问题]在firefox中输入中文问题

系统字体配置、中文显示和输入法问题
回复
bobzsj87
帖子: 8
注册时间: 2006-11-07 15:00
送出感谢: 0
接收感谢: 0

[问题]在firefox中输入中文问题

#1

帖子 bobzsj87 » 2006-12-04 22:18

请教:
我安装了scim-bridge,在其他linux环境下单击右键,选择Input method都可以调出scim输入,可是firefox里面就不行,于是不能输入中文。

我在scim的设置里面也设置了ctrl+space调用,可是没有用。。。

菜鸟问题,请高手相助
tenfen
帖子: 17
注册时间: 2006-11-29 0:15
送出感谢: 0
接收感谢: 0

小弟遇到同样的问题

#2

帖子 tenfen » 2006-12-05 0:06

小弟遇到同样的问题,现在的回复都是在文本编辑器下写好再copy的,惨啊,如何才能调出scim输入法?
gaussanderson
帖子: 8
注册时间: 2006-09-05 19:19
送出感谢: 0
接收感谢: 0

#3

帖子 gaussanderson » 2006-12-05 12:31

高手帮忙啊!
这么个难堪的问题,简直是坍ubuntu台啊!如果有过解决问题的经历共享一下吧.我google也没有找到解决办法 :cry:
bobzsj87
帖子: 8
注册时间: 2006-11-07 15:00
送出感谢: 0
接收感谢: 0

转贴:看看有没有用

#4

帖子 bobzsj87 » 2006-12-05 12:38

本贴来自:http://my.opera.com/jfxwc/archive/monthly/?day=20061112

二、中文输入问题的解决

  问题描述:使用 Ctrl+Space 无法呼出 scim,因此无法在 Java 应用程序中输入中文。

  原因分析:1.可能是由于该 Java 应用程序将 Ctrl+Space 定义成了快捷键,所以与 scim 存在冲突。2.由于 scim XIM 支持模块没能自动加载,故导致在 Java 应用程序中无法呼出 scim。

  解决方案:针对第一种原因,只要修改 scim 的呼出热键,或者修改 Java 应用程序中的快捷键,即可解决问题。

  而第二种原因可以按如下方法处理:

  1.检查 XMODIFIER 的设置

  export | grep XMODIFIER | grep "@im=SCIM" | wc -l

输出应该为1。如果不是,则检查系统配置,推荐使用 utf-8 区域。

  2.如果上一步输出无误,则输入下列命令:

  ps aux | grep "scim-launcher.*-f x11" | grep -v grep | wc -l

此输出应该大于或等于1。如果不是,如我的输出为0,则说明 scim XIM 支持模块没有自动载入。你可以手动载入它:

  scim -d -c socket -f x11 -e socket

  此时,我启动 Java 应用程序,试了试 scim,已经可以输入中文了。但如果每次都手动加载还是比较麻烦,所以我们考虑让系统自动加载它。

  在/etc/X11/Xsession.d中创建 75custom-scim_init 文件,包括如下内容:

  
  export XMODIFIERS="@im=SCIM"
  export GTK_IM_MODULE="scim"
  export XIM_PROGRAM="scim -d"
  

  转到 System->Preferences->Sessions,选择 Startup Programs,添加 scim -d,并保留顺序为50。

  登录 root 终端,输入下列命令:

  gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules

  重新启动系统,一切正常,cool!

  参考:

  最简单的对 JDK 1.5的中文乱码处理方法 中 kdekid 网友的方法,既保险又简单,感谢。
  Why XIM apps does not work? scim 的官方文档,遇到问题查找官方文档不失为一种解决之道啊。
liumiaowilson
帖子: 28
注册时间: 2006-12-07 12:17
送出感谢: 0
接收感谢: 0
联系:

用fcitx吧

#5

帖子 liumiaowilson » 2006-12-11 15:55

我也遇到过同样的问题,不过换用fcitx后 就没有问题了
回复

回到 “字体美化和中文支持”