安装FCITX的问题!

系统字体配置、中文显示和输入法问题
头像
yysq009
帖子: 2682
注册时间: 2007-01-28 23:00
来自: @江西|南昌@
送出感谢: 0
接收感谢: 0
联系:

安装FCITX的问题!

#1

帖子 yysq009 » 2007-01-29 14:50

我下载了FCITX的TAR包 通过解压 安装 但是出现下面的问题 请高手解答下。
yysq@yysq-desktop:~$ cd fcitx-3.4.2
yysq@yysq-desktop:~/fcitx-3.4.2$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking build system type... i686-pc-linux-gnulibc1
checking host system type... i686-pc-linux-gnulibc1
checking for gcc... gcc
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.
是少了什么组件么???
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 karron » 2007-01-29 14:58

sudo apt-get build-dep fcitx 安装编译fcitx的依赖库看看.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

#3

帖子 dogfox » 2007-01-29 15:18

我是这样安装的
参考

代码: 全选

$ cd /usr/local/fcitx-fox/
ls
sudo ./fcitx.install
编译 FCITX 需要以下包:
• GCC-2.95.3 或更新
• XFree86-4.3.0/xorg 或更新(及其开发包)
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#4

帖子 BigSnake.NET » 2007-01-29 15:21

^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
yysq009
帖子: 2682
注册时间: 2007-01-28 23:00
来自: @江西|南昌@
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 yysq009 » 2007-01-29 16:33

我想知道最后的错误代码是什么意思?是说我少了什么组件么???
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#6

帖子 BigSnake.NET » 2007-01-29 16:37

是不是沒裝gcc。。。。
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
yysq009
帖子: 2682
注册时间: 2007-01-28 23:00
来自: @江西|南昌@
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 yysq009 » 2007-01-29 16:43

应该是装了 因为我输入GCC -V系统回复是

yysq@yysq-desktop:~$ gcc -v
Using built-in specs.
Target: i486-linux-gnu
Configured with: ../src/configure -v --enable-languages=c,c++,fortran,objc,obj-c++,treelang --prefix=/usr --enable-shared --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --enable-nls --program-suffix=-4.1 --enable-__cxa_atexit --enable-clocale=gnu --enable-libstdcxx-debug --enable-mpfr --enable-checking=release i486-linux-gnu
Thread model: posix
gcc version 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)
yysq@yysq-desktop:~$

不知道这个提示 是否是GCC安装好了。
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 zhan » 2007-01-29 16:56

基本的编译环境没有配置好,包括一些 C/C++ 的头文件等等,这个错误一般是说编译器问题。再具体的我也不知道了 ..
要解决这个,请
sudo apt-get install build-essential

P.S. 要编译 fcitx 还需要 libxft, libpng 等等库文件。
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
头像
yysq009
帖子: 2682
注册时间: 2007-01-28 23:00
来自: @江西|南昌@
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 yysq009 » 2007-01-29 17:01

我按照2楼的方法 更新后 ./configure 和make都成功了 但是MAKE INSTALL的时候却提示错误。代码如下:
yysq@yysq-desktop:~/fcitx-3.4.2$ make install
Making install in doc
make[1]: Entering directory `/home/yysq/fcitx-3.4.2/doc'
make[2]: Entering directory `/home/yysq/fcitx-3.4.2/doc'
make[2]: Nothing to be done for `install-exec-am'.
test -z "/usr/local/share/fcitx/doc" || mkdir -p -- "/usr/local/share/fcitx/doc"
mkdir: 无法创建目录‘/usr/local/share/fcitx’: Permission denied
make[2]: *** [install-docDATA] 错误 1
make[2]: Leaving directory `/home/yysq/fcitx-3.4.2/doc'
make[1]: *** [install-am] 错误 2
make[1]: Leaving directory `/home/yysq/fcitx-3.4.2/doc'
make: *** [install-recursive] 错误 1
yysq@yysq-desktop:~/fcitx-3.4.2$
不知道是什么错误。。。


PS:执行sudo apt-get install build-essential 以后提示如下:
yysq@yysq-desktop:~$ sudo apt-get install build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
build-essential 已经是最新的版本了。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 110 个软件未被升级。
yysq@yysq-desktop:~$
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#10

帖子 BigSnake.NET » 2007-01-29 17:34

Permission denied
要sudo哈。。。
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
头像
yysq009
帖子: 2682
注册时间: 2007-01-28 23:00
来自: @江西|南昌@
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 yysq009 » 2007-01-29 19:38

还是不行,不过找了个FCITX的DEB包安装上了。还是DEB包好。跟装系统软件一样,舒服!~~~
想问下,因为自己装了很多其他软件,但是启动很麻烦,如何能添加进系统的菜单呢?
头像
cime63
帖子: 286
注册时间: 2007-01-28 11:53
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 cime63 » 2007-01-29 21:37

同楼上问
头像
yysq009
帖子: 2682
注册时间: 2007-01-28 23:00
来自: @江西|南昌@
送出感谢: 0
接收感谢: 0
联系:

#13

帖子 yysq009 » 2007-01-29 22:36

有人能帮忙下么?谢谢了!~~顶了。
头像
dogfox
论坛版主
帖子: 5309
注册时间: 2006-09-02 14:18
来自: 汉桑城
送出感谢: 1 次
接收感谢: 1 次
联系:

#14

帖子 dogfox » 2007-01-30 1:23

yysq009 写了:我按照2楼的方法 更新后 ./configure 和make都成功了 但是MAKE INSTALL的时候却提示错误。代码如下:
yysq@yysq-desktop:~/fcitx-3.4.2$ make install
Making install in doc
make[1]: Entering directory `/home/yysq/fcitx-3.4.2/doc'
make[2]: Entering directory `/home/yysq/fcitx-3.4.2/doc'
make[2]: Nothing to be done for `install-exec-am'.
test -z "/usr/local/share/fcitx/doc" || mkdir -p -- "/usr/local/share/fcitx/doc"
mkdir: 无法创建目录‘/usr/local/share/fcitx’: Permission denied
make[2]: *** [install-docDATA] 错误 1
make[2]: Leaving directory `/home/yysq/fcitx-3.4.2/doc'
make[1]: *** [install-am] 错误 2
make[1]: Leaving directory `/home/yysq/fcitx-3.4.2/doc'
make: *** [install-recursive] 错误 1
yysq@yysq-desktop:~/fcitx-3.4.2$
不知道是什么错误。。。


PS:执行sudo apt-get install build-essential 以后提示如下:
yysq@yysq-desktop:~$ sudo apt-get install build-essential
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
build-essential 已经是最新的版本了。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 110 个软件未被升级。
yysq@yysq-desktop:~$
莫名其妙
毋需make
全世界linux爱好者联合起来 !
一切闭源操作系统都是纸老虎 !
要斗私批修,拒绝黑屏,使用linux !
让一部分人先用起Archlinux来 !
linux是第一生产力 !
讲正气,讲开源,讲free
要坚定不移的走开源的道路 !
linux明天会更好 !

dpkg -l |grep ^rc|awk '{print $2}' |tr ["\n"] [" "]|sudo xargs dpkg -P -
ubuntu粉丝群 26660836 已满员
头像
yysq009
帖子: 2682
注册时间: 2007-01-28 23:00
来自: @江西|南昌@
送出感谢: 0
接收感谢: 0
联系:

#15

帖子 yysq009 » 2007-01-30 12:25

什么意思阿? 看不明白.
回复

回到 “字体美化和中文支持”