[fcitx] 双拼输入时出现的奇怪字符

系统字体配置、中文显示和输入法问题
头像
cuihao
帖子: 4793
注册时间: 2008-07-24 11:33
来自: 郑州
送出感谢: 1 次
接收感谢: 89 次
联系:

[fcitx] 双拼输入时出现的奇怪字符

#1

帖子 cuihao » 2013-01-27 21:45

如图:
截图 - 2013年01月27日 - 21时41分45秒.png
截图 - 2013年01月27日 - 21时41分45秒.png (8.22 KiB) 查看 2009 次
全拼下“hz”也会触发。这是啥特殊功能?
fcitx 4.2.7
求人不如求它仨: 天蓝的Wiki 屎黄的Wiki 绿
Site: CUIHAO.TK    Twitter: @cuihaoleo
Machine: Athlon64 X2 5200+ / 2x2GB DDR2-800 / GeForce GTS 450
AD: ~まだ見ぬ誰かの笑顔のために~
头像
yjcong
帖子: 2470
注册时间: 2006-02-28 3:11
送出感谢: 0
接收感谢: 0

Re: [fcitx] 双拼输入时出现的奇怪字符

#2

帖子 yjcong » 2013-01-27 22:34

刚升级的4.2.7把键盘一部分功能给吃了, 而且, X动不动的就100%
一梦三年,
松风依旧,
萝月何曾老.


灵幽听微, 谁观玉颜?
灼灼春华, 绿叶含丹.
头像
自由建客
论坛版主
帖子: 13436
注册时间: 2008-07-30 23:21
系统: Debian stable AMD64
来自: freebuilder@yeah.net
送出感谢: 12 次
接收感谢: 112 次
联系:

Re: [fcitx] 双拼输入时出现的奇怪字符

#3

帖子 自由建客 » 2013-01-27 22:57

hz 不是黑?
csslayer
帖子: 572
注册时间: 2009-08-03 13:08
送出感谢: 1 次
接收感谢: 16 次

Re: [fcitx] 双拼输入时出现的奇怪字符

#4

帖子 csslayer » 2013-01-28 0:02

笔画

hpszn 横撇竖折捺
csslayer
帖子: 572
注册时间: 2009-08-03 13:08
送出感谢: 1 次
接收感谢: 16 次

Re: [fcitx] 双拼输入时出现的奇怪字符

#5

帖子 csslayer » 2013-01-28 0:43

yjcong 写了:刚升级的4.2.7把键盘一部分功能给吃了, 而且, X动不动的就100%
什么意思?
键盘部分你想说这个?
http://fcitx-im.org/wiki/FAQ/zh-cn#.E9. ... 8.E5.8C.96

后半你确定是fcitx的问题?
已知有问题的只有firefox的菜单,bug在 libx11 或者 firefox 里面。

https://bugzilla.mozilla.org/show_bug.cgi?id=787943
可以用 gtk2 的immodule 绕过。
头像
cuihao
帖子: 4793
注册时间: 2008-07-24 11:33
来自: 郑州
送出感谢: 1 次
接收感谢: 89 次
联系:

Re: [fcitx] 双拼输入时出现的奇怪字符

#6

帖子 cuihao » 2013-01-28 9:20

csslayer 写了:笔画

hpszn 横撇竖折捺
能关闭吗?目前的configtool 0.4.6里好像还没有。
最好设置个触发条件,比如u+hz。
求人不如求它仨: 天蓝的Wiki 屎黄的Wiki 绿
Site: CUIHAO.TK    Twitter: @cuihaoleo
Machine: Athlon64 X2 5200+ / 2x2GB DDR2-800 / GeForce GTS 450
AD: ~まだ見ぬ誰かの笑顔のために~
csslayer
帖子: 572
注册时间: 2009-08-03 13:08
送出感谢: 1 次
接收感谢: 16 次

Re: [fcitx] 双拼输入时出现的奇怪字符

#7

帖子 csslayer » 2013-01-28 10:26

拼音增强输入那个模块里面

好像没直接定义的……你改个最小笔画触发长度凑合好了
头像
cuihao
帖子: 4793
注册时间: 2008-07-24 11:33
来自: 郑州
送出感谢: 1 次
接收感谢: 89 次
联系:

Re: [fcitx] 双拼输入时出现的奇怪字符

#8

帖子 cuihao » 2013-01-28 11:32

csslayer 写了:拼音增强输入那个模块里面

好像没直接定义的……你改个最小笔画触发长度凑合好了
:em01 修改个30先用着。
求人不如求它仨: 天蓝的Wiki 屎黄的Wiki 绿
Site: CUIHAO.TK    Twitter: @cuihaoleo
Machine: Athlon64 X2 5200+ / 2x2GB DDR2-800 / GeForce GTS 450
AD: ~まだ見ぬ誰かの笑顔のために~
头像
自由建客
论坛版主
帖子: 13436
注册时间: 2008-07-30 23:21
系统: Debian stable AMD64
来自: freebuilder@yeah.net
送出感谢: 12 次
接收感谢: 112 次
联系:

Re: [fcitx] 双拼输入时出现的奇怪字符

#9

帖子 自由建客 » 2013-01-28 14:12

自以为用上双拼了 :em04
头像
yjcong
帖子: 2470
注册时间: 2006-02-28 3:11
送出感谢: 0
接收感谢: 0

Re: [fcitx] 双拼输入时出现的奇怪字符

#10

帖子 yjcong » 2013-01-28 14:55

csslayer 写了:
yjcong 写了:刚升级的4.2.7把键盘一部分功能给吃了, 而且, X动不动的就100%
什么意思?
键盘部分你想说这个?
http://fcitx-im.org/wiki/FAQ/zh-cn#.E9. ... 8.E5.8C.96

后半你确定是fcitx的问题?
已知有问题的只有firefox的菜单,bug在 libx11 或者 firefox 里面。

https://bugzilla.mozilla.org/show_bug.cgi?id=787943
可以用 gtk2 的immodule 绕过。
https://bbs.archlinux.org/viewtopic.php?id=156927
虽然我把title改成solved, 但实际是问题定位到了fcitx4.2.7. 因为我downgrade到4.2.6什么异常都没有了

我没开forefox, 仅仅是刚登录X, 在terminal上切换fcitx, X就100%. 若是libx11的问题, 为什么fcitx4.2.6就没问题呢?

在对应fcitx4.2.7的fcitx-configtool-0.4.6-1里, Appearance下, 是一片空白, 什么也没有. 这个貌似和kimpanel有关吧
一梦三年,
松风依旧,
萝月何曾老.


灵幽听微, 谁观玉颜?
灼灼春华, 绿叶含丹.
csslayer
帖子: 572
注册时间: 2009-08-03 13:08
送出感谢: 1 次
接收感谢: 16 次

Re: [fcitx] 双拼输入时出现的奇怪字符

#11

帖子 csslayer » 2013-01-28 15:34

yjcong 写了:
csslayer 写了:
yjcong 写了:刚升级的4.2.7把键盘一部分功能给吃了, 而且, X动不动的就100%
什么意思?
键盘部分你想说这个?
http://fcitx-im.org/wiki/FAQ/zh-cn#.E9. ... 8.E5.8C.96

后半你确定是fcitx的问题?
已知有问题的只有firefox的菜单,bug在 libx11 或者 firefox 里面。

https://bugzilla.mozilla.org/show_bug.cgi?id=787943
可以用 gtk2 的immodule 绕过。
https://bbs.archlinux.org/viewtopic.php?id=156927
虽然我把title改成solved, 但实际是问题定位到了fcitx4.2.7. 因为我downgrade到4.2.6什么异常都没有了

我没开forefox, 仅仅是刚登录X, 在terminal上切换fcitx, X就100%. 若是libx11的问题, 为什么fcitx4.2.6就没问题呢?

在对应fcitx4.2.7的fcitx-configtool-0.4.6-1里, Appearance下, 是一片空白, 什么也没有. 这个貌似和kimpanel有关吧
哪个 terminal?

Appearance 下面至少有个提示信息吧,你没启动用户级的 dbus?
http://fcitx-im.org/wiki/Configure_%28O ... 9.2Fstartx

fcitx 4.2.4 开始就会改你系统键盘布局了,给指定输入法设键盘布局的办法:
https://www.csslayer.info/wordpress/fci ... t-binding/
csslayer
帖子: 572
注册时间: 2009-08-03 13:08
送出感谢: 1 次
接收感谢: 16 次

Re: [fcitx] 双拼输入时出现的奇怪字符

#12

帖子 csslayer » 2013-01-28 15:36

yjcong 写了:
csslayer 写了:
yjcong 写了:刚升级的4.2.7把键盘一部分功能给吃了, 而且, X动不动的就100%
什么意思?
键盘部分你想说这个?
http://fcitx-im.org/wiki/FAQ/zh-cn#.E9. ... 8.E5.8C.96

后半你确定是fcitx的问题?
已知有问题的只有firefox的菜单,bug在 libx11 或者 firefox 里面。

https://bugzilla.mozilla.org/show_bug.cgi?id=787943
可以用 gtk2 的immodule 绕过。
https://bbs.archlinux.org/viewtopic.php?id=156927
虽然我把title改成solved, 但实际是问题定位到了fcitx4.2.7. 因为我downgrade到4.2.6什么异常都没有了

我没开forefox, 仅仅是刚登录X, 在terminal上切换fcitx, X就100%. 若是libx11的问题, 为什么fcitx4.2.6就没问题呢?

在对应fcitx4.2.7的fcitx-configtool-0.4.6-1里, Appearance下, 是一片空白, 什么也没有. 这个貌似和kimpanel有关吧
建议你把 setxkbmap 去掉然后用 fcitx 来配键盘布局
头像
yjcong
帖子: 2470
注册时间: 2006-02-28 3:11
送出感谢: 0
接收感谢: 0

Re: [fcitx] 双拼输入时出现的奇怪字符

#13

帖子 yjcong » 2013-01-28 15:59

csslayer 写了:
yjcong 写了:
csslayer 写了:
yjcong 写了:刚升级的4.2.7把键盘一部分功能给吃了, 而且, X动不动的就100%
什么意思?
键盘部分你想说这个?
http://fcitx-im.org/wiki/FAQ/zh-cn#.E9. ... 8.E5.8C.96

后半你确定是fcitx的问题?
已知有问题的只有firefox的菜单,bug在 libx11 或者 firefox 里面。

https://bugzilla.mozilla.org/show_bug.cgi?id=787943
可以用 gtk2 的immodule 绕过。
https://bbs.archlinux.org/viewtopic.php?id=156927
虽然我把title改成solved, 但实际是问题定位到了fcitx4.2.7. 因为我downgrade到4.2.6什么异常都没有了

我没开forefox, 仅仅是刚登录X, 在terminal上切换fcitx, X就100%. 若是libx11的问题, 为什么fcitx4.2.6就没问题呢?

在对应fcitx4.2.7的fcitx-configtool-0.4.6-1里, Appearance下, 是一片空白, 什么也没有. 这个貌似和kimpanel有关吧
建议你把 setxkbmap 去掉然后用 fcitx 来配键盘布局
谢谢你的回复.

但为什么我用fcitx426就什么问题也没有呢? 在fcitx427的时候, 键盘是正确识别的, 但仅仅是一部分四周的乱七八糟的功能键出现异常.

我仅仅用fcitx打中文. 平时输入字母多于汉字, 所以不想通过fcitx输入字母.(你难道是说, 启动fcitx之后, 就不用额外地setxkbmap了?)


-----------------------------------------------------------
刚试了一番

1>fcitx426
加上eval `dbus-launch --sh-syntax --exit-with-session`
去掉setxkbmap
===>基本可以正常使用fcitx, 键盘识别也正确. 但问题是, 我用的wm是icewm, 在icewm下自己定义了一些快捷键, 用setxkbmap, icewm的快捷键的键盘识别正确, 而去掉setxkmap,仅仅靠fcitx, icewm快捷键的键盘识别错误. 应该是fcitx对键盘的定义没传到icewm那, 而setxkbmap可以

2>upgrade到fcitx427
加上eval `dbus-launch --sh-syntax --exit-with-session`
去掉setxkbmap
===>X100%现象没有了, appearance可以正常显示. 可icewm快捷键的键盘识别依旧有问题(如426), 而且四周的一些功能键还是失效.

结论::(1)fcitx427还是存在一些很难触发的小众问题,(2)我继续使用fcitx426, 等待428的出现
一梦三年,
松风依旧,
萝月何曾老.


灵幽听微, 谁观玉颜?
灼灼春华, 绿叶含丹.
csslayer
帖子: 572
注册时间: 2009-08-03 13:08
送出感谢: 1 次
接收感谢: 16 次

Re: [fcitx] 双拼输入时出现的奇怪字符

#14

帖子 csslayer » 2013-01-28 17:16

yjcong 写了:
csslayer 写了:
yjcong 写了:
csslayer 写了:
yjcong 写了:刚升级的4.2.7把键盘一部分功能给吃了, 而且, X动不动的就100%
什么意思?
键盘部分你想说这个?
http://fcitx-im.org/wiki/FAQ/zh-cn#.E9. ... 8.E5.8C.96

后半你确定是fcitx的问题?
已知有问题的只有firefox的菜单,bug在 libx11 或者 firefox 里面。

https://bugzilla.mozilla.org/show_bug.cgi?id=787943
可以用 gtk2 的immodule 绕过。
https://bbs.archlinux.org/viewtopic.php?id=156927
虽然我把title改成solved, 但实际是问题定位到了fcitx4.2.7. 因为我downgrade到4.2.6什么异常都没有了

我没开forefox, 仅仅是刚登录X, 在terminal上切换fcitx, X就100%. 若是libx11的问题, 为什么fcitx4.2.6就没问题呢?

在对应fcitx4.2.7的fcitx-configtool-0.4.6-1里, Appearance下, 是一片空白, 什么也没有. 这个貌似和kimpanel有关吧
建议你把 setxkbmap 去掉然后用 fcitx 来配键盘布局
谢谢你的回复.

但为什么我用fcitx426就什么问题也没有呢? 在fcitx427的时候, 键盘是正确识别的, 但仅仅是一部分四周的乱七八糟的功能键出现异常.

我仅仅用fcitx打中文. 平时输入字母多于汉字, 所以不想通过fcitx输入字母.(你难道是说, 启动fcitx之后, 就不用额外地setxkbmap了?)


-----------------------------------------------------------
刚试了一番

1>fcitx426
加上eval `dbus-launch --sh-syntax --exit-with-session`
去掉setxkbmap
===>基本可以正常使用fcitx, 键盘识别也正确. 但问题是, 我用的wm是icewm, 在icewm下自己定义了一些快捷键, 用setxkbmap, icewm的快捷键的键盘识别正确, 而去掉setxkmap,仅仅靠fcitx, icewm快捷键的键盘识别错误. 应该是fcitx对键盘的定义没传到icewm那, 而setxkbmap可以

2>upgrade到fcitx427
加上eval `dbus-launch --sh-syntax --exit-with-session`
去掉setxkbmap
===>X100%现象没有了, appearance可以正常显示. 可icewm快捷键的键盘识别依旧有问题(如426), 而且四周的一些功能键还是失效.

结论::(1)fcitx427还是存在一些很难触发的小众问题,(2)我继续使用fcitx426, 等待428的出现
中文的时候默认用 us 布局,你得用 fcitx-configtool 来把中文的改成 de 的。你有用xmodmap吗?

fcitx 的对布局的管理有两种,一个是没有可以输入的位置的时候,有个单独的布局设置,这个时候它会跑去读现在 X 的那个布局,可以用 fcitx 的设置覆盖,方法是用 fcitx-configtool 的第一页的 右下角的第一个键盘 图标设个布局。还有就是有输入位置的时候会按照当前的输入法选择一个布局。configtool 第一页选中某个输入法的时候,点右起第二个按钮可以配置这个输入法的布局。

当然……你还可以用这个命令启动

fcitx --disable fcitx-xkb

然后继续用你的 setxkbmap
csslayer
帖子: 572
注册时间: 2009-08-03 13:08
送出感谢: 1 次
接收感谢: 16 次

Re: [fcitx] 双拼输入时出现的奇怪字符

#15

帖子 csslayer » 2013-01-28 18:19

yjcong 写了:
csslayer 写了:
yjcong 写了:
csslayer 写了:
yjcong 写了:刚升级的4.2.7把键盘一部分功能给吃了, 而且, X动不动的就100%
什么意思?
键盘部分你想说这个?
http://fcitx-im.org/wiki/FAQ/zh-cn#.E9. ... 8.E5.8C.96

后半你确定是fcitx的问题?
已知有问题的只有firefox的菜单,bug在 libx11 或者 firefox 里面。

https://bugzilla.mozilla.org/show_bug.cgi?id=787943
可以用 gtk2 的immodule 绕过。
https://bbs.archlinux.org/viewtopic.php?id=156927
虽然我把title改成solved, 但实际是问题定位到了fcitx4.2.7. 因为我downgrade到4.2.6什么异常都没有了

我没开forefox, 仅仅是刚登录X, 在terminal上切换fcitx, X就100%. 若是libx11的问题, 为什么fcitx4.2.6就没问题呢?

在对应fcitx4.2.7的fcitx-configtool-0.4.6-1里, Appearance下, 是一片空白, 什么也没有. 这个貌似和kimpanel有关吧
建议你把 setxkbmap 去掉然后用 fcitx 来配键盘布局
谢谢你的回复.

但为什么我用fcitx426就什么问题也没有呢? 在fcitx427的时候, 键盘是正确识别的, 但仅仅是一部分四周的乱七八糟的功能键出现异常.

我仅仅用fcitx打中文. 平时输入字母多于汉字, 所以不想通过fcitx输入字母.(你难道是说, 启动fcitx之后, 就不用额外地setxkbmap了?)


-----------------------------------------------------------
刚试了一番

1>fcitx426
加上eval `dbus-launch --sh-syntax --exit-with-session`
去掉setxkbmap
===>基本可以正常使用fcitx, 键盘识别也正确. 但问题是, 我用的wm是icewm, 在icewm下自己定义了一些快捷键, 用setxkbmap, icewm的快捷键的键盘识别正确, 而去掉setxkmap,仅仅靠fcitx, icewm快捷键的键盘识别错误. 应该是fcitx对键盘的定义没传到icewm那, 而setxkbmap可以

2>upgrade到fcitx427
加上eval `dbus-launch --sh-syntax --exit-with-session`
去掉setxkbmap
===>X100%现象没有了, appearance可以正常显示. 可icewm快捷键的键盘识别依旧有问题(如426), 而且四周的一些功能键还是失效.

结论::(1)fcitx427还是存在一些很难触发的小众问题,(2)我继续使用fcitx426, 等待428的出现
不介意的话贴下你完整的 ~/.xinitrc
回复

回到 “字体美化和中文支持”