当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 10 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 英文界面下,文档里的内容显示为乱码!
帖子发表于 : 2007-02-04 23:22 

注册: 2006-12-15 21:55
帖子: 118
地址: 重庆
送出感谢: 0 次
接收感谢: 0 次
这个问题怎么解决啊?
~$ locale
LANG=en_US.UTF-8
LANGUAGE=en_US:en_GB:en
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
好像这个有问题,不知道应该怎么改哦,麻烦大虾指点下。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-02-04 23:33 

注册: 2006-12-15 21:55
帖子: 118
地址: 重庆
送出感谢: 0 次
接收感谢: 0 次
在gedit里面,tools->set language里面也没有中文选项。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-02-04 23:53 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
language-pack-zh
language-pack-gnome-zh


_________________
● 鸣学


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-02-05 0:15 
头像

注册: 2006-07-14 18:56
帖子: 345
地址: Apple Valley, Planet Tux, Linux System
送出感谢: 0 次
接收感谢: 0 次
daniums 写道:
在gedit里面,tools->set language里面也没有中文选项。


在open/save对话框里选


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-02-05 2:07 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
运行gconf-editor,找到 /apps/gedit-2/preferences/encodings/auto_detected
把GB18030放到第一位。


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-02-05 8:01 

注册: 2006-12-15 21:55
帖子: 118
地址: 重庆
送出感谢: 0 次
接收感谢: 0 次
eexpress 写道:
language-pack-zh
language-pack-gnome-zh

你说的是中文语言包吧?这个我是安装了的啊。


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-02-05 8:04 

注册: 2006-12-15 21:55
帖子: 118
地址: 重庆
送出感谢: 0 次
接收感谢: 0 次
5451vs5451 写道:
daniums 写道:
在gedit里面,tools->set language里面也没有中文选项。


在open/save对话框里选

这个也不行,我记得我上次装完系统不需要设置就能显示啊,郁闷。


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-02-05 8:06 

注册: 2006-12-15 21:55
帖子: 118
地址: 重庆
送出感谢: 0 次
接收感谢: 0 次
zhuqin_83 写道:
运行gconf-editor,找到 /apps/gedit-2/preferences/encodings/auto_detected
把GB18030放到第一位。

找到这个地方,没有GB18030 :shock: :shock: :shock:


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-02-05 8:15 
头像

注册: 2006-05-13 4:02
帖子: 10606
送出感谢: 0 次
接收感谢: 7
自己添阿


_________________
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-02-05 9:40 

注册: 2006-12-15 21:55
帖子: 118
地址: 重庆
送出感谢: 0 次
接收感谢: 0 次
zhuqin_83 写道:
运行gconf-editor,找到 /apps/gedit-2/preferences/encodings/auto_detected
把GB18030放到第一位。

按照这个方法添加了GB2312,放到第2位,第1位是UTF8,现在能够正常显示了。
谢谢各位兄弟。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 10 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Bing [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译