当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : XMMS 的问题!
帖子发表于 : 2005-10-18 0:30 

注册: 2005-10-09 15:25
帖子: 155
送出感谢: 0 次
接收感谢: 0 次
用新立得装了个XMMS可是全是乱码!怎么解决啊?
怎么装皮肤啊?它的界面太难看了!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-10-18 10:31 

注册: 2005-10-02 16:08
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
乱码问题我也还没解决

但是现在我会装皮肤了,可以在 http://www.xmms.org/skins.php

这里是装皮肤的指南:http://www.xmms.org/faq.php#Skins1

切记要有权限访问皮肤文件夹,我之前就是这个问题弄了好久


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-10-19 22:44 
头像

注册: 2005-08-15 0:04
帖子: 1880
地址: 南7技校
送出感谢: 0 次
接收感谢: 0 次
关于xmms乱码问题论坛上有相当多的帖子,收一收就好了,设置也不是太难。
其实皮肤可以apt-get的,只是好象目录变到了/usr/share/xmms/skins下了,自己改一下就好


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-10-20 12:33 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
/usr/share/xmms/Skins


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-04-09 0:47 

注册: 2005-12-28 16:23
帖子: 233
送出感谢: 0 次
接收感谢: 0 次
将下载下来的tar包放在

~/.xmms/skin

也可以的


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2006-04-09 9:50 

注册: 2006-03-16 20:14
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
beep 的乱码怎么解决阿??
大牛们?


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2006-04-09 12:18 
头像

注册: 2005-07-11 17:37
帖子: 336
地址: 浙江
送出感谢: 0 次
接收感谢: 0 次
http://wiki.ubuntu.org.cn/index/chinese/beep_zh


_________________
ubuntu 5.10 +windowsxpsp2
HP NX6120
PM1.6+512M DDR333+915GM+40G HD+Combo

Life is Struggle!


页首
 用户资料  
 
8 楼 
 文章标题 : [转]xmms中文解决方案
帖子发表于 : 2006-04-12 7:32 
头像

注册: 2006-03-30 7:30
帖子: 32
送出感谢: 0 次
接收感谢: 0 次
无论如何gtk1.x程序都会读取用户目录下的.gtkrc,优先级高于/etc/gtk/下的设置文件 (如果使用gnome,则 gnome-settings-daemon 会在用户目录下创建名为 .gtkrc-1.2-gnome2 的文件,其中指向一个设置文件,一般是.gtkrc.mine,优先级高于.gtkrc)。所以,只需要设置好用户目录下的.gtkrc(使用gnome则设置好.gtkrc.mine)即可。

因为你使用了utf8的locale,所以在保证字体所在目录中fonts.dir和fonts.scale 完整并正确的前提下,应该用类似 -misc-simsun-medium-r-normal-*-12-*-*-*-*-*-iso10646-1 这样的行来描述所要使用的中文字体,xmms的界面中文显示才会正确。而后在xmms本身的设置里设置好字体即可。如果希望xmms可以自动找到正确的字体来显示不同的编码,在所有字体的最后再加一个*-r-*(别忘了前面的逗号)即可。

第一步:因此我就在我的用户主目录下创建了一个文件
代码:
.gtkrc.mine
文件内容为:
# $(gtkconfigdir)/gtkrc.zh_CN
#
# This file defines the fontsets for Chinese language (zh) using
# the simplified chinese standard GuoBiao as in mainland China (CN)
#
# 1999, Pablo Saratxaga <pablo@mandrakesoft.com>
#

style "gtk-default-zh-cn" {
fontset = "-adobe-helvetica-medium-r-normal--12-*-*-*-*-*-iso8859-1,\
-*-*-medium-r-normal--16-*-*-*-*-*-gb2312.1980-0,*-r-*"
}
class "GtkWidget" style "gtk-default-zh-cn"
现在仔细看了 一下,发现播放清单的中文字体显示还没解决。 Mad

第二步:播放清单字体设置为;
-adobe-helvetica-medium-r-normal--12-*-*-*-*-*-iso8859-1,-*-*-medium-r-normal--16-*-*-*-*-*-gb2312.1980-0,*-r-*
大部分中文能显示,不过由于mp3里面什么编码的不同,有一些不能正常显示

第三步:Very Happy Very Happy Very Happy 哈,解决了,就是楼顶说的:
1.安装 xmms-mpg123-ja
代码:
sudo apt-get install xmms-mpg123-ja (xmms-mpg123-ja比默认的mpg123多了编码转换)
2.
用 xmms-mpg123-ja 插件代替 xmms 默认的 xmms-mpg123
xmms 首选项-》音频输入输出插件
去掉 libmpg123 的[启用]
选上 libmpg123-ja 的 [启用]

3.
xmms 首选项-》音频输入输出插件 -》 libmpg123-ja -》配置 -》标题
选上输入转换
GB18030 -》 UTF-8
第四步:
播放清单中仍有部分中文乱码,找到一个临时的解决办法,就是
1。右键点击歌曲,在弹出来的菜单中
2。选中 查看文件信息 ,
3。然后点击 移除ID3标签 ,然后关闭。
4。注意不要点击 保存 ,不然就不行,怪!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译