我怎么找不到scim-modules-socket?

系统字体配置、中文显示和输入法问题
回复
shangxd
帖子: 3
注册时间: 2005-08-30 11:21
送出感谢: 0
接收感谢: 0

我怎么找不到scim-modules-socket?

#1

帖子 shangxd » 2005-10-21 9:00

我的sources.list

代码: 全选

deb http://archive.ubuntu.org.cn/ubuntu hoary main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu hoary-security main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu hoary-updates main restricted universe multiverse
#deb http://archive.ubuntu.org.cn/ubuntu-cn ubuntu.org.cn main universe multiverse restricted
deb http://archive.ubuntu.org.cn/ubuntu hoary-backports main universe multiverse
deb http://archive.ubuntu.org.cn/backports hoary-extras main universe multiverse restricted
deb-src http://archive.ubuntu.org.cn/ubuntu hoary main restricted universe multiverse
deb-src http://archive.ubuntu.org.cn/ubuntu hoary-security main restricted universe multiverse
deb-src http://archive.ubuntu.org.cn/ubuntu hoary-updates main restricted universe multiverse

中间注释的那个是因为更新有错误。是不是少了什么?
头像
freeflying
论坛版主
帖子: 521
注册时间: 2005-03-26 9:38
送出感谢: 0
接收感谢: 0

#2

帖子 freeflying » 2005-10-21 11:41

use this :

代码: 全选


deb http://debian.cn99.com/ubuntu-cn breezy main

shangxd
帖子: 3
注册时间: 2005-08-30 11:21
送出感谢: 0
接收感谢: 0

#3

帖子 shangxd » 2005-10-21 13:11

sources.list是:
deb http://archive.ubuntu.org.cn/ubuntu hoary main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu hoary-security main restricted universe multiverse
deb http://archive.ubuntu.org.cn/ubuntu hoary-updates main restricted universe multiverse
#deb http://archive.ubuntu.org.cn/ubuntu-cn ubuntu.org.cn main universe multiverse restricted
deb http://archive.ubuntu.org.cn/ubuntu hoary-backports main universe multiverse
deb http://archive.ubuntu.org.cn/backports hoary-extras main universe multiverse restricted
deb-src http://archive.ubuntu.org.cn/ubuntu hoary main restricted universe multiverse
deb-src http://archive.ubuntu.org.cn/ubuntu hoary-security main restricted universe multiverse
deb-src http://archive.ubuntu.org.cn/ubuntu hoary-updates main restricted universe multiverse
deb http://debian.cn99.com/ubuntu-cn breezy main

现在有以下错误:

代码: 全选

# apt-get install scim scim-gtk2-immodule scim-modules-socket scim-modules-table scim-pinyin scim-tables-zh scim-input-pad
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  scim: Depends: libc6 (>= 2.3.4-1) but 2.3.2.ds1-20ubuntu14 is to be installed
        Depends: libcairo2 (>= 1.0.2) but it is not installable
        Depends: libfontconfig1 (>= 2.3.0) but 2.2.3-4ubuntu7 is to be installed
        Depends: libgcc1 (>= 1:4.0.1) but 1:4.0-0pre6ubuntu7 is to be installed
        Depends: libglib2.0-0 (>= 2.8.0) but 2.6.3-1 is to be installed
        Depends: libgtk2.0-0 (>= 2.8.0) but 2.6.4-0ubuntu4 is to be installed
        Depends: libpango1.0-0 (>= 1.10.1) but 1.8.1-0ubuntu2 is to be installed
        Depends: libscim8 but it is not going to be installed
        Depends: libstdc++6 (>= 4.0.1) but it is not going to be installed
  scim-gtk2-immodule: Depends: libc6 (>= 2.3.4-1) but 2.3.2.ds1-20ubuntu14 is to be installed
                      Depends: libcairo2 (>= 1.0.2) but it is not installable
                      Depends: libfontconfig1 (>= 2.3.0) but 2.2.3-4ubuntu7 is to be installed
                      Depends: libgcc1 (>= 1:4.0.1) but 1:4.0-0pre6ubuntu7 is to be installed
                      Depends: libglib2.0-0 (>= 2.8.0) but 2.6.3-1 is to be installed
                      Depends: libgtk2.0-0 (>= 2.8.0) but 2.6.4-0ubuntu4 is to be installed
                      Depends: libpango1.0-0 (>= 1.10.1) but 1.8.1-0ubuntu2 is to be installed
                      Depends: libscim8 but it is not going to be installed
                      Depends: libstdc++6 (>= 4.0.1) but it is not going to be installed
  scim-input-pad: Depends: libc6 (>= 2.3.4-1) but 2.3.2.ds1-20ubuntu14 is to be installed
                  Depends: libcairo2 (>= 1.0.2) but it is not installable
                  Depends: libfontconfig1 (>= 2.3.0) but 2.2.3-4ubuntu7 is to be installed
                  Depends: libgcc1 (>= 1:4.0.1) but 1:4.0-0pre6ubuntu7 is to be installed
                  Depends: libglib2.0-0 (>= 2.8.0) but 2.6.3-1 is to be installed
                  Depends: libgtk2.0-0 (>= 2.8.0) but 2.6.4-0ubuntu4 is to be installed
                  Depends: libpango1.0-0 (>= 1.10.1) but 1.8.1-0ubuntu2 is to be installed
                  Depends: libscim8 but it is not going to be installed
                  Depends: libstdc++6 (>= 4.0.1) but it is not going to be installed
  scim-modules-socket: Depends: libc6 (>= 2.3.4-1) but 2.3.2.ds1-20ubuntu14 is to be installed
                       Depends: libgcc1 (>= 1:4.0.1) but 1:4.0-0pre6ubuntu7 is to be installed
                       Depends: libscim8 but it is not going to be installed
                       Depends: libstdc++6 (>= 4.0.1) but it is not going to be installed
  scim-modules-table: Depends: libc6 (>= 2.3.4-1) but 2.3.2.ds1-20ubuntu14 is to be installed
                      Depends: libcairo2 (>= 1.0.2) but it is not installable
                      Depends: libfontconfig1 (>= 2.3.0) but 2.2.3-4ubuntu7 is to be installed
                      Depends: libgcc1 (>= 1:4.0.1) but 1:4.0-0pre6ubuntu7 is to be installed
                      Depends: libglib2.0-0 (>= 2.8.0) but 2.6.3-1 is to be installed
                      Depends: libgtk2.0-0 (>= 2.8.0) but 2.6.4-0ubuntu4 is to be installed
                      Depends: libpango1.0-0 (>= 1.10.1) but 1.8.1-0ubuntu2 is to be installed
                      Depends: libscim8 but it is not going to be installed
                      Depends: libstdc++6 (>= 4.0.1) but it is not going to be installed
  scim-pinyin: Depends: libc6 (>= 2.3.4-1) but 2.3.2.ds1-20ubuntu14 is to be installed
               Depends: libcairo2 (>= 1.0.2) but it is not installable
               Depends: libfontconfig1 (>= 2.3.0) but 2.2.3-4ubuntu7 is to be installed
               Depends: libgcc1 (>= 1:4.0.1) but 1:4.0-0pre6ubuntu7 is to be installed
               Depends: libglib2.0-0 (>= 2.8.0) but 2.6.3-1 is to be installed
               Depends: libgtk2.0-0 (>= 2.8.0) but 2.6.4-0ubuntu4 is to be installed
               Depends: libpango1.0-0 (>= 1.10.1) but 1.8.1-0ubuntu2 is to be installed
               Depends: libscim8 but it is not going to be installed
               Depends: libstdc++6 (>= 4.0.1) but it is not going to be installed
E: Broken packages

代码: 全选

回复

回到 “字体美化和中文支持”