当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]我想问一下,能不能能在英文系统下输入汉字??谢谢了
帖子发表于 : 2007-05-26 17:54 

注册: 2007-05-20 14:33
帖子: 33
送出感谢: 0 次
接收感谢: 0 次
能不能能在英文系统下输入汉字?我已经安装了输入法,在中文系统下 可以输入汉字,在英文系统下面好像按ctrl和 空格 不能 调出 csim
谁 知道 帮我一下
谢谢大家了


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-05-26 18:23 
头像

注册: 2007-01-15 17:15
帖子: 3766
送出感谢: 0 次
接收感谢: 0 次
论坛有答案


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-05-26 22:20 

注册: 2006-04-03 11:26
帖子: 551
送出感谢: 0 次
接收感谢: 1
一点问题没有,我就是英文系统下用的


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-05-28 4:17 

注册: 2005-04-09 7:23
帖子: 162
地址: 云南
送出感谢: 0 次
接收感谢: 0 次
编辑/etc/gtk-2.0/gtk.immodules文件。
把:
"/usr/lib/gtk-2.0/2.10.0/immodules/im-xim.so"
"xim" "X Input Method" "gtk20" "/usr/share/locale" "ko:ja:th:zh"

改为
"/usr/lib/gtk-2.0/2.10.0/immodules/im-xim.so"
"xim" "X Input Method" "gtk20" "/usr/share/locale" "en:ko:ja:th:zh"


_________________
图片图片
我滴blog


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-06-03 11:45 

注册: 2007-06-02 21:47
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
冰封尘 写道:
编辑/etc/gtk-2.0/gtk.immodules文件。
把:
"/usr/lib/gtk-2.0/2.10.0/immodules/im-xim.so"
"xim" "X Input Method" "gtk20" "/usr/share/locale" "ko:ja:th:zh"

改为
"/usr/lib/gtk-2.0/2.10.0/immodules/im-xim.so"
"xim" "X Input Method" "gtk20" "/usr/share/locale" "en:ko:ja:th:zh"
谢谢。按您的办法已经可以输入汉字了。


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-06-10 23:07 

注册: 2007-06-10 23:00
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
i still cant... ive done exactly as you said tho


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-06-10 23:17 

注册: 2006-09-07 22:51
帖子: 849
送出感谢: 0 次
接收感谢: 0 次
如果使用fctix的话这是我的例子:
代码:
#!/bin/bash
cat<<eof>/etc/X11/Xsession.d/95xinput
#!/bin/bash
case \$LC_CTYPE in
*zh_CN*)
;;
*)
export LC_CTYPE="zh_CN.UTF-8";
export XMODIFIERS='@im=fcitx';
export GTK_IM_MODULE="fcitx" ;
;;
esac
if [ \$(ps aux|grep -v grep |grep fcitx |cut -c 66-70) == "fcitx" ];then
echo "fcitx is runing "
else
fcitx
fi
eof
chmod +x /etc/X11/Xsession.d/95xinput


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-06-20 9:58 

注册: 2007-04-04 9:18
帖子: 8
送出感谢: 0 次
接收感谢: 0 次
But i still can't input chinese in gnome. i have edited this files.


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-06-20 10:46 
头像

注册: 2007-02-02 18:14
帖子: 30702
系统: debian sid
送出感谢: 1
接收感谢: 34
scim没有装好


_________________
醉了星星,醉月亮●●●●●The Long Way To Go(*^_^*)


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-06-24 22:08 

注册: 2007-05-17 16:24
帖子: 39
送出感谢: 0 次
接收感谢: 0 次
按照如下方法,应该没问题的,我就是这样的:
Chinese Input for Ubuntu Hoary:
(version française) (http://forum.ubuntu-fr.org/viewtopic.ph ... 862#p17862)

1) install the following packages:
* scim
* scim-chinese
* scim-config-socket
* scim-frontend-socket
* scim-gtk2-immodule
* scim-server-socket
* scim-tables-zh (option)
* xfonts-intl-chinese
* xfonts-intl-chinese-big
* ttf-arphic-gbsn00lp
* ttf-arphic-gkai00mp
* ttf-arphic-bkai00mp
* ttf-arphic-bsmi00lp

accept all dependencies.

2) System -> Preferences -> Sessions

Startup Programs Tab -> Add Button
Startup Command: scim -d
Order: 80

3) Restart Gnome: CTRL+ALT+SUPPR

4) Open any software and press CTRL+SPACE to activate chinese input
------------------------------------------------------------------------------------------------------

IF not working you can as an alternative replace step 2) as follow:

2) alt+F2, gedit

type these few lines:
scim -d
export XMODIFIERS=@im=scim
export GTK_IM_MODULE=scim
gnome-session
Save them under your home directory name: .xsession

Then open a terminal and type:
$chmod +x .xsession


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-06-29 23:17 

注册: 2007-06-29 22:57
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
其实什么文件都不用修改,直接在 "Synaptic Package Manager"里的Internationalization and localization里选上所有的zh_CN中文语言支持包就可以了,包括SCIM输入法的中文输入,系统显示中文等等。。。

ubuntu做的很方便的,用"Synaptic Package Manager"就可以,共享了debian的package,几乎不用自己安装什么。


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-07-16 13:27 

注册: 2007-05-20 14:33
帖子: 33
送出感谢: 0 次
接收感谢: 0 次
谢谢大家了


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2007-07-17 12:44 

注册: 2007-06-02 21:47
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
likey 写道:
按照如下方法,应该没问题的,我就是这样的:
Chinese Input for Ubuntu Hoary:
(version française) (http://forum.ubuntu-fr.org/viewtopic.ph ... 862#p17862)

1) install the following packages:
* scim
* scim-chinese
* scim-config-socket
* scim-frontend-socket
* scim-gtk2-immodule
* scim-server-socket
* scim-tables-zh (option)
* xfonts-intl-chinese
* xfonts-intl-chinese-big
* ttf-arphic-gbsn00lp
* ttf-arphic-gkai00mp
* ttf-arphic-bkai00mp
* ttf-arphic-bsmi00lp

accept all dependencies.

2) System -> Preferences -> Sessions

Startup Programs Tab -> Add Button
Startup Command: scim -d
Order: 80

3) Restart Gnome: CTRL+ALT+SUPPR

4) Open any software and press CTRL+SPACE to activate chinese input
------------------------------------------------------------------------------------------------------

IF not working you can as an alternative replace step 2) as follow:

2) alt+F2, gedit

type these few lines:
scim -d
export XMODIFIERS=@im=scim
export GTK_IM_MODULE=scim
gnome-session
Save them under your home directory name: .xsession

Then open a terminal and type:
$chmod +x .xsession
重装以后,又不能在英文系统中使用SCIM中文输入法了,后来按照以上办法一步步做居然成功了,太感谢您了。


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-07-18 16:12 

注册: 2007-06-02 21:47
帖子: 26
送出感谢: 0 次
接收感谢: 0 次
likey:你的办法同样适用于FC7,我试过了。谢谢。如果你不反对的话,我准备将此贴转发到红联等其它有关FC的网站,让更多的朋友了解。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译