当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 22 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 我制作的fcitx 3.5-0703 deb包,请大家试用
帖子发表于 : 2007-07-06 16:16 

注册: 2007-01-08 10:48
帖子: 426
地址: 北京
送出感谢: 0 次
接收感谢: 0 次
首先感谢cenlonchen的指点!没有他的指点我无法制作出fcitx3.5的deb包。昨天我编译出错,cenlonchen进行了指点,但很惭愧我当时没有试成功。今天又试,将原来的fcitx-3.5目录删掉重新解压缩,重新按照cenlonchen的指点进行操作,第一次仍然是同样的错误,第二次在命令前方加了sudo,结果终于成功了!!!只是生成的包写的是3.3.1,不知道是为什么,可能是因为我机器里当时装的是3.3.1的版本。
接下来apt-get remove fcitx,然后在进程里杀掉fcitx进程(结果会出现一系列崩溃信息,不过没关系,最后会恢复正常)。接着,安装新的fcitx包,注销并重新登录就可以了。
我试用了一下, 在eva中正常输入没问题(我用的可是最新的五笔拼音啊,呵呵,好用!),在crossover office2003的word中用也没问题,还解决了前一个版本(3.3.1)存在的问题,在kconsole中用也没问题,真是爽啊!!!是不是还有别的问题我就不知道,希望大家在试用过程中发现吧。呵呵,以上这些用的就是fcitx 3.5五笔拼音!

完了,因为附件限定在2M以下,而我制作的fcitx包有4.8M大,有谁能告诉我怎么办让大家都分享我的成果?!


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-07-06 16:28 
头像

注册: 2005-06-11 14:03
帖子: 6226
地址: 不明真相的群众
送出感谢: 0 次
接收感谢: 0 次
修改 fcitx-3.5 目录里面的debian目录里面的changelog, 把最上面的版本好改成你需要的版本号.

生产deb很简单.特别是有debian目录的时候. 只需要在源代码目录执行下面的一条语句就可以了.

fakeroot debian/rules binary


如果缺什么包就安装什么就好了.


_________________
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-07-06 16:40 

注册: 2007-01-08 10:48
帖子: 426
地址: 北京
送出感谢: 0 次
接收感谢: 0 次
非常感谢!我用你的指点修改了。现在用dpkg-buildpackage -rfakeroot命令打的包就是想要的版本号的包了。大家也可以我写的这个命令去打包。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-07-06 23:52 

注册: 2007-07-06 23:49
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
想要啊.谁有FTP啊.


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-07-07 0:19 
头像

注册: 2005-11-06 1:51
帖子: 1795
地址: 七彩云世界
送出感谢: 0 次
接收感谢: 0 次
lrbin50 写道:
想要啊.谁有FTP啊.

我也是,今天刚编译的,苦于.ftpubuntu上不去,.
版本号,的确是个小失误.
我已经和,yuking通知了.相信很快就会改过来的.!!!


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-07-07 0:23 

注册: 2007-07-06 23:49
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
等待啊.早就想这个东东了


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-07-07 11:45 

注册: 2005-08-06 10:10
帖子: 198
送出感谢: 0 次
接收感谢: 0 次
等啊,等
还是没等到


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-07-07 17:11 

注册: 2007-07-06 23:49
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
没有原意传一个啊。我编译老出错的啊。等了大半天了没一个好心人啊。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-07-08 20:03 

注册: 2006-05-19 20:32
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
hehe shi yong


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-07-09 17:39 

注册: 2005-08-10 20:19
帖子: 108
送出感谢: 0 次
接收感谢: 0 次
ftp://ftp.hyvv.org/linux/fcitx_3.5.4-1_i386.deb
下了记得要顶哦。。

有空看看我的博客吧http://www.hyvv.org


_________________
图片

http://www.hyvv.org
我的UBUNTU7.10博客


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-07-09 21:38 

注册: 2007-07-06 23:49
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
顶你一下,我想要个AMD64的有没有啊?


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2007-07-09 22:32 

注册: 2005-08-10 20:19
帖子: 108
送出感谢: 0 次
接收感谢: 0 次
lrbin50 写道:
顶你一下,我想要个AMD64的有没有啊?

我没有哦。上面那个是i386的。问楼主看看。
我只是在BBS下载的再提供一个完整的文件!!


_________________
图片

http://www.hyvv.org
我的UBUNTU7.10博客


页首
 用户资料  
 
13 楼 
 文章标题 : 顶一下
帖子发表于 : 2007-07-10 22:56 

注册: 2007-02-03 23:06
帖子: 40
送出感谢: 0 次
接收感谢: 0 次
:lol:


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2007-07-11 12:51 

注册: 2006-05-30 20:48
帖子: 524
送出感谢: 0 次
接收感谢: 0 次
看到这个版本就想收藏了。
希望那不是真的。


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2007-07-11 13:12 

注册: 2006-05-30 20:48
帖子: 524
送出感谢: 0 次
接收感谢: 0 次
7.04里不可用?装里就启动不里gnome了。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 22 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译