当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]smbmount ubuntu分区时中文目录或文件不显示
帖子发表于 : 2007-09-18 16:03 

注册: 2006-05-30 10:13
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
环境:server为 ubuntu 6.06 开启 samba服务

client为 ubuntu 7.04 使用 Network窗口管理器可以浏览到所有的中文目录或文件

fstab:

# /suzhou/public
//suzhou/public /mnt/public smbfs iocharset=utf8,username=**,password=**,uid=1000,umask=000 0 0

中文目录或文件不显示;

locale为:

LANG=en_US.UTF-8
LANGUAGE=en_US:en
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

费解,iocharset我曾经改为cp936,gb2312都不可以,费解。希望有成功人士指点一二。


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-09-18 16:11 
头像

注册: 2005-12-12 19:10
帖子: 117
地址: 山西左权
送出感谢: 2
接收感谢: 1
应该是samba服务器的问题。
在globl项下加入:
display charset = UTF-8
unix charset = UTF-8
dos charset = cp936

不过,有可能我没有明白你的问题


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-09-19 17:11 

注册: 2006-05-30 10:13
帖子: 6
送出感谢: 0 次
接收感谢: 0 次
确实是samba服务器的问题,按照您的设置还是不可以,很搞笑的我把UTF-8改成utf8,

dos charset = utf8
unix charset = utf8

就可以了,很费解,因为默认就应是这个配置了


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-09-19 17:29 
头像

注册: 2005-12-12 19:10
帖子: 117
地址: 山西左权
送出感谢: 2
接收感谢: 1
嗯呐


_________________
以前佩服德国,一个国家就能单挑那么多还差点打赢;现在鄙视德国,一个国家怎么总搞到被群殴!
以前鄙视苏联,被打得半死;现在佩服苏联,被打成那样不死还能扳回来!
以前鄙视美国,不就是凭着块大;现在佩服美国,有本事你也那么强大!

Thinkpad R400 P8700/4g RAM/320G+160G sata Disk/Windows 7 + Ubuntu 11.10


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:squall724 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译