输入法的问题,各位救命

系统字体配置、中文显示和输入法问题
回复
marising
帖子: 8
注册时间: 2007-08-10 11:05
送出感谢: 0
接收感谢: 0

输入法的问题,各位救命

#1

帖子 marising » 2007-09-26 12:00

1.我装的是SCIM,但是发现不太好用,因此决定装fcitx
sudo apt-get install fcitx,重启x,
发现fcitx闪现了一下,就没有了,查看进程,发现已经启动,kill进程,再启动fcitx,输入法的小图标是有了,但是无法输入中文.
locale如下
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US.UTF-8
LANGUAGE=en_US:en
LC_CTYPE=zh_CN.UTF-8
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
2.实在不行删除fcitx重新安装scim,安装提示
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en_US:en",
LC_ALL = (unset),
LC_CTYPE = "zh_CN",
LANG = "en_US.UTF-8"
are supported and installed on your system.
按Ctrl + space也没有反应.
我的系统是英文,不知道是locale的原因还是其他原因.


$ dpkg-reconfigure locales

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en_US.UTF-8",
LC_ALL = "",
LC_CTYPE = "zh_CN.UTF-8",
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_ALL to default locale: No such file or directory
/usr/sbin/dpkg-reconfigure must be run as root
头像
bones7456
论坛版主
帖子: 8495
注册时间: 2006-04-12 20:05
来自: 杭州
送出感谢: 0
接收感谢: 8 次
联系:

#2

帖子 bones7456 » 2007-09-26 12:45

im-switch
关注我的blog: ε==3
头像
hualang0929
帖子: 1226
注册时间: 2006-11-11 10:23
来自: Mars
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 hualang0929 » 2007-09-26 12:47

刚开始用中文啦,熟悉了之后想怎么折腾再折腾~~
抬头望星空一片晴,我独行,夜已渐寒……
回复

回到 “字体美化和中文支持”