当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 11 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]IntelGM945集成显卡,MPlayer没有视频驱动[已经找到原因]
帖子发表于 : 2007-10-10 10:46 
头像

注册: 2007-09-09 15:41
帖子: 218
地址: Beijing
送出感谢: 0 次
接收感谢: 1
机器的图形界面应该是没有什么问题。但是MPlayer播放视频时只有声音,没有图像
代码:
mplayer -vo help

没有输出。
向这样的显卡,怎么安装视频驱动啊 :oops:

——————————————————————
问题貌似已经有眉目了,看第 N 楼


最后由 weilichun 编辑于 2007-10-12 22:15,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-10-10 10:49 
头像

注册: 2006-04-12 20:05
帖子: 8495
地址: 杭州
送出感谢: 0 次
接收感谢: 8
mplayer -vo help

这个都没有输出?你的mplayer是不是有问题啊?


_________________
关注我的blog: ε==3


页首
 用户资料  
 
3 楼 
 文章标题 : [问题]
帖子发表于 : 2007-10-10 11:13 
头像

注册: 2007-09-09 15:41
帖子: 218
地址: Beijing
送出感谢: 0 次
接收感谢: 1
bones7456 写道:
mplayer -vo help

这个都没有输出?你的mplayer是不是有问题啊?

应该没有吧,在源里安装的。没有视频驱动。
卸载后,官方网站下载源代码,自己编译安装,问题依旧。郁闷


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-10-10 19:04 
头像

注册: 2007-08-20 21:39
帖子: 1109
地址: 沈阳
送出感谢: 0 次
接收感谢: 0 次
我的是和楼主一样的显卡 没有这样的问题啊 是不是楼主没有选Mpaler的Video啊...改成XV11试试!


_________________
失恋的痛苦不在于失恋本身 在于青黄不接!
青黄不接的年代里 我把爱情暂放一边!

★★○●◎◇★☆☆★


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-10-11 12:52 
头像

注册: 2007-09-09 15:41
帖子: 218
地址: Beijing
送出感谢: 0 次
接收感谢: 1
shugoal 写道:
我的是和楼主一样的显卡 没有这样的问题啊 是不是楼主没有选Mpaler的Video啊...改成XV11试试!

怎么选择?楼上请你说的具体一点啊
像这个显卡,应该不用另外安装视频驱动吧..


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-10-11 16:13 

注册: 2007-10-11 15:58
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
打开mplayer,在 Preferences ///// Video //// xv
重启mplayer试一下


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-10-11 16:47 
头像

注册: 2007-09-09 15:41
帖子: 218
地址: Beijing
送出感谢: 0 次
接收感谢: 1
xfoxe 写道:
打开mplayer,在 Preferences ///// Video //// xv
重启mplayer试一下


Preferences->video里面什么也没有啊


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-10-12 16:20 

注册: 2007-10-11 15:58
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
参见置顶帖中的方法再试试呢


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-10-12 17:04 
头像

注册: 2007-08-20 21:39
帖子: 1109
地址: 沈阳
送出感谢: 0 次
接收感谢: 0 次
weilichun 写道:
xfoxe 写道:
打开mplayer,在 Preferences ///// Video //// xv
重启mplayer试一下


Preferences->video里面什么也没有啊


什么都没有??

把那个Mplayer打开 然后右键Mpaler 然后Preferences然后再选择Video选项卡 然后把那个改成X11 或者 xv 然后按OK 然后关闭Mplayer


_________________
失恋的痛苦不在于失恋本身 在于青黄不接!
青黄不接的年代里 我把爱情暂放一边!

★★○●◎◇★☆☆★


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2007-10-12 19:48 
头像

注册: 2007-09-09 15:41
帖子: 218
地址: Beijing
送出感谢: 0 次
接收感谢: 1
引用:
什么都没有??

把那个Mplayer打开 然后右键Mpaler 然后Preferences然后再选择Video选项卡 然后把那个改成X11 或者 xv 然后按OK 然后关闭Mplayer


老兄,video选项卡里没有任何驱动,怎么选啊 :oops: :oops:


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-10-12 22:27 
头像

注册: 2007-09-09 15:41
帖子: 218
地址: Beijing
送出感谢: 0 次
接收感谢: 1
在synaptic里需要首先安装库
比如,x11的驱动,需要安装x11-dev,具体的记得不清楚了。要想有SDL驱动,需要安装libSDL,好多呢。

在mplayer的官方网站下载源代码,[好像还有win32codes,播放rmvb需要这个],按照原代码包中的README进行操作
进入源代码包目录后
代码:
./configure

注意看各种驱动是否支持,如果不支持某种驱动,比如aa,caca[用字符界面的视频],需要安装libaa1或者libaa-dev
libcaca1或者libcaca-dev
[没有必要安装所有驱动,选择你想要的就可以了,比如x11基本上就够了]


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 11 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google Feedfetcher, loveofmaria 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译