当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [分享][教训]备份时所有中文变乱码
帖子发表于 : 2007-10-21 22:47 

注册: 2007-09-19 22:30
帖子: 76
地址: Shanghai
送出感谢: 0 次
接收感谢: 0 次
教训阿。。。。
我把笔记本整个换成ubuntu了,重新分了区,于是把以前的c盘d盘的内容备份到了移动硬盘上,这是在ubuntu下做的,直接复制粘贴,想来这怎么会出事,全部搞完了,装上7.04(因为没解决amsn的问题,就先不升级了),最后打开移动盘上的文件,傻眼了

看起来只是文件名全乱了码,普通记事本里的中文内容还是能显示的,没想出原因,估计是在复制过程中的编码出错。因为在移动硬盘上建立中文文件名能在windows下正常显示,反之亦然,唯一只有在错在复制过程了,而笔记本上原本mount的是c盘d盘,vfat,也可以直接起中文名,复制粘贴也没问题。现在重现不了这问题,自己对linux编码没什么了解,猜是编码没用utf-8,乱码的样子像是用了gb18030,因为我在英文环境下打开了一个文件,显示乱码,切换到中文环境显示正常,把文件重新存成gb2312或utf-8在英文下就能正常看到,也许是存进移动的时候用了gb18030吧,这码还这没见过

。。。那么多中文目录要我一一过目重起名了


附件:
snapshot1.jpg
snapshot1.jpg [ 167.36 KiB | 被浏览 371 次 ]

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-10-21 22:53 
头像

注册: 2007-03-13 17:26
帖子: 2254
送出感谢: 0 次
接收感谢: 1
mount -o iocharset=???,codepage=???


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-10-22 19:43 

注册: 2007-09-19 22:30
帖子: 76
地址: Shanghai
送出感谢: 0 次
接收感谢: 0 次
不清楚和mount有没有关系,原本是好的,因为mount是自动的,以前也没发生过建个中文目录在windows下看不到的事,现在移动盘里的文件在windows下也是乱码。
:(


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-10-22 20:43 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
试试这些参数吧。cp936这样的。man mount


_________________
● 鸣学


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译