当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]无法显示ntfs分区中中文文件名的文件及文件夹(已解决)
帖子发表于 : 2007-11-05 14:43 

注册: 2007-11-05 14:25
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
新手! 刚刚安装了ubuntu7.10 amd64
在英文环境下,挂载的windows ntfs分区里的中文文件名的文件及文件夹全都不显示.不是乱码,而是文件压根就不显示.
切换到中文环境下,故障依旧!
还请大虾们帮帮忙! 多谢!!


最后由 qdwht 编辑于 2007-12-06 9:40,总共编辑了 3 次

页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-11-05 22:17 

注册: 2005-12-06 15:49
帖子: 174
送出感谢: 0 次
接收感谢: 0 次
以前用 ntfs-3g 的时候碰到过类似的问题,查 ntfs-3g 的FAQ,说是因为 locale 不对,解决的办法是在 fstab 配置的时候加上正确的 locale。也许你可以参考一下


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-11-07 1:16 

注册: 2007-11-05 14:25
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
多谢_tsaichin!
我先是在/etc/fstab 中添加locale=zh_CN.utf8,重起动后没效果 :? 不知什么地方不对。
后来在网上搜到还可以安装ntfs-config,用它来设定。问题解决了!
不过 在fstab中看了一下,变成了locale=en_US.UTF-8 :shock:


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-11-08 1:56 

注册: 2007-10-26 15:23
帖子: 65
送出感谢: 0 次
接收感谢: 0 次
sigh,楼主,我和你的问题一样

不过我的问题更郁闷
我装了nftfs-3g和ntfs-config,配置好之后重启第一次似乎是有效果,可以显示中文文件 和中文文件夹
但后来重启之后又不行了

每次启动之后都得umouont -a再mount -a才能显示 挂载的分区中的中文文件,郁闷,头大
试过好几种办法都不行。。。。 :roll:


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2007-11-27 13:49 

注册: 2007-09-21 16:42
帖子: 100
送出感谢: 0 次
接收感谢: 0 次
还没有解决么,俺们也有相同的问题
期待ing


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2007-11-27 14:07 
头像

注册: 2006-10-27 18:15
帖子: 154
送出感谢: 0 次
接收感谢: 0 次
我也有这个问题,晚上关注下


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-11-27 17:03 
头像

注册: 2007-11-04 12:13
帖子: 52
地址: 深圳
送出感谢: 0 次
接收感谢: 0 次
怎么装?
说详细一些啊!本人对电脑 不是很熟


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2007-11-27 23:22 

注册: 2007-11-05 14:25
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
:cry: 今天机器突然不好用了,中文文件名的文件又在ntfs分区消失了!!!
而且应用程序上的菜单栏上的字也变成超小的字体!!!


附件:
Screenshot.png
Screenshot.png [ 75.3 KiB | 被浏览 904 次 ]

页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2007-12-06 9:39 

注册: 2007-11-05 14:25
帖子: 24
送出感谢: 0 次
接收感谢: 0 次
刚刚听说了一种解决办法。
编辑/etc/fstab文件,把ntfs分区放到/usr之后挂载即可。实在搞不清楚的可以把 ntfs放到最后挂载。
修改时要以root权限更改。


附件:
Screenshot-经典 - File Browser.png
Screenshot-经典 - File Browser.png [ 69.3 KiB | 被浏览 848 次 ]

页首
 用户资料  
 
10 楼 
 文章标题 : 自动挂载NTFS
帖子发表于 : 2007-12-12 22:22 
头像

注册: 2007-09-23 17:06
帖子: 1051
送出感谢: 1
接收感谢: 8
nfts-config可以说是基于ntfs-3g的一个自动化程序吧! 假如你也有NTFS的分区,那么赶紧装上这个吧!

在终端下输入:

$ sudo apt-get install ntfs-config


把它安装好以后,去“应用程序”“系统工具”里面去找,中文名是“NTFS写入支持配置程序”。

就可以解决中文文件名的问题,我试了,超爽!

打开它后只有几个按钮和两个选择,分别是用于支持外部设备(移动硬盘等)和内部设备(本地硬盘),根据自己需要,勾上,然后确定。完了!就这样,去NTFS分区干你想干的吧!原文引自
http://linuxdesktop.cn/2007/04/26/use-n ... g-in-feist[/img]


附件:
文件注释: ntfs-config
ntfs-config1.jpg
ntfs-config1.jpg [ 26.93 KiB | 被浏览 774 次 ]

页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2007-12-13 12:34 
头像

注册: 2007-09-23 17:06
帖子: 1051
送出感谢: 1
接收感谢: 8
qdwht 写道:
多谢_tsaichin!
我先是在/etc/fstab 中添加locale=zh_CN.utf8,重起动后没效果 :? 不知什么地方不对。
后来在网上搜到还可以安装ntfs-config,用它来设定。问题解决了!
不过 在fstab中看了一下,变成了locale=en_US.UTF-8 :shock:


的方法是行的,我也遇到了类似的问题,装上NTFS-config后,也是立竿见影的,但是重启一下后,就又不行了,但是用了
sudo gedit /etc/fstab
然后把 locale=zh_CN.utf8 添在首行重启即可!
不知什么原因?有知道的,告知一下了!


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-05-11 12:00 

注册: 2007-12-31 15:21
帖子: 11
送出感谢: 0 次
接收感谢: 0 次
安装了NTFS-confg,在/etc/fstab最前面增加了locale=zh_CN.utf8都没有解决问题!

最后使用9楼的朋友的方法解决了该问题!


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-05-12 1:00 
头像

注册: 2006-07-03 9:12
帖子: 270
送出感谢: 0 次
接收感谢: 0 次
晒晒我的/etc/fstab:


/dev/sda1 /mnt/sda1 ntfs-3g silent,locale=zh_CN.utf8,umask=0,exec,nonempty 0 0
/dev/sda5 /mnt/sda5 ntfs-3g silent,locale=zh_CN.utf8,umask=0,exec,nonempty 0 0
/dev/sda6 /mnt/sda6 ntfs-3g silent,locale=zh_CN.utf8,umask=0,exec,nonempty 0 0
/dev/sda7 /mnt/sda7 vfat utf8,umask=0,exec 0 0


仅供参考!!!


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译