当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求助:Ubuntu下编辑的文本到windows下是乱码
帖子发表于 : 2008-01-03 18:36 

注册: 2007-10-08 11:56
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
Ubuntu下编辑的文本到windows下是乱码,同样windows下编辑的文本到Ubuntu下也是乱码,知道为什么,还请帮忙。

~$ locale
LANG=zh_CN.UTF-8
LC_CTYPE="zh_CN.UTF-8"
LC_NUMERIC="zh_CN.UTF-8"
LC_TIME="zh_CN.UTF-8"
LC_COLLATE="zh_CN.UTF-8"
LC_MONETARY="zh_CN.UTF-8"
LC_MESSAGES="zh_CN.UTF-8"
LC_PAPER="zh_CN.UTF-8"
LC_NAME="zh_CN.UTF-8"
LC_ADDRESS="zh_CN.UTF-8"
LC_TELEPHONE="zh_CN.UTF-8"
LC_MEASUREMENT="zh_CN.UTF-8"
LC_IDENTIFICATION="zh_CN.UTF-8"
LC_ALL=


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2008-01-03 19:07 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
用什么编辑


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2008-01-03 19:10 

注册: 2007-10-08 11:56
帖子: 20
送出感谢: 0 次
接收感谢: 0 次
ubuntu: gedit
window: 记事本,和写字板。


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2008-01-03 19:17 
头像

注册: 2006-07-02 11:16
帖子: 12522
地址: 廣州
送出感谢: 0 次
接收感谢: 8
helicopter 写道:
ubuntu: gedit
window: 记事本,和写字板。


怎么个乱码法
尝试打开文件时指定编码UTF-8或GBK


_________________
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2008-01-03 20:18 
头像

注册: 2007-12-03 9:54
帖子: 943
送出感谢: 0 次
接收感谢: 0 次
BigSnake.NET 写道:
helicopter 写道:
ubuntu: gedit
window: 记事本,和写字板。


怎么个乱码法
尝试打开文件时指定编码UTF-8或GBK

这样应该能够解决


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2008-01-05 10:30 

注册: 2008-01-04 19:56
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
记事本对于编码支持方面太弱,建议换用第三方记事本工具,如Notepad++、EmEditor(商业软件)等。


页首
 用户资料  
 
7 楼 
 文章标题 : 我也正为同样的问题烦恼
帖子发表于 : 2008-06-08 11:23 

注册: 2008-05-29 11:32
帖子: 65
送出感谢: 0 次
接收感谢: 0 次
我也正为同样的问题烦恼


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2008-06-08 11:34 
头像

注册: 2007-12-31 14:57
帖子: 1097
送出感谢: 0 次
接收感谢: 1
编码问题,记事本就用来记事好了,用浏览器打开,切换编码,再在复制回去,要么就在Ubuntu保存是保存为GBK编码


页首
 用户资料  
 
9 楼 
 文章标题 : 我的解决了,方法如下:
帖子发表于 : 2008-06-08 11:55 

注册: 2008-05-29 11:32
帖子: 65
送出感谢: 0 次
接收感谢: 0 次
ubuntu8打开文本(XP下面建立的文本文件)内容是乱码,但文件名称也是中文却不乱码(我比较喜欢用英文界面,但是我很多文本文件又都是中文的(GBK)编码,每次双击打开,gedit都显示乱码)。解决方法:

配置gedit的默认编码方式:
用Configuratio Editor (命令:gconf-editor),修改app->gedit-2->preferences->encoding中的auto_detected, 把GBK加入里面并放到最前面即可。当然也可以加入别的编码,例如:GB18030,等

你可以试一试。


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2008-06-08 22:19 
头像

注册: 2006-07-23 20:27
帖子: 484
送出感谢: 0 次
接收感谢: 0 次
把ubuntu的系统改为GBK的locale就是了
一了百了

干嘛非要用utf8 在中国兼容性太差了 很多网页链接下来都是乱码文件名
改为gbk后 一点问题也不会出的 系统运行很稳定


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2008-06-08 22:21 
头像

注册: 2007-11-22 10:20
帖子: 3406
地址: 北京
送出感谢: 0 次
接收感谢: 1
paulcross 写道:
把ubuntu的系统改为GBK的locale就是了
一了百了

干嘛非要用utf8 在中国兼容性太差了 很多网页链接下来都是乱码文件名
改为gbk后 一点问题也不会出的 系统运行很稳定
到底是谁的兼容性不好呀……


_________________
lenovo Thinkpad R60i 0657 LHC
windowsXP……准备换回ubuntu了。

Twitter: @carbont


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2008-06-08 22:27 
头像

注册: 2006-07-23 20:27
帖子: 484
送出感谢: 0 次
接收感谢: 0 次
谁的乱码少 谁的兼容性好

在中国还是用GBK的多
这点和ooo与office的关系差不多

事实标准才是真标准


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2008-06-08 22:59 
头像

注册: 2007-05-06 2:46
帖子: 15634
送出感谢: 0 次
接收感谢: 2
一直用UTF-8

那来乱码,回车位呈黑块倒是有


用写字板转一下就好了


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译