ubuntu 8.04 的一个小问题

系统错误报告和讨论
回复
头像
lovekid
帖子: 554
注册时间: 2007-03-05 11:43
送出感谢: 1 次
接收感谢: 1 次
联系:

ubuntu 8.04 的一个小问题

#1

帖子 lovekid » 2008-04-27 16:31

昨天怀着激动的心情安装了ubuntu 8.04,8.04果然没有让我失望,成功的解决了我的笔记本所有的问题,正当我高兴的时候,一个小意外发生了,由于用mplayer(源里的最新版本)播放rmvb影片时突然死机,具体什么原因我也不清楚,但死机时的表现是:mplayer的视频窗口刚刚调整到影片的默认分辨率,就锁死不动了,整个视频窗口一片蓝,其他的程序也不能响应,ctrl+alt+backspace也没反应。无奈之下,只好长按电源,强制关机。再次开机,问题出现了,从grub选择ubuntu进入系统,屏幕出现starting up…… 后,就开始报错,提示:

Undefined video mode : 2f6

然后提示什么 输入 scan 查找 所有视频模式,按空格键继续,要不然就等待三十秒钟(原文是英文的,大体就这个意思)

我反复重启电脑,把上面的三种选择挨个试了一遍,第一种选择,电脑给我列出了七种视频模式(0~6),我选择了第0种和第6种模式试了一下,确实不一样,0可以正常工作二6则把屏幕“压”扁了,但无论选择哪种模式,进入图形界面后,都恢复正常,第二种选择,按空格后机器正常工作,第三种选择,三十秒后正常启动。
但无论怎么弄,电脑就是不能记住正确的选择,每次开机都得安空格,要不就得等三十秒。

所以很奇怪,这是不是一个BUG,某些代码错误的改写了视频模式,而又没有及时保存,最终导致我在非正常关机时配置没有被正确保存

MPlayer 1.0rc2-4.2.3
mplayer 视频输出: xv X11/Xv
gnome V 2.22.1

以上是凭记忆写的,今天发现有点不对,直接把图片传上来
附件
IMG0318A.jpg
上次由 lovekid 在 2008-04-29 21:26,总共编辑 1 次。
YuQmt
帖子: 3
注册时间: 2008-04-24 10:24
送出感谢: 0
接收感谢: 0

#2

帖子 YuQmt » 2008-04-29 11:10

:lol: 我装了8.04后也经常死机, 我猜可能是显卡驱动的原因.
donghong82
帖子: 6
注册时间: 2008-04-28 9:00
送出感谢: 0
接收感谢: 0

#3

帖子 donghong82 » 2008-04-29 13:35

中文环境中替换Scim为fctix
头像
星s
帖子: 40
注册时间: 2007-09-27 20:36
来自: 哈尔滨
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 星s » 2008-05-23 11:09

我的问题和lz类似。但我不是播放器的问题,我到现在还没有安装mplayer之类的。
也是一开机出现那些。但我的按空格可略过。
我手动装了驱动,驱动成功,但开机后问题依旧。
头像
hongmop
帖子: 37
注册时间: 2007-05-12 7:06
来自: china
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 hongmop » 2008-06-08 21:51

我今天开机也遇到相似的问题。今天下午最后一次关机,我选择的是休眠,之后出去吃饭了,回来开机时就出现这种问题:starting up 不动了
fnsoxt
帖子: 2
注册时间: 2007-04-29 17:19
送出感谢: 0
接收感谢: 0

#6

帖子 fnsoxt » 2008-06-25 17:53

我的也一直死机啊,现在怀疑是网卡或者是电源管理的问题。我的是全新的安装,但是保留了个人的设置。为什么什么这样?我还是把所有的配置删除吧
sinareal
帖子: 2
注册时间: 2008-05-03 23:21
送出感谢: 0
接收感谢: 0

undefined video mode number

#7

帖子 sinareal » 2008-06-27 16:15

我也出现过类似的问题,是number:318
解决方法是:
sudo gedit /boot/grub/menu.lst
打开后,找到 vga=791(也可能是其他数字),改成 vga=normal
保存后重启就可以了

我是查到这篇文章解决问题的:http://blog.edirectories.info/2008/04/h ... in-ubuntu/
回复

回到 “Ubuntu错误报告”