[其它]Ubuntu的声音问题!

系统错误报告和讨论
回复
alertsniper
帖子: 296
注册时间: 2007-09-22 21:49
送出感谢: 3 次
接收感谢: 0
联系:

[其它]Ubuntu的声音问题!

#1

帖子 alertsniper » 2008-05-26 17:59

以前有人提过Ubuntu8.04的声音问题,不过这个不一样,以前是不能同时输出两个以上的声音,现在升级后没有了这个问题,不过现在又有一个问题了~
症状如下:
当一个程序同时播放几个声音文件时(我说的是Firefox看几个网络视频时),声音没有问题,但是这时其他的播放软件不能播放声音!如果一个程序播放了含有声音的文件时,其他程序不能播放声音!而且在这个播放声音程序没有退出时,其他程序不能播放声音,需要退出其他程序才行!
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 BigSnake.NET » 2008-05-26 18:06

声音后端统统选 alsa , 不能设的用 aoss 启动
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
alertsniper
帖子: 296
注册时间: 2007-09-22 21:49
送出感谢: 3 次
接收感谢: 0
联系:

#3

帖子 alertsniper » 2008-05-26 20:19

这是.....没有设错吧~
附件
Screenshot-声音首选项.png
alertsniper
帖子: 296
注册时间: 2007-09-22 21:49
送出感谢: 3 次
接收感谢: 0
联系:

#4

帖子 alertsniper » 2008-05-29 17:25

问题是....我的设置本来就是那么设置的~也不应该会有这种问题阿!
alertsniper
帖子: 296
注册时间: 2007-09-22 21:49
送出感谢: 3 次
接收感谢: 0
联系:

#5

帖子 alertsniper » 2008-05-30 18:29

惊讶的发现....只有firefox打开含有声音的网页时才会让其他播放器无法工作~
头像
Angevil
帖子: 9
注册时间: 2007-04-23 21:56
来自: 火星
送出感谢: 0
接收感谢: 0

#6

帖子 Angevil » 2008-06-04 4:52

别设置成“自动选择”,全部选定 ALSA。
ASUS M2NC51PV
liuke.forever
帖子: 102
注册时间: 2008-05-28 14:14
送出感谢: 0
接收感谢: 0

#7

帖子 liuke.forever » 2008-06-10 8:29

alertsniper 写了:惊讶的发现....只有firefox打开含有声音的网页时才会让其他播放器无法工作~
1,在主音量控制里的设备要选为Alsa,应该8.04默认的就是Alsa
2,要把软件的声音输出设备改为Alsa,比如Mplayer,Amarok的声音输出设备改为Asla,因为这些软件的默认声音输出
设备不是Asla
所以此问题的关键还是Asla,因该采用Asla是可以解决声卡独占问题的。
dingxu887
帖子: 4
注册时间: 2008-09-20 17:58
送出感谢: 0
接收感谢: 0

Re:

#8

帖子 dingxu887 » 2008-09-24 10:05

liuke.forever 写了:
alertsniper 写了:惊讶的发现....只有firefox打开含有声音的网页时才会让其他播放器无法工作~
1,在主音量控制里的设备要选为Alsa,应该8.04默认的就是Alsa
2,要把软件的声音输出设备改为Alsa,比如Mplayer,Amarok的声音输出设备改为Asla,因为这些软件的默认声音输出
设备不是Asla
所以此问题的关键还是Asla,因该采用Asla是可以解决声卡独占问题的。
把所有的都调成了asla 但是浏览网页是播放了声音文件其他播放器就都没有声音了。。
firefox的怎么改阿 !!1
lxyd060
帖子: 10
注册时间: 2008-11-06 16:54
送出感谢: 0
接收感谢: 0

Re: [其它]Ubuntu的声音问题!

#9

帖子 lxyd060 » 2008-11-12 5:53

我的在用8。04,开始没意识到这个问题,后来无意打开视频网站竟然发现是没有声音的,当时开着音乐,后来验证电影与音乐也是无法同时输出声音的。搜索一下才知道只有一个程序可以运行声音,其他的成哑巴了。不过现在成功解决了。
具体是怎么回事我也太了解,貌似系统没有开启所有的声音设置,尤其是多路声音无法共存,每个人遇到的问题可能不太一样,不能解决的可以跟我交流下,个人是新手,更希望能与大家多多交流。。。
yrelle
帖子: 7
注册时间: 2009-03-20 10:51
送出感谢: 0
接收感谢: 0

Re: [其它]Ubuntu的声音问题!

#10

帖子 yrelle » 2009-03-20 10:58

症状与各位类似, 都是突然发作, 再无法扭转——无论 firefox 播放 youtube 与其他多媒体软件占用音频冲突... 其他多媒体软件间无冲突.

声音设置已全部更改为ALSA.

==========================================
具体是怎么回事我也太了解,貌似系统没有开启所有的声音设置,尤其是多路声音无法共存,每个人遇到的问题可能不太一样,不能解决的可以跟我交流下,个人是新手,更希望能与大家多多交流。。。
mao99mi
帖子: 5
注册时间: 2009-04-17 21:42
送出感谢: 0
接收感谢: 0

Re: [其它]Ubuntu的声音问题!

#11

帖子 mao99mi » 2009-04-18 19:49

主系统是vista系统 ,后装的ubuntu。
声卡是NVidia [HDA NVdia] AD198* Analog、AD198*Digital 、si3054 Modem
在Vista中,只显示Analog Digital都显示正常,但是测试的时候Digital没有声音。

在ubuntu中,突然冒出来一个si3054 Modem都不知道从哪里来的?!
是用终端aplay ~l 查看的。

现在设置如下:还是没反应,只是播放声音的时候会有吱吱的声音。
清大家帮忙下,可能要重启下不,偶设置网络连接的时候就关机后开机才可以。。。

前面的几个均选择ALSA-高级 Linux声音构架,下面的默认混音器选择 设备:HDA NVidia(alsa mixer)
在音量控制器首选项选择的是HDA NVidia(alsa mixer)
附件
Screenshot-1.png
头像
wuhezhong
帖子: 111
注册时间: 2010-04-03 18:10
送出感谢: 0
接收感谢: 0

Re: [其它]Ubuntu的声音问题!

#12

帖子 wuhezhong » 2010-04-10 9:14

在新德里软件里删除这个pulseaudio果真可以解决网页视频没有声音的问题。并且本机播放音乐也有声音。
我问佛:为何不给所有女子羞花闭月的容颜?
佛曰:那只是昙花的一现,用来蒙蔽世俗的眼
—————---/´ ¯/)
—————--/—-/
—————-/—-/
———--/´¯/'--'/´¯`•_
———-/'/--/—-/—--/¨¯\
——--('(———- ¯~/'--')
———\————-'—--/ 各类计算机在线书籍下载和在线浏览站点------->ppurl.com ------>首页下方有标签!
———-'\'————_-•´
————\———--(
回复

回到 “Ubuntu错误报告”