2.6.15-23内核没有声音

系统错误报告和讨论
头像
renex
帖子: 269
注册时间: 2006-04-29 21:45
来自: Shanghai
送出感谢: 0
接收感谢: 0

2.6.15-23内核没有声音

#1

帖子 renex » 2006-05-20 23:32

2.6.15-22有

硬件是Dell 510M

intel 82801的集成声卡
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-05-20 23:40

吓人,和内核无关吧。
● 鸣学
头像
renex
帖子: 269
注册时间: 2006-04-29 21:45
来自: Shanghai
送出感谢: 0
接收感谢: 0

#3

帖子 renex » 2006-05-21 1:09

eexpress 写了:吓人,和内核无关吧。
目前现象就是23内核没有声音,22内核有
有啥建议可以检测一下具体是什么原因没有声音?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#4

帖子 eexpress » 2006-05-21 14:08

只会

代码: 全选

$ lsmod |grep snd
snd_intel8x0           35964  0
snd_ac97_codec         99808  1 snd_intel8x0
snd_ac97_bus            2400  1 snd_ac97_codec
snd_pcm_oss            56448  0
snd_mixer_oss          20544  1 snd_pcm_oss
snd_pcm                96644  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              26884  1 snd_pcm
snd                    60004  6 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              10784  1 snd
snd_page_alloc         11304  2 snd_intel8x0,snd_pcm
比较加载了的模块。其他方法不会了。
● 鸣学
头像
renex
帖子: 269
注册时间: 2006-04-29 21:45
来自: Shanghai
送出感谢: 0
接收感谢: 0

#5

帖子 renex » 2006-05-22 15:00

23

代码: 全选

snd_intel8x0           35740  1
snd_ac97_codec         99808  1 snd_intel8x0
snd_ac97_bus            2400  1 snd_ac97_codec
snd_pcm_oss            56448  0
snd_mixer_oss          20544  1 snd_pcm_oss
snd_pcm                96676  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              26884  1 snd_pcm
snd                    60004  8 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              10784  1 snd
snd_page_alloc         11304  2 snd_intel8x0,snd_pcm
22

代码: 全选

snd_intel8x0           35932  2
snd_ac97_codec         99808  1 snd_intel8x0
snd_ac97_bus            2400  1 snd_ac97_codec
snd_pcm_oss            56448  0
snd_mixer_oss          20544  1 snd_pcm_oss
snd_pcm                96644  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              26884  1 snd_pcm
snd                    60004  10 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              10784  1 snd
snd_page_alloc         11304  2 snd_intel8x0,snd_pcm
头像
renex
帖子: 269
注册时间: 2006-04-29 21:45
来自: Shanghai
送出感谢: 0
接收感谢: 0

#6

帖子 renex » 2006-05-22 15:12

还是看不出为什么没声音,看样子这个问题比较复杂
头像
lwtong
帖子: 15
注册时间: 2006-05-22 16:37
送出感谢: 0
接收感谢: 0

我的声音也没有

#7

帖子 lwtong » 2006-05-22 17:52

那个大虾知道啊! 急急 ubuntu 2.6.15-23-386的
头像
lwtong
帖子: 15
注册时间: 2006-05-22 16:37
送出感谢: 0
接收感谢: 0

#8

帖子 lwtong » 2006-05-22 18:10

ubuntu难道就这么难用??????????, :cry: 分辨率也那么难调.
(1) 公社的magic linux 2.0
http(lupa):
http://mirror.lupaworld.com/magiclinux/2.0/
(2)红旗5
http://www.redflag-linux.com/xiazai/xiazai.php?id=1405
就没有那么多的问题.
头像
renex
帖子: 269
注册时间: 2006-04-29 21:45
来自: Shanghai
送出感谢: 0
接收感谢: 0

#9

帖子 renex » 2006-05-22 18:44

lwtong 写了:ubuntu难道就这么难用??????????, :cry: 分辨率也那么难调.
(1) 公社的magic linux 2.0
http(lupa):
http://mirror.lupaworld.com/magiclinux/2.0/
(2)红旗5
http://www.redflag-linux.com/xiazai/xiazai.php?id=1405
就没有那么多的问题.

每个人都可以挑选自己喜欢的来用,那东西不一定是最好的
头像
lwtong
帖子: 15
注册时间: 2006-05-22 16:37
送出感谢: 0
接收感谢: 0

回上面的主题

#10

帖子 lwtong » 2006-05-22 19:09

就因为不是最好的才有学习的动力.
好的人不就难得动手了 :oops:
图片
头像
renex
帖子: 269
注册时间: 2006-04-29 21:45
来自: Shanghai
送出感谢: 0
接收感谢: 0

#11

帖子 renex » 2006-05-26 16:17

就没人处理一下?

最新的2.6.15-23.39一样没有声音
lookee
帖子: 141
注册时间: 2005-09-09 18:13
送出感谢: 0
接收感谢: 0

#12

帖子 lookee » 2006-05-26 19:05

嗯,我也发现了,用22的内核是有声音的
给我一个支点,我可以撬起地球仪!
Ubuntu Edgy Eft
Thinkpad T60
T2300(1.66G) 512M(667MHz) X1300(64M) 60G
头像
renex
帖子: 269
注册时间: 2006-04-29 21:45
来自: Shanghai
送出感谢: 0
接收感谢: 0

#13

帖子 renex » 2006-05-29 10:30

我很苦恼呀
pingyz
帖子: 13
注册时间: 2006-05-17 18:40
送出感谢: 0
接收感谢: 0

Re: 2.6.15-23内核没有声音

#14

帖子 pingyz » 2006-05-29 18:07

我的情况(供参考):我以前用FC4的时候,也是这种情况,从2.6.14升级到2.6.15时就是没有声音。而在升级以前好好的;另外,网卡在2.6.15启动时也无法获得IP地址,升级以前没有任何问题的。我也感觉是这个内核改了什么东西。
而且后来在FC4下升级到更新的内核(似乎是2.6.16?忘记了),也是这种情况。
嗯,我就是因为这个原因脱离FC家族,转到ubuntu家族来的。
机器配置:Intel845GL主板集成声卡显卡,网卡Realtek8039
renex 写了:2.6.15-22有

硬件是Dell 510M

intel 82801的集成声卡
alteeno
帖子: 254
注册时间: 2006-01-18 18:11
送出感谢: 0
接收感谢: 0

看来这个问题比较棘手。

#15

帖子 alteeno » 2006-06-05 9:37

官网上也有人反映这个问题,但还没有解决方案。
回复

回到 “Ubuntu错误报告”