当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 14 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 8.10下,eclipse无法识别Scanner
帖子发表于 : 2008-12-13 17:26 

注册: 2008-12-08 23:00
帖子: 21
送出感谢: 0 次
接收感谢: 0 次
如题,做了如下测试,请过目。
import java.util.*;
public class Test {
public static void main(String[] args) {
Scanner input = new Scanner (System.in);
System.out.print("请输入: ");
String a = input.next();
System.out.print(a);
}
}

就是这几行代码,无法通过编译,提示如下:
Exception in thread "main" java.lang.Error: Unresolved compilation problems:
Scanner cannot be resolved to a type
Scanner cannot be resolved to a type

开始以为是少了jdk,在新立德里找到了jdk6,安装后,结果还是一样,实在是没有办法了,到社区求助,麻烦各位帮忙分析一下吧。。。 :em19


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 8.10下,eclipse无法识别Scanner
帖子发表于 : 2008-12-13 17:51 

注册: 2008-12-08 23:00
帖子: 21
送出感谢: 0 次
接收感谢: 0 次
自己顶阿。。


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 8.10下,eclipse无法识别Scanner
帖子发表于 : 2008-12-13 18:15 

注册: 2008-12-08 23:00
帖子: 21
送出感谢: 0 次
接收感谢: 0 次
:em20 :em20 :em20


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 8.10下,eclipse无法识别Scanner
帖子发表于 : 2008-12-13 18:22 

注册: 2008-12-08 23:00
帖子: 21
送出感谢: 0 次
接收感谢: 0 次
救命阿。。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 8.10下,eclipse无法识别Scanner
帖子发表于 : 2008-12-15 16:19 
头像

注册: 2007-03-13 17:26
帖子: 2254
送出感谢: 0 次
接收感谢: 1
jdk 有问题吧


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 8.10下,eclipse无法识别Scanner
帖子发表于 : 2009-01-19 14:41 
头像

注册: 2009-01-14 15:35
帖子: 39
送出感谢: 0 次
接收感谢: 0 次
bdpaylm 写道:
如题,做了如下测试,请过目。
import java.util.*;
public class Test {
public static void main(String[] args) {
Scanner input = new Scanner (System.in);
System.out.print("请输入: ");
String a = input.next();
System.out.print(a);
}
}

就是这几行代码,无法通过编译,提示如下:
Exception in thread "main" java.lang.Error: Unresolved compilation problems:
Scanner cannot be resolved to a type
Scanner cannot be resolved to a type

开始以为是少了jdk,在新立德里找到了jdk6,安装后,结果还是一样,实在是没有办法了,到社区求助,麻烦各位帮忙分析一下吧。。。 :em19

我和你一样的问题阿Scanner cannot be resolved to a type
Scanner cannot be resolved to a type


_________________
linux从此开始@喝着酒晒太阳~~~


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 8.10下,eclipse无法识别Scanner
帖子发表于 : 2009-02-10 1:13 

注册: 2009-01-10 19:33
帖子: 38
送出感谢: 0 次
接收感谢: 0 次
同问,如果不能解决的话,用bufferedreader太麻烦了。


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 8.10下,eclipse无法识别Scanner
帖子发表于 : 2009-04-05 15:04 

注册: 2009-04-05 11:55
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
我也是这样的问题阿 要怎么解决阿


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 8.10下,eclipse无法识别Scanner
帖子发表于 : 2009-04-14 16:20 

注册: 2009-04-04 9:25
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
是啊~我也这样 咋解决 没人说么


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 8.10下,eclipse无法识别Scanner
帖子发表于 : 2009-05-06 12:25 
头像

注册: 2009-04-04 11:57
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
就是呀,有没有解决方法呀?


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 8.10下,eclipse无法识别Scanner
帖子发表于 : 2009-05-06 20:51 
头像

注册: 2009-04-04 11:57
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
ok ,now i have find the solution to solve this problem.
At first ,you should adjust your system to use the higher version jdk,so you should enter these codes:

Codes:
sudo update-java-alternatives -s java-6-sun

Then you should go into eclipse
->window
->preferences
->java
->installed jres
now click add

select stanard vm if that pops up not sure if that will be in your version of eclipse

click browse
go to /usr/lib/jvm/The Appropriate One Probably java-6-sun-1.6.0.10 or similar/

Then just make sure you deselect the other JREs and only have this one selected


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 8.10下,eclipse无法识别Scanner
帖子发表于 : 2009-07-30 11:02 
头像

注册: 2009-07-23 22:22
帖子: 51
送出感谢: 0 次
接收感谢: 0 次
谢谢11楼的兄弟,我开始也猜测是jdk,jre版本不匹配,但不知怎么弄~ :em06


_________________
Back to Fedora from Archlinux...
吾辈乃水人一枚,潜水日久。


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 8.10下,eclipse无法识别Scanner
帖子发表于 : 2009-10-26 23:35 

注册: 2009-09-23 20:44
帖子: 5
送出感谢: 0 次
接收感谢: 0 次
同样 问题,netbeans正常


页首
 用户资料  
 
14 楼 
 文章标题 : Re: 8.10下,eclipse无法识别Scanner
帖子发表于 : 2009-10-31 20:24 

注册: 2008-04-07 15:13
帖子: 25
送出感谢: 0 次
接收感谢: 0 次
我猜你是不是用了GIJ
试试sun-java-jre


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 14 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译