当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : how to deal with broken dependencies as follows
帖子发表于 : 2009-03-21 1:32 

注册: 2009-03-21 1:22
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
An unresolvable problem occurred while initializing the package information.

Please report this bug against the 'update-manager' package and include the following error message:

'E:错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。'



you have 2 broken packages on your system!

Use the "Broken" filter to locate them.


Could not apply changes!
Fix broken packages first


下列的软件包有不能满足的依赖关系:
libperl5.10: 依赖: perl-base (= 5.10.0-11.1ubuntu2) 但是 5.10.0-19 已经安装了
perl: 依赖: perl-base (= 5.10.0-11.1ubuntu2) 但是 5.10.0-19 已经安装了
E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: how to deal with broken dependencies as follows
帖子发表于 : 2009-03-21 20:36 

注册: 2009-03-21 1:22
帖子: 3
送出感谢: 0 次
接收感谢: 0 次
:em06 我用的是Ubuntu8.10 由于使用学校校园网,网络配置出现了一点问题,一直不能上网,在windows下下载了软件包,安装时就出现了以上情况。apt-get install -f ,无法解决问题。dpkg 不大会用,也解决不了。请教高手帮忙指点一下。谢谢!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: how to deal with broken dependencies as follows
帖子发表于 : 2010-11-21 10:40 

注册: 2008-10-13 8:52
帖子: 43
送出感谢: 0 次
接收感谢: 0 次
网上很多人遇到这个问题阿,
求解决方法阿!!!


_________________
benry
tojingpeng@gmail.com


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译